bokeh-server app is just a blank page

I copied all the elements from the sliders and stocks examples. But for some reason nothing is showing up besides the “link to this” text. I can’t even find any differences between my app and the working stocks app when browsing through Sources in Chome’s developer console. I am getting desperate at this point. Why is nothing showing up for me?

Here’s the script I’m working on. There’s supposed to be an infrastructure to load data from files but for now I added some dummy config values and a dummy Plot.line call.

In the rest of the repo you can see my previous, aborted attempt (before I saw the app examples).

Appreciate any help, or even guesses as to things to try.

To top off the frustration, someone posted a StackOverflow question with what appears to be the same problem, only to add a comment to the effect of “nevermind, fixed it”. That’s not how Q&A sites are supposed to work.

Actually, I’m getting

Uncaught ReferenceError: build_views is not defined

in the developer console in my app, but not when I run the stocks app.

···

On Wednesday, March 4, 2015 at 7:40:48 PM UTC-5, Henry Harrison wrote:

I copied all the elements from the sliders and stocks examples. But for some reason nothing is showing up besides the “link to this” text. I can’t even find any differences between my app and the working stocks app when browsing through Sources in Chome’s developer console. I am getting desperate at this point. Why is nothing showing up for me?

Here’s the script I’m working on. There’s supposed to be an infrastructure to load data from files but for now I added some dummy config values and a dummy Plot.line call.

In the rest of the repo you can see my previous, aborted attempt (before I saw the app examples).

Appreciate any help, or even guesses as to things to try.

To top off the frustration, someone posted a StackOverflow question with what appears to be the same problem, only to add a comment to the effect of “nevermind, fixed it”. That’s not how Q&A sites are supposed to work.

and Resource interpreted as Script but transferred with MIME type text/html: “http://localhost:5006/bokeh/jsgenerate/VBox/DataPlayerApp/DataPlayerApp”.

···

On Wednesday, March 4, 2015 at 7:44:15 PM UTC-5, Henry Harrison wrote:

Actually, I’m getting

Uncaught ReferenceError: build_views is not defined

in the developer console in my app, but not when I run the stocks app.

On Wednesday, March 4, 2015 at 7:40:48 PM UTC-5, Henry Harrison wrote:

I copied all the elements from the sliders and stocks examples. But for some reason nothing is showing up besides the “link to this” text. I can’t even find any differences between my app and the working stocks app when browsing through Sources in Chome’s developer console. I am getting desperate at this point. Why is nothing showing up for me?

Here’s the script I’m working on. There’s supposed to be an infrastructure to load data from files but for now I added some dummy config values and a dummy Plot.line call.

In the rest of the repo you can see my previous, aborted attempt (before I saw the app examples).

Appreciate any help, or even guesses as to things to try.

To top off the frustration, someone posted a StackOverflow question with what appears to be the same problem, only to add a comment to the effect of “nevermind, fixed it”. That’s not how Q&A sites are supposed to work.

Well, removing the Toggle fixed the problem. So maybe there is a bug with the Toggle widget?

···

On Wednesday, March 4, 2015 at 7:46:19 PM UTC-5, Henry Harrison wrote:

and Resource interpreted as Script but transferred with MIME type text/html: “http://localhost:5006/bokeh/jsgenerate/VBox/DataPlayerApp/DataPlayerApp”.

On Wednesday, March 4, 2015 at 7:44:15 PM UTC-5, Henry Harrison wrote:

Actually, I’m getting

Uncaught ReferenceError: build_views is not defined

in the developer console in my app, but not when I run the stocks app.

On Wednesday, March 4, 2015 at 7:40:48 PM UTC-5, Henry Harrison wrote:

I copied all the elements from the sliders and stocks examples. But for some reason nothing is showing up besides the “link to this” text. I can’t even find any differences between my app and the working stocks app when browsing through Sources in Chome’s developer console. I am getting desperate at this point. Why is nothing showing up for me?

Here’s the script I’m working on. There’s supposed to be an infrastructure to load data from files but for now I added some dummy config values and a dummy Plot.line call.

In the rest of the repo you can see my previous, aborted attempt (before I saw the app examples).

Appreciate any help, or even guesses as to things to try.

To top off the frustration, someone posted a StackOverflow question with what appears to be the same problem, only to add a comment to the effect of “nevermind, fixed it”. That’s not how Q&A sites are supposed to work.

Henry,

That definitely sounds like it might be. Can you make an issue on the Bokeh GH issue tracker, so we can make sure this does not get lost?

Thanks,

Bryan

···

On Mar 5, 2015, at 10:11 AM, Henry Harrison <[email protected]> wrote:

Well, removing the Toggle fixed the problem. So maybe there is a bug with the Toggle widget?

On Wednesday, March 4, 2015 at 7:46:19 PM UTC-5, Henry Harrison wrote:
and Resource interpreted as Script but transferred with MIME type text/html: "http://localhost:5006/bokeh/jsgenerate/VBox/DataPlayerApp/DataPlayerApp".

On Wednesday, March 4, 2015 at 7:44:15 PM UTC-5, Henry Harrison wrote:
Actually, I'm getting

Uncaught ReferenceError: build_views is not defined

in the developer console in my app, but not when I run the stocks app.

On Wednesday, March 4, 2015 at 7:40:48 PM UTC-5, Henry Harrison wrote:
I copied all the elements from the sliders and stocks examples. But for some reason nothing is showing up besides the "link to this" text. I can't even find any differences between my app and the working stocks app when browsing through Sources in Chome's developer console. I am getting desperate at this point. Why is nothing showing up for me?

Here's the script I'm working on. There's supposed to be an infrastructure to load data from files but for now I added some dummy config values and a dummy Plot.line call.

In the rest of the repo you can see my previous, aborted attempt (before I saw the app examples).

Appreciate any help, or even guesses as to things to try.

To top off the frustration, someone posted a StackOverflow question with what appears to be the same problem, only to add a comment to the effect of "nevermind, fixed it". That's not how Q&A sites are supposed to work.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/e9ad63cb-2651-4330-b850-ca24bf6d788a%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.