Having bokeh automatically listen on the network ip address

Not sure why, but when I start bokeh-server it always only listens on localhost address (I have confirmed this with IT in my company and various tests on my machine and other machines). Is there any way to have it listen on the network IP address?

Thanks,

Josh

There is the "--ip" command line option to bokeh-server, are you saying this option is not working as expected?

Thanks,

Bryan

···

On Aug 29, 2014, at 2:03 PM, Josh Wasserstein <[email protected]> wrote:

Not sure why, but when I start bokeh-server it always only listens on localhost address (I have confirmed this with IT in my company and various tests on my machine and other machines). Is there any way to have it listen on the network IP address?

Thanks,

Josh

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/CAD4ivxWHLPe%3D_nL_%3De1ie6LaxU6WDpRaT3p1ByG3oT1aAzV%2BQw%40mail.gmail.com.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Additionally, if you use “–ip 0.0.0.0”, that will listen to all network interfaces on the machine.

-Peter

···

On Fri, Aug 29, 2014 at 2:05 PM, Bryan Van de Ven [email protected] wrote:

There is the “–ip” command line option to bokeh-server, are you saying this option is not working as expected?

Thanks,

Bryan

On Aug 29, 2014, at 2:03 PM, Josh Wasserstein [email protected] wrote:

Not sure why, but when I start bokeh-server it always only listens on localhost address (I have confirmed this with IT in my company and various tests on my machine and other machines). Is there any way to have it listen on the network IP address?

Thanks,

Josh

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/CAD4ivxWHLPe%3D_nL_%3De1ie6LaxU6WDpRaT3p1ByG3oT1aAzV%2BQw%40mail.gmail.com.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8B0BCB37-F71F-4711-A13A-1EE474040BF9%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Thank you Bryan and Peter. That worked. I didn’t know I had to be explicit about “0.0.0.0”. That makes sense.

Josh

···

On Fri, Aug 29, 2014 at 3:08 PM, Peter Wang [email protected] wrote:

Additionally, if you use “–ip 0.0.0.0”, that will listen to all network interfaces on the machine.

-Peter

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/CABGrp%2B8NwwpFsLjyZ56ouDFC9%3D9MeLDpyoH%3DOq1i390ryMyRXQ%40mail.gmail.com.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

On Fri, Aug 29, 2014 at 2:05 PM, Bryan Van de Ven [email protected] wrote:

There is the “–ip” command line option to bokeh-server, are you saying this option is not working as expected?

Thanks,

Bryan

On Aug 29, 2014, at 2:03 PM, Josh Wasserstein [email protected] wrote:

Not sure why, but when I start bokeh-server it always only listens on localhost address (I have confirmed this with IT in my company and various tests on my machine and other machines). Is there any way to have it listen on the network IP address?

Thanks,

Josh

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/CAD4ivxWHLPe%3D_nL_%3De1ie6LaxU6WDpRaT3p1ByG3oT1aAzV%2BQw%40mail.gmail.com.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8B0BCB37-F71F-4711-A13A-1EE474040BF9%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.