Help with fork of the project //www.github.com/Maluuba/bokeh

Hi all!!
I’m trying to run this project from GitHub i.e. a fork of the boken
github .com/Maluuba/bokeh

I have followed all the steps in the instruction but the problem is arising whenever I’m trying to do step 9 i.e.

Python setup.py install --build-js

When I run the command it is creating the error message below.

Building BokehJS… Failed.

ERROR: ‘gulp build’ returned the following

---- on stdout:

---- on stderr:
(node:24913) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.
(Use node --trace-deprecation ... to show where the warning was created)
AssertionError [ERR_ASSERTION] [ERR_ASSERTION]: Task function must be specified
at Gulp.set [as _setTask] (/home/sidharth/Documents/FigureQA/bokeh/bokehjs/node_modules/undertaker/lib/set-task.js:10:3)
at Gulp.task (/home/sidharth/Documents/FigureQA/bokeh/bokehjs/node_modules/undertaker/lib/task.js:13:8)
at Object. (/home/sidharth/Documents/FigureQA/bokeh/bokehjs/gulp/tasks/build.ts:4:6)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Module.m._compile (/home/sidharth/Documents/FigureQA/bokeh/bokehjs/node_modules/ts-node/src/index.ts:392:23)
at Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Object.require.extensions. [as .ts] (/home/sidharth/Documents/FigureQA/bokeh/bokehjs/node_modules/ts-node/src/index.ts:395:12)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.module.constructor.require (/home/sidharth/Documents/FigureQA/bokeh/bokehjs/gulpfile.js:11:29) {
generatedMessage: false,
code: ‘ERR_ASSERTION’,
actual: false,
expected: true,
operator: ‘==’
}

I have tried a few different things to solve the problem which includes following the instructions of
1.

I have also tried decreasing the version of gulp (sorry can remember the versions now ), nodejs from latest to 10, 8, 6

Not only that I have tried a few more solutions like following the instructions from the link below.
[bokeh/bokeh#7854] (github.com/bokeh/bokeh/issues/7854)

I still cannot solve the issue. Can you please help me out? Please let me know if you have any questions for me regarding the problem or
Thank you so much.

Thank you so much once again, please let me know if you have any questions for me.

@sidharthkrishan gulp was removed from the build nearly half a decade ago. If you are seeing that message then your fork is hopelessly out of date. There have been enormous changes since then, not the least of which is that all of BokehJS was ported to an entirely different language (TypeScript). Your first step should be to get your fork up to date with the latest from the main repo, so that you can follow along with the modern, detailed, up to date developer setup instructions:

If your actual intention is to be able to build a very ancient (0.12.x) version of Bokeh I am afraid I can’t be of much help. I expect that would be quite difficult and not worth the effort. If you really need to use versions that old you should stick using with old published releases, rather than trying to build from source.

Hi @Bryan !
Thank you so much for replying. The fork I’m using is not mine, it’s a Microsoft project which I’m trying to use, So, I don’t think I can update the fork. Still thank you so much for the help.

Best Regards

@sidharthkrishan It appears the project is archived (read-only, abandoned, …) Even still I don’t know why anyone would need to build BokehJS from scratch to use it. If the project needs an old version of Bokeh, then all the old releases are still published and available via both conda and pip.