How to get rid of lines in rect plots

I generate heatmaps with the rect glyph. However it seems I cannot get rid of white lines between the rectangles unless I set an a priori not logical width and height.

Below I plot a 2d gaussian distribution, the x and y axes are just indices, thus evenly spaced by 1 so using rectangles with width and height equal to 1 should fill the whole canvas without white spaces, considering I set line_alpha=0

The dilate=True option helps, but we can still see white lines between the squares.

The only way I found to not have any visible spacing between the squares is to set them larger than what seems a priori required, e.g. 1.1x1.1 instead of 1x1 with dilate=True

import numpy as np
from scipy.signal import gaussian

from import show
from bokeh.plotting import figure
from bokeh.models import LinearColorMapper, ColorBar, ColumnDataSource
from bokeh.palettes import Magma256

some data to plot

x = 10*gaussian(100,std=20)
matrix = np.matmul(x.reshape(100,1),x.reshape(1,100))
IDs = range(100)*100

source = ColumnDataSource( data={‘row’:np.array(sorted(IDs)),‘col’:np.array(IDs),‘mat’:matrix.flatten()} )

mapper = LinearColorMapper(palette=Magma256[::-1], low=10, high=90,low_color=‘grey’,high_color=‘red’)

fig = figure()



Maybe there is a better way to set width and height, or some other parameter, to prevent having any spacing between the rectangles?