JS error in CDN

Hi all,

Happy Holidays !

I’ve just upgraded to 0.7 and my plots don’t show anymore…

I’m using the CDN as source, and it seems that line 55213 has an issue, preventing the Bokeh js object to be instanciated, which eventually crashes the rendering…

			_getFormatter: function(){
if (this.options.formatter === false ||Â this.options.formatter === null){
return this._defaultFormatter;
}
return this.options.formatter;
},

the À seems strange (encoding issue?)

Cheers

Tom

Hi,

···

On Mon, Dec 29, 2014 at 11:18 AM, Thomas Lecocq [email protected] wrote:

Hi all,

Happy Holidays !

I’ve just upgraded to 0.7 and my plots don’t show anymore…

I’m using the CDN as source, and it seems that line 55213 has an issue, preventing the Bokeh js object to be instanciated, which eventually crashes the rendering…

			_getFormatter: function(){
if (this.options.formatter === false ||Â this.options.formatter === null){
return this._defaultFormatter;
}
return this.options.formatter;
},

the À seems strange (encoding issue?)

What you see is 0xA0 (nbsp) character, which was somehow introduced to our code base. This issue is present only in non-minified bokeh.js. If you use bokeh-0.7.0.min.js (as a workaround until 0.7.1), it should work fine.

Mateusz

Cheers

Tom

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/51bbd308-591d-4b5d-893b-36327cda8c0b%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Hey,

I’m instanciating the cdn directly from the python code, how can I define it to use the minified version ?

Cheers

Tom

···

Le lundi 29 décembre 2014 13:27:32 UTC+1, mateusz.paprocki a écrit :

Hi,

On Mon, Dec 29, 2014 at 11:18 AM, Thomas Lecocq [email protected] wrote:

Hi all,

Happy Holidays !

I’ve just upgraded to 0.7 and my plots don’t show anymore…

I’m using the CDN as source, and it seems that line 55213 has an issue, preventing the Bokeh js object to be instanciated, which eventually crashes the rendering…

			_getFormatter: function(){
if (this.options.formatter === false ||Â this.options.formatter === null){
return this._defaultFormatter;
}
return this.options.formatter;
},

the À seems strange (encoding issue?)

What you see is 0xA0 (nbsp) character, which was somehow introduced to our code base. This issue is present only in non-minified bokeh.js. If you use bokeh-0.7.0.min.js (as a workaround until 0.7.1), it should work fine.

Mateusz

Cheers

Tom

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected]tinuum.io.

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/51bbd308-591d-4b5d-893b-36327cda8c0b%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Thomas,

Try setting the environment variable:

  BOKEH_MINIFIED=yes

Although, it really should be using the minified sources by default, and the fact that it is not should also probably be investigated.

Bryan

···

On Dec 29, 2014, at 7:29 AM, Thomas Lecocq <[email protected]> wrote:

Hey,

I'm instanciating the cdn directly from the python code, how can I define it to use the minified version ?

Cheers

Tom

Le lundi 29 décembre 2014 13:27:32 UTC+1, mateusz.paprocki a écrit :
Hi,

On Mon, Dec 29, 2014 at 11:18 AM, Thomas Lecocq <[email protected]> wrote:
Hi all,

Happy Holidays !

I've just upgraded to 0.7 and my plots don't show anymore...

I'm using the CDN as source, and it seems that line 55213 has an issue, preventing the Bokeh js object to be instanciated, which eventually crashes the rendering...

    _getFormatter: function(){
      if (this.options.formatter === false ||Â this.options.formatter === null){
        return this._defaultFormatter;
      }

      return this.options.formatter;
    },

the À seems strange (encoding issue?)
What you see is 0xA0 (nbsp) character, which was somehow introduced to our code base. This issue is present only in non-minified bokeh.js. If you use bokeh-0.7.0.min.js (as a workaround until 0.7.1), it should work fine.

Mateusz

Cheers

Tom

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/51bbd308-591d-4b5d-893b-36327cda8c0b%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/2a41eceb-042d-4562-a27c-d9bbd6c7fd84%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Hi Bryan,

setting the env var works fine ! 0.7 it runs :slight_smile:

Tom

···

Le lundi 29 décembre 2014 18:00:08 UTC+1, Bryan Van de ven a écrit :

Thomas,

Try setting the environment variable:

    BOKEH_MINIFIED=yes

Although, it really should be using the minified sources by default, and the fact that it is not should also probably be investigated.

Bryan

On Dec 29, 2014, at 7:29 AM, Thomas Lecocq [email protected] wrote:

Hey,

I’m instanciating the cdn directly from the python code, how can I define it to use the minified version ?

Cheers

Tom

Le lundi 29 décembre 2014 13:27:32 UTC+1, mateusz.paprocki a écrit :

Hi,

On Mon, Dec 29, 2014 at 11:18 AM, Thomas Lecocq [email protected] wrote:

Hi all,

Happy Holidays !

I’ve just upgraded to 0.7 and my plots don’t show anymore…

I’m using the CDN as source, and it seems that line 55213 has an issue, preventing the Bokeh js object to be instanciated, which eventually crashes the rendering…

            _getFormatter: function(){
                    if (this.options.formatter === false ||Â this.options.formatter === null){
                            return this._defaultFormatter;
                    }
                    return this.options.formatter;
            },

the À seems strange (encoding issue?)

What you see is 0xA0 (nbsp) character, which was somehow introduced to our code base. This issue is present only in non-minified bokeh.js. If you use bokeh-0.7.0.min.js (as a workaround until 0.7.1), it should work fine.

Mateusz

Cheers

Tom


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/51bbd308-591d-4b5d-893b-36327cda8c0b%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/2a41eceb-042d-4562-a27c-d9bbd6c7fd84%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Thomas, that's great! For reference, here is the GH issue:

Thanks,

Bryan

···

On Dec 29, 2014, at 11:50 AM, Thomas Lecocq <[email protected]> wrote:

Hi Bryan,

setting the env var works fine ! 0.7 it runs :slight_smile:

Tom

Le lundi 29 décembre 2014 18:00:08 UTC+1, Bryan Van de ven a écrit :
Thomas,

Try setting the environment variable:

        BOKEH_MINIFIED=yes

Although, it really should be using the minified sources by default, and the fact that it is not should also probably be investigated.

Bryan

> On Dec 29, 2014, at 7:29 AM, Thomas Lecocq <[email protected]> wrote:
>
> Hey,
>
> I'm instanciating the cdn directly from the python code, how can I define it to use the minified version ?
>
> Cheers
>
> Tom
>
> Le lundi 29 décembre 2014 13:27:32 UTC+1, mateusz.paprocki a écrit :
> Hi,
>
> On Mon, Dec 29, 2014 at 11:18 AM, Thomas Lecocq <[email protected]> wrote:
> Hi all,
>
> Happy Holidays !
>
> I've just upgraded to 0.7 and my plots don't show anymore...
>
> I'm using the CDN as source, and it seems that line 55213 has an issue, preventing the Bokeh js object to be instanciated, which eventually crashes the rendering...
>
> _getFormatter: function(){
> if (this.options.formatter === false ||Â this.options.formatter === null){
> return this._defaultFormatter;
> }
>
> return this.options.formatter;
> },
>
>
> the À seems strange (encoding issue?)
> What you see is 0xA0 (nbsp) character, which was somehow introduced to our code base. This issue is present only in non-minified bokeh.js. If you use bokeh-0.7.0.min.js (as a workaround until 0.7.1), it should work fine.
>
> Mateusz
>
> Cheers
>
> Tom
>
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/51bbd308-591d-4b5d-893b-36327cda8c0b%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/2a41eceb-042d-4562-a27c-d9bbd6c7fd84%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/9720b427-70a1-48b4-9ff9-5cb6a748a120%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.