Wheel Zoom and Shift+Scroll

Hi,

In the previous release you had to hold down SHIFT then scroll for the wheel_zoom tool to take affect. Now, even if the mouse is over the plot, scrolling causes the plot to wheel_zoom. Is there a way to disable this behavior, or go back to the old behavior? The reason I’m asking is I have a many plots on the page, and before we would be able to scroll down the page. Now, when we scroll down the page, the mouse hits a plot, and scrolling of the page stops but instead starts zooming out of the graph.

If I don’t include the wheel_zoom tool, then the only difference is now scrolling wont’ scroll down the page. It just halts the page because the mouse is over the plot, and scrolling has no affect. The workaround now is for the user to place their mouse cursor at a position which does not overlap the plots.

Sean

Hi Sean,

Unintended consequences, I am afraid. There was a chorus to make scroll and pan work together, and it did not occur that the old behavior was still wanted. I am sure we can make this configurable, it should not be too hard, but it may be a few weeks before we can look at it (lots of end of year travel). If you are interested in taking a stab at it, and working up a PR, I would be happy to provide any information you need.

Bryan

···

On Dec 9, 2014, at 2:00 PM, Sean Truong <[email protected]> wrote:

Hi,

In the previous release you had to hold down SHIFT then scroll for the wheel_zoom tool to take affect. Now, even if the mouse is over the plot, scrolling causes the plot to wheel_zoom. Is there a way to disable this behavior, or go back to the old behavior? The reason I'm asking is I have a many plots on the page, and before we would be able to scroll down the page. Now, when we scroll down the page, the mouse hits a plot, and scrolling of the page stops but instead starts zooming out of the graph.

If I don't include the wheel_zoom tool, then the only difference is now scrolling wont' scroll down the page. It just halts the page because the mouse is over the plot, and scrolling has no affect. The workaround now is for the user to place their mouse cursor at a position which does not overlap the plots.

Sean

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/179fc807-c7a7-474e-865e-1e8b33a51efe%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.