Bokeh items are not rendering due to websocket connection failed

Launching a panel web application using bokeh commands. Part of which it used to worked fine when using the IP address and port number on python script and on the service. However, somehow, it stopped working on some machines that are connected to the network and is only working on one remote machine on Firefox and not on Chrome. Any explanation to this? I tried setting up the argument to * to make it easier for access. Same problem persists. It was working fine, it currently renders blank template for other machines/users.

websocket connections can fail because the payload size to too large (there is a configuration that can be adjusted in that case) or because something in between e.g. a proxy like Nginx or Apache, is configured in a way that blocks those connections, or probably other reasons. It’s not really possible to speculate without any other details. Places to look for information: the bokeh server console logs, the browser JavaScript console logs, and intervening network proxy logs.