Bokeh server in Azure Databricks

I am working in Azure Databricks and am trying to run a bokeh server.

Azure Databricks updated its IPython version in recent updates, so theoretically, everything should work now. However, I am getting inconsistent behavior.

I tried what this notebook described, but I don’t even get the logo, no output at all, but the cell runs fine:

The second part of the notebook again does not output anything, but seems to run fine as well.

Interestingly, the third part works just as expected:
from IPython.display import IFrame
IFrame(‘https://demo.bokeh.org/sliders’, width=900, height=500)

Any pointers where to start? I know that in Databricks, I sometimes have to put display(stuff) instead of just stuff, and for figures for example display(fig.figure()), but I tried that and it doesn’t work.

Feel free to suggest anything to try, or provide links about how exactly bokeh in notebooks is supposed to work so that I can start debugging

Unfortunately I don’t have any experience with Azure Databricks. Just trying to keep up with vanilla Jupyter notebooks / Jupyterlab already taxes the available project resources. All I can suggest at present is to examine the browser JavaScript console logs for any error or warning messages.

As for the IFrame, that basically sandboxes and renders an entirely separate site inside a page, and in this case the external site has nothing to do with notebooks, so I would expect it to work regardless of any problems with notebooks.

Just for reference, the version printed out on the working MyBinder notebook (which I just bumped to use the latest Bokeh version) are: