bokeh server over ssh tunnel

I’m trying to access the plots running on a work machine (xxx.xxx.xxx.1) that is accessible through another gateway machine. I’m trying to access the plots on the server from a machine at home. Normally I setup a ssh tunnel from my local machine to the machine at work (now running bokeh server and well as client for plotting). I tried setting up ssh tunnel to enable me to forward the bokeh port.

ssh -f -N -L 5006:xxx.xxx.xxx.1:5006 [email protected]

I then tried localhost:5006 on my local machine with the expectation that I would be connecting to xxx.xxx.xxx.1. This did not work and I got a connection timeout.

Is it possible to get bokeh server to work over a ssh tunnel?

bokeh 0.11.1

server start with: bokeh serve --host localhost:5006 --host xxx.xxx.xxx.1

Try the following.

On the node where Bokeh will run:

bokeh serve &

ssh -NfR 5006:localhost:5006 [email protected]

On the local machine (e.g., laptop):

ssh -NfL localhost:5006:localhost:5006 [email protected]

Now you should be able to navigate to http://localhost:5006 to access Bokeh running on a node behind the gateway.

···

On Mon, Feb 29, 2016 at 3:39 PM, waqy [email protected] wrote:

I’m trying to access the plots running on a work machine (xxx.xxx.xxx.1) that is accessible through another gateway machine. I’m trying to access the plots on the server from a machine at home. Normally I setup a ssh tunnel from my local machine to the machine at work (now running bokeh server and well as client for plotting). I tried setting up ssh tunnel to enable me to forward the bokeh port.

ssh -f -N -L 5006:xxx.xxx.xxx.1:5006 [email protected]

I then tried localhost:5006 on my local machine with the expectation that I would be connecting to xxx.xxx.xxx.1. This did not work and I got a connection timeout.

Is it possible to get bokeh server to work over a ssh tunnel?

bokeh 0.11.1

server start with: bokeh serve --host localhost:5006 --host xxx.xxx.xxx.1

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/053f8a0a-d6ce-4a49-a113-51c2a77e8372%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Tom,

Have you tested this to work? If so that is awesome! Would you be interested in making a small PR to add this information to the users guide?

Bryan

···

On Feb 29, 2016, at 7:44 PM, Tom Lynch <[email protected]> wrote:

Try the following.

On the node where Bokeh will run:

    bokeh serve &
    ssh -NfR 5006:localhost:5006 [email protected]

On the local machine (e.g., laptop):

    ssh -NfL localhost:5006:localhost:5006 [email protected]

Now you should be able to navigate to http://localhost:5006 to access Bokeh running on a node behind the gateway.

On Mon, Feb 29, 2016 at 3:39 PM, waqy <[email protected]> wrote:
I'm trying to access the plots running on a work machine (xxx.xxx.xxx.1) that is accessible through another gateway machine. I'm trying to access the plots on the server from a machine at home. Normally I setup a ssh tunnel from my local machine to the machine at work (now running bokeh server and well as client for plotting). I tried setting up ssh tunnel to enable me to forward the bokeh port.

ssh -f -N -L 5006:xxx.xxx.xxx.1:5006 [email protected]

I then tried localhost:5006 on my local machine with the expectation that I would be connecting to xxx.xxx.xxx.1. This did not work and I got a connection timeout.

Is it possible to get bokeh server to work over a ssh tunnel?

# bokeh 0.11.1
# server start with: bokeh serve --host localhost:5006 --host xxx.xxx.xxx.1

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/053f8a0a-d6ce-4a49-a113-51c2a77e8372%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/CADKZnj1%3DRRUA0T6dg_7ZZ_GfqCBcg%3Dyf89mbmsX2gzgvNS2VKA%40mail.gmail.com.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

In the example, the line to invoke Bokeh is listed as:

bokeh serve &

If you’re not using screen or multiple terminal windows you might want to run it as:

nohup bokeh serve &

Neither of these variants has any bearing on how the tunnel works; it’s just convenient if you want to issue the ssh command in the same terminal session.

···

On Mon, Feb 29, 2016 at 7:44 PM, Tom Lynch [email protected] wrote:

Try the following.

On the node where Bokeh will run:

bokeh serve &
ssh -NfR 5006:localhost:5006 [email protected]

On the local machine (e.g., laptop):

ssh -NfL localhost:5006:localhost:5006 [email protected]

Now you should be able to navigate to http://localhost:5006 to access Bokeh running on a node behind the gateway.

On Mon, Feb 29, 2016 at 3:39 PM, waqy [email protected] wrote:

I’m trying to access the plots running on a work machine (xxx.xxx.xxx.1) that is accessible through another gateway machine. I’m trying to access the plots on the server from a machine at home. Normally I setup a ssh tunnel from my local machine to the machine at work (now running bokeh server and well as client for plotting). I tried setting up ssh tunnel to enable me to forward the bokeh port.

ssh -f -N -L 5006:xxx.xxx.xxx.1:5006 [email protected]

I then tried localhost:5006 on my local machine with the expectation that I would be connecting to xxx.xxx.xxx.1. This did not work and I got a connection timeout.

Is it possible to get bokeh server to work over a ssh tunnel?

bokeh 0.11.1

server start with: bokeh serve --host localhost:5006 --host xxx.xxx.xxx.1

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/053f8a0a-d6ce-4a49-a113-51c2a77e8372%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Yeah, I did test it. I’ll look at adding it to the user guide.

···

On Mon, Feb 29, 2016 at 7:49 PM, Bryan Van de Ven [email protected] wrote:

Tom,

Have you tested this to work? If so that is awesome! Would you be interested in making a small PR to add this information to the users guide?

Bryan

On Feb 29, 2016, at 7:44 PM, Tom Lynch [email protected] wrote:

Try the following.

On the node where Bokeh will run:

bokeh serve &
ssh -NfR 5006:localhost:5006 [email protected]

On the local machine (e.g., laptop):

ssh -NfL localhost:5006:localhost:5006 [email protected]

Now you should be able to navigate to http://localhost:5006 to access Bokeh running on a node behind the gateway.

On Mon, Feb 29, 2016 at 3:39 PM, waqy [email protected] wrote:

I’m trying to access the plots running on a work machine (xxx.xxx.xxx.1) that is accessible through another gateway machine. I’m trying to access the plots on the server from a machine at home. Normally I setup a ssh tunnel from my local machine to the machine at work (now running bokeh server and well as client for plotting). I tried setting up ssh tunnel to enable me to forward the bokeh port.

ssh -f -N -L 5006:xxx.xxx.xxx.1:5006 [email protected]

I then tried localhost:5006 on my local machine with the expectation that I would be connecting to xxx.xxx.xxx.1. This did not work and I got a connection timeout.

Is it possible to get bokeh server to work over a ssh tunnel?

bokeh 0.11.1

server start with: bokeh serve --host localhost:5006 --host xxx.xxx.xxx.1

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/053f8a0a-d6ce-4a49-a113-51c2a77e8372%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/CADKZnj1%3DRRUA0T6dg_7ZZ_GfqCBcg%3Dyf89mbmsX2gzgvNS2VKA%40mail.gmail.com.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/A9BE5F24-FB74-485E-B67E-0593F06E05D9%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Brilliant! I'd suggest a small section around here maybe:

  https://github.com/bokeh/bokeh/blame/master/sphinx/source/docs/user_guide/server.rst#L496

(had to link to "blame" to prevent GH from trying to render .rst)

Bryan

···

On Feb 29, 2016, at 7:51 PM, Tom Lynch <[email protected]> wrote:

Yeah, I did test it. I'll look at adding it to the user guide.

On Mon, Feb 29, 2016 at 7:49 PM, Bryan Van de Ven <[email protected]> wrote:
Tom,

Have you tested this to work? If so that is awesome! Would you be interested in making a small PR to add this information to the users guide?

Bryan

> On Feb 29, 2016, at 7:44 PM, Tom Lynch <[email protected]> wrote:
>
> Try the following.
>
> On the node where Bokeh will run:
>
> bokeh serve &
> ssh -NfR 5006:localhost:5006 [email protected]
>
> On the local machine (e.g., laptop):
>
> ssh -NfL localhost:5006:localhost:5006 [email protected]
>
> Now you should be able to navigate to http://localhost:5006 to access Bokeh running on a node behind the gateway.
>
>
> On Mon, Feb 29, 2016 at 3:39 PM, waqy <[email protected]> wrote:
> I'm trying to access the plots running on a work machine (xxx.xxx.xxx.1) that is accessible through another gateway machine. I'm trying to access the plots on the server from a machine at home. Normally I setup a ssh tunnel from my local machine to the machine at work (now running bokeh server and well as client for plotting). I tried setting up ssh tunnel to enable me to forward the bokeh port.
>
> ssh -f -N -L 5006:xxx.xxx.xxx.1:5006 [email protected]
>
> I then tried localhost:5006 on my local machine with the expectation that I would be connecting to xxx.xxx.xxx.1. This did not work and I got a connection timeout.
>
> Is it possible to get bokeh server to work over a ssh tunnel?
>
>
> # bokeh 0.11.1
> # server start with: bokeh serve --host localhost:5006 --host xxx.xxx.xxx.1
>
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/053f8a0a-d6ce-4a49-a113-51c2a77e8372%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/CADKZnj1%3DRRUA0T6dg_7ZZ_GfqCBcg%3Dyf89mbmsX2gzgvNS2VKA%40mail.gmail.com.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/A9BE5F24-FB74-485E-B67E-0593F06E05D9%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/CADKZnj0UGdVzKqwm_-ZKbpquPd4MA9yCfdZJokrQaokLvF7_Gw%40mail.gmail.com.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Many thanks Tom. Tried you suggestion and it works perfectly. Definitely put it user guide.

···

On Monday, February 29, 2016 at 5:54:01 PM UTC-8, Bryan Van de ven wrote:

Brilliant! I’d suggest a small section around here maybe:

    [https://github.com/bokeh/bokeh/blame/master/sphinx/source/docs/user_guide/server.rst#L496](https://github.com/bokeh/bokeh/blame/master/sphinx/source/docs/user_guide/server.rst#L496)

(had to link to “blame” to prevent GH from trying to render .rst)

Bryan

On Feb 29, 2016, at 7:51 PM, Tom Lynch [email protected] wrote:

Yeah, I did test it. I’ll look at adding it to the user guide.

On Mon, Feb 29, 2016 at 7:49 PM, Bryan Van de Ven [email protected] wrote:

Tom,

Have you tested this to work? If so that is awesome! Would you be interested in making a small PR to add this information to the users guide?

Bryan

On Feb 29, 2016, at 7:44 PM, Tom Lynch [email protected] wrote:

Try the following.

On the node where Bokeh will run:

bokeh serve &
ssh -NfR 5006:localhost:5006 [email protected]

On the local machine (e.g., laptop):

ssh -NfL localhost:5006:localhost:5006 [email protected]

Now you should be able to navigate to http://localhost:5006 to access Bokeh running on a node behind the gateway.

On Mon, Feb 29, 2016 at 3:39 PM, waqy [email protected] wrote:

I’m trying to access the plots running on a work machine (xxx.xxx.xxx.1) that is accessible through another gateway machine. I’m trying to access the plots on the server from a machine at home. Normally I setup a ssh tunnel from my local machine to the machine at work (now running bokeh server and well as client for plotting). I tried setting up ssh tunnel to enable me to forward the bokeh port.

ssh -f -N -L 5006:xxx.xxx.xxx.1:5006 [email protected]

I then tried localhost:5006 on my local machine with the expectation that I would be connecting to xxx.xxx.xxx.1. This did not work and I got a connection timeout.

Is it possible to get bokeh server to work over a ssh tunnel?

bokeh 0.11.1

server start with: bokeh serve --host localhost:5006 --host xxx.xxx.xxx.1

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/053f8a0a-d6ce-4a49-a113-51c2a77e8372%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/CADKZnj1%3DRRUA0T6dg_7ZZ_GfqCBcg%3Dyf89mbmsX2gzgvNS2VKA%40mail.gmail.com.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/A9BE5F24-FB74-485E-B67E-0593F06E05D9%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/CADKZnj0UGdVzKqwm_-ZKbpquPd4MA9yCfdZJokrQaokLvF7_Gw%40mail.gmail.com.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.