bokeh server shows no examples although anaconda was installed.

Hi,
I am new to Anaconda and Bokeh and I just installed a fresh Anaconda 3.4 x64.

‘3.4.1 |Anaconda 2.0.1 (64-bit)| (default, Jun 11 2014, 17:27:11) [MSC v.1600 64 bit (AMD64)]’

``

I installed bokeh using “conda bokeh”

bokeh.server.run()

``

and got:

Bokeh Server Configuration

···

==========================
listening : 127.0.0.1:5006
backend : shelve
python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF
js options : splitjs:OFF, debugjs:OFF
data-directory : None

Starting Bokeh plot server on port 5006…127.0.0.1 - - [16/Aug/2014 18:53:28] “GET / HTTP/1.1” 302 221
127.0.0.1 - - [16/Aug/2014 18:53:28] “GET /bokeh/ HTTP/1.1” 200 479
127.0.0.1 - - [16/Aug/2014 18:53:30] “GET /bokeh/userinfo/ HTTP/1.1” 200 39
127.0.0.1 - - [16/Aug/2014 18:53:46] “GET /bokeh/sub HTTP/1.1” 200 4

View http://127.0.0.1:5006/bokeh to see plots

``

I then visited http://localhost:5006/bokeh/ but I see only “Bokeh Documents for defaultuser” and “logout” with no examples appearing.

I have also tried to run
bokeh-server.exe

``

but it didn’t help.

Additionally, how do I upload new plot to the server, assuming it is working correctly?

Moreover, why do I need redis.io for?

Thanks,

HS.

Hi HS,

Thanks for your interest in bokeh! Running the server does not create any plots, just makes a place for plots to be stored. You need to actually create a plot and store it on the server. You can see lots of examples in the examples/plotting/server directory of the GitHub source tree:

  https://github.com/ContinuumIO/bokeh/tree/master/examples/plotting/server

Let us know if we can help more!

Bryan

···

On Aug 16, 2014, at 11:01 AM, [email protected] wrote:

Hi,
I am new to Anaconda and Bokeh and I just installed a fresh Anaconda 3.4 x64.
'3.4.1 |Anaconda 2.0.1 (64-bit)| (default, Jun 11 2014, 17:27:11) [MSC v.1600 64 bit (AMD64)]'
I installed bokeh using "conda bokeh"

bokeh.server.run()
and got:
Bokeh Server Configuration

listening : 127.0.0.1:5006
backend : shelve
python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF
js options : splitjs:OFF, debugjs:OFF
data-directory : None

Starting Bokeh plot server on port 5006...127.0.0.1 - - [16/Aug/2014 18:53:28] "GET / HTTP/1.1" 302 221
127.0.0.1 - - [16/Aug/2014 18:53:28] "GET /bokeh/ HTTP/1.1" 200 479
127.0.0.1 - - [16/Aug/2014 18:53:30] "GET /bokeh/userinfo/ HTTP/1.1" 200 39
127.0.0.1 - - [16/Aug/2014 18:53:46] "GET /bokeh/sub HTTP/1.1" 200 4

View http://127.0.0.1:5006/bokeh to see plots

I then visited http://localhost:5006/bokeh/ but I see only "Bokeh Documents for defaultuser" and "logout" with no examples appearing.

I have also tried to run
bokeh-server.exe

but it didn't help.

Additionally, how do I upload new plot to the server, assuming it is working correctly?
Moreover, why do I need redis.io for?

Thanks,
HS.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a0d1995e-9767-4700-a823-12ca3d799a50%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Thanks.
So how do I make a non-local server to collect plots I generate locally?

I want one server computer to run “bokeh-server” and to push plot stuff into it from a local computer.

Thanks,

HS.

···

On Saturday, August 16, 2014 7:05:08 PM UTC+3, Bryan Van de ven wrote:

Hi HS,

Thanks for your interest in bokeh! Running the server does not create any plots, just makes a place for plots to be stored. You need to actually create a plot and store it on the server. You can see lots of examples in the examples/plotting/server directory of the GitHub source tree:

    [https://github.com/ContinuumIO/bokeh/tree/master/examples/plotting/server](https://github.com/ContinuumIO/bokeh/tree/master/examples/plotting/server)

Let us know if we can help more!

Bryan

On Aug 16, 2014, at 11:01 AM, c[email protected] wrote:

Hi,

I am new to Anaconda and Bokeh and I just installed a fresh Anaconda 3.4 x64.

‘3.4.1 |Anaconda 2.0.1 (64-bit)| (default, Jun 11 2014, 17:27:11) [MSC v.1600 64 bit (AMD64)]’

I installed bokeh using “conda bokeh”

bokeh.server.run()

and got:

Bokeh Server Configuration

==========================

listening : 127.0.0.1:5006

backend : shelve

python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF

js options : splitjs:OFF, debugjs:OFF

data-directory : None

Starting Bokeh plot server on port 5006…127.0.0.1 - - [16/Aug/2014 18:53:28] “GET / HTTP/1.1” 302 221

127.0.0.1 - - [16/Aug/2014 18:53:28] “GET /bokeh/ HTTP/1.1” 200 479

127.0.0.1 - - [16/Aug/2014 18:53:30] “GET /bokeh/userinfo/ HTTP/1.1” 200 39

127.0.0.1 - - [16/Aug/2014 18:53:46] “GET /bokeh/sub HTTP/1.1” 200 4

View http://127.0.0.1:5006/bokeh to see plots

I then visited http://localhost:5006/bokeh/ but I see only “Bokeh Documents for defaultuser” and “logout” with no examples appearing.

I have also tried to run

bokeh-server.exe

but it didn’t help.

Additionally, how do I upload new plot to the server, assuming it is working correctly?

Moreover, why do I need redis.io for?

Thanks,

HS.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a0d1995e-9767-4700-a823-12ca3d799a50%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Hi HS,

There are a few different levels of interfaces of Bokeh. There is a low-level "object" interface that mirrors BokehJS, to use this you have to set up sessions and documents yourself. I suggest you start with the higher level interface in bokeh.plotting. To use this interface, you need to call the output_server(...) function before you do any plotting. The documentation for output_server(...) is here:

  http://bokeh.pydata.org/docs/reference.html#bokeh.plotting.output_server

To have a set up where the server is on a different machine, you simply need to supply the "url" parameter to output_server(...) and any plots that you create and show() or save() will be stored on the server at that url.

Thanks,

Bryan

···

On Aug 16, 2014, at 1:39 PM, [email protected] wrote:

Thanks.
So how do I make a non-local server to collect plots I generate locally?
I want one server computer to run "bokeh-server" and to push plot stuff into it from a local computer.

Thanks,
HS.

On Saturday, August 16, 2014 7:05:08 PM UTC+3, Bryan Van de ven wrote:
Hi HS,

Thanks for your interest in bokeh! Running the server does not create any plots, just makes a place for plots to be stored. You need to actually create a plot and store it on the server. You can see lots of examples in the examples/plotting/server directory of the GitHub source tree:

        https://github.com/ContinuumIO/bokeh/tree/master/examples/plotting/server

Let us know if we can help more!

Bryan

On Aug 16, 2014, at 11:01 AM, [email protected] wrote:

> Hi,
> I am new to Anaconda and Bokeh and I just installed a fresh Anaconda 3.4 x64.
> '3.4.1 |Anaconda 2.0.1 (64-bit)| (default, Jun 11 2014, 17:27:11) [MSC v.1600 64 bit (AMD64)]'
> I installed bokeh using "conda bokeh"
>
> bokeh.server.run()
> and got:
> Bokeh Server Configuration
> ==========================
> listening : 127.0.0.1:5006
> backend : shelve
> python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF
> js options : splitjs:OFF, debugjs:OFF
> data-directory : None
>
>
>
>
> Starting Bokeh plot server on port 5006...127.0.0.1 - - [16/Aug/2014 18:53:28] "GET / HTTP/1.1" 302 221
> 127.0.0.1 - - [16/Aug/2014 18:53:28] "GET /bokeh/ HTTP/1.1" 200 479
> 127.0.0.1 - - [16/Aug/2014 18:53:30] "GET /bokeh/userinfo/ HTTP/1.1" 200 39
> 127.0.0.1 - - [16/Aug/2014 18:53:46] "GET /bokeh/sub HTTP/1.1" 200 4
>
>
> View http://127.0.0.1:5006/bokeh to see plots
>
> I then visited http://localhost:5006/bokeh/ but I see only "Bokeh Documents for defaultuser" and "logout" with no examples appearing.
>
> I have also tried to run
> bokeh-server.exe
>
> but it didn't help.
>
> Additionally, how do I upload new plot to the server, assuming it is working correctly?
> Moreover, why do I need redis.io for?
>
> Thanks,
> HS.
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a0d1995e-9767-4700-a823-12ca3d799a50%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/ad2e916c-9273-4b08-b165-1f7da49d3e41%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Hi,

I’m running Python2.7 on an ArchLinux distro (no X) on a Raspberry Pi and am trying to get bokeh-server working. Unfortunately, I only seem to get the same message “Bokeh Documents for default user” on my browser (running on a different computer). When I fire up bokeh-server I get the following:

[[email protected]pi server]$ bokeh-server --ip 192.168.1.136

Bokeh Server Configuration

···

==========================

python version : 2.7.8

bokeh version : 0.6.0

listening : 192.168.1.136:5006

backend : shelve

python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF

js options : splitjs:OFF, debugjs:OFF

data-directory : None

zmqpub starting

Starting Bokeh plot server on port 5006…

View http://192.168.1.136:5006/bokeh to see plots

Bryan, you suggested downloading some of the example plots from Github. I’ve done that… now where should I put these example plots on the RPi? How do I tell bokeh-server where to look? I tried

bokeh-server --ip 192.168.1.136 --data-directory /home/jasmith/temp/bokeh-master/examples/plotting/server

but I got the same “Bokeh Documents for default user” message on my browser.

Any suggestions for how to get the bokeh-server to find those example files and display them on the browser would be much appreciated.

all the best,

James

On Saturday, August 16, 2014 12:05:08 PM UTC-4, Bryan Van de ven wrote:

Hi HS,

Thanks for your interest in bokeh! Running the server does not create any plots, just makes a place for plots to be stored. You need to actually create a plot and store it on the server. You can see lots of examples in the examples/plotting/server directory of the GitHub source tree:

    [https://github.com/ContinuumIO/bokeh/tree/master/examples/plotting/server](https://github.com/ContinuumIO/bokeh/tree/master/examples/plotting/server)

Let us know if we can help more!

Bryan

On Aug 16, 2014, at 11:01 AM, [email protected] wrote:

Hi,

I am new to Anaconda and Bokeh and I just installed a fresh Anaconda 3.4 x64.

‘3.4.1 |Anaconda 2.0.1 (64-bit)| (default, Jun 11 2014, 17:27:11) [MSC v.1600 64 bit (AMD64)]’

I installed bokeh using “conda bokeh”

bokeh.server.run()

and got:

Bokeh Server Configuration

==========================

listening : 127.0.0.1:5006

backend : shelve

python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF

js options : splitjs:OFF, debugjs:OFF

data-directory : None

Starting Bokeh plot server on port 5006…127.0.0.1 - - [16/Aug/2014 18:53:28] “GET / HTTP/1.1” 302 221

127.0.0.1 - - [16/Aug/2014 18:53:28] “GET /bokeh/ HTTP/1.1” 200 479

127.0.0.1 - - [16/Aug/2014 18:53:30] “GET /bokeh/userinfo/ HTTP/1.1” 200 39

127.0.0.1 - - [16/Aug/2014 18:53:46] “GET /bokeh/sub HTTP/1.1” 200 4

View http://127.0.0.1:5006/bokeh to see plots

I then visited http://localhost:5006/bokeh/ but I see only “Bokeh Documents for defaultuser” and “logout” with no examples appearing.

I have also tried to run

bokeh-server.exe

but it didn’t help.

Additionally, how do I upload new plot to the server, assuming it is working correctly?

Moreover, why do I need redis.io for?

Thanks,

HS.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a0d1995e-9767-4700-a823-12ca3d799a50%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Hi James,

I think you have exposed a need for better documentation about a core component. I mentioned before that "Running the server does not create any plots, just makes a place for plots to be stored" but that's only half the story, I left out the other half, which is that once you have a server running, you can run all the scripts in the example directory, separately, in a new shell. *Those* scripts store plots on the server when you run them, and they should open a browser for you to the right link by default. Let's run through a complete example:

* In a first terminal, do this:

[email protected] (git:feature/selection) ~/work/bokeh $ bokeh-server

    Bokeh Server Configuration

···

==========================
    python version : 2.7.8
    bokeh version : 0.6.1.dev.20140923
    listening : 127.0.0.1:5006
    backend : shelve
    python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF
    js options : splitjs:OFF, debugjs:OFF
    data-directory : None
    
zmqpub starting

Starting Bokeh plot server on port 5006...
View http://127.0.0.1:5006/bokeh to see plots

* Leave the server running, in a NEW terminal, do this:

[email protected] (git:feature/selection) ~/work/bokeh/examples/plotting/server $ python color_scatter.py
Using saved session configuration for http://localhost:5006/
To override, pass 'load_from_config=False' to Session

This should automatically open a browser to the single document page for this plot, it will look something like this:

  http://localhost:5006/bokeh/doc/<big long UUID>/<another big UUID>

However, maybe it does not work if the server is running on a remote computer. However in any case, now if you navigate to the Bokeh server main page:

  http://localhost:5006/bokeh/

You should see the color scatterplot in the list of plots. Note, above it has "localhost" but if you are passing the --ip parameter to the server, then then you would use whatever ip address you specified for the server to listen on instead of "localhost". However, Bokeh outputs to the localhost server by default, so you will also have to modify the "color_scatterplot.py" example to point it at your specific server address by passing in a "url" parameter to the output_server(...) function (there's no way for it to magically know where you are running your server). I would suggest trying everything on a single machine with the default server settings, first.

Let me know if this does not work for you.

Byran

On Sep 24, 2014, at 9:46 AM, [email protected] wrote:

Hi,

I'm running Python2.7 on an ArchLinux distro (no X) on a Raspberry Pi and am trying to get bokeh-server working. Unfortunately, I only seem to get the same message "Bokeh Documents for default user" on my browser (running on a different computer). When I fire up bokeh-server I get the following:

[[email protected] server]$ bokeh-server --ip 192.168.1.136

Bokeh Server Configuration

python version : 2.7.8
bokeh version : 0.6.0
listening : 192.168.1.136:5006
backend : shelve
python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF
js options : splitjs:OFF, debugjs:OFF
data-directory : None

zmqpub starting

Starting Bokeh plot server on port 5006...
View http://192.168.1.136:5006/bokeh to see plots

Bryan, you suggested downloading some of the example plots from Github. I've done that... now where should I put these example plots on the RPi? How do I tell bokeh-server where to look? I tried

bokeh-server --ip 192.168.1.136 --data-directory /home/jasmith/temp/bokeh-master/examples/plotting/server

but I got the same "Bokeh Documents for default user" message on my browser.

Any suggestions for how to get the bokeh-server to find those example files and display them on the browser would be much appreciated.

all the best,

James

On Saturday, August 16, 2014 12:05:08 PM UTC-4, Bryan Van de ven wrote:
Hi HS,

Thanks for your interest in bokeh! Running the server does not create any plots, just makes a place for plots to be stored. You need to actually create a plot and store it on the server. You can see lots of examples in the examples/plotting/server directory of the GitHub source tree:

        https://github.com/ContinuumIO/bokeh/tree/master/examples/plotting/server

Let us know if we can help more!

Bryan

On Aug 16, 2014, at 11:01 AM, [email protected] wrote:

> Hi,
> I am new to Anaconda and Bokeh and I just installed a fresh Anaconda 3.4 x64.
> '3.4.1 |Anaconda 2.0.1 (64-bit)| (default, Jun 11 2014, 17:27:11) [MSC v.1600 64 bit (AMD64)]'
> I installed bokeh using "conda bokeh"
>
> bokeh.server.run()
> and got:
> Bokeh Server Configuration
> ==========================
> listening : 127.0.0.1:5006
> backend : shelve
> python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF
> js options : splitjs:OFF, debugjs:OFF
> data-directory : None
>
>
>
>
> Starting Bokeh plot server on port 5006...127.0.0.1 - - [16/Aug/2014 18:53:28] "GET / HTTP/1.1" 302 221
> 127.0.0.1 - - [16/Aug/2014 18:53:28] "GET /bokeh/ HTTP/1.1" 200 479
> 127.0.0.1 - - [16/Aug/2014 18:53:30] "GET /bokeh/userinfo/ HTTP/1.1" 200 39
> 127.0.0.1 - - [16/Aug/2014 18:53:46] "GET /bokeh/sub HTTP/1.1" 200 4
>
>
> View http://127.0.0.1:5006/bokeh to see plots
>
> I then visited http://localhost:5006/bokeh/ but I see only "Bokeh Documents for defaultuser" and "logout" with no examples appearing.
>
> I have also tried to run
> bokeh-server.exe
>
> but it didn't help.
>
> Additionally, how do I upload new plot to the server, assuming it is working correctly?
> Moreover, why do I need redis.io for?
>
> Thanks,
> HS.
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a0d1995e-9767-4700-a823-12ca3d799a50%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/89b3d159-e97d-4bc9-9265-5ced5e37fbc6%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Hi Bryan,

thanks for the quick reply. It seems to work (Raspberry Pi is the server, MacBook Pro is the client). I have the bokeh-server running in one ssh terminal, and I call the python graph script example in a second terminal. I just need to be patient while the page loads in Safari on my MacBook. Here’s a screen capture of it working:

http://youtu.be/da_loaEaytc

I’ve modified the color_scatter.py example as follows:

import numpy as np

from six.moves import zip

from bokeh.plotting import *

new line added: -js

from bokeh.session import Session

N = 4000

new line added: -js

session = Session(load_from_config=False)

x = np.random.random(size=N) * 100

y = np.random.random(size=N) * 100

radii = np.random.random(size=N) * 1.5

colors = ["#%02x%02x%02x" % (r, g, 150) for r, g in zip(np.floor(50+2x), np.floor(30+2y))]

change line: -js

output_server(“color_scatter”,url=‘http://192.168.1.136:5006’)

scatter(x,y, radius=radii, radius_units=“data”,

fill_color=colors, fill_alpha=0.6,

line_color=None, tools=“select,pan,wheel_zoom,box_zoom,reset,previewsave”, name=“color_scatter_example”)

show() # open a browser

all the best,

James

···

On Wednesday, September 24, 2014 10:01:56 AM UTC-4, Bryan Van de ven wrote:

Hi James,

I think you have exposed a need for better documentation about a core component. I mentioned before that “Running the server does not create any plots, just makes a place for plots to be stored” but that’s only half the story, I left out the other half, which is that once you have a server running, you can run all the scripts in the example directory, separately, in a new shell. Those scripts store plots on the server when you run them, and they should open a browser for you to the right link by default. Let’s run through a complete example:

  • In a first terminal, do this:

[email protected] (git:feature/selection) ~/work/bokeh $ bokeh-server

Bokeh Server Configuration

==========================

python version : 2.7.8

bokeh version  : 0.6.1.dev.20140923

listening      : [127.0.0.1:5006](http://127.0.0.1:5006)

backend        : shelve

python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF

js options     : splitjs:OFF, debugjs:OFF

data-directory : None

zmqpub starting

Starting Bokeh plot server on port 5006…

View http://127.0.0.1:5006/bokeh to see plots

  • Leave the server running, in a NEW terminal, do this:

[email protected] (git:feature/selection) ~/work/bokeh/examples/plotting/server $ python color_scatter.py
Using saved session configuration for http://localhost:5006/

To override, pass ‘load_from_config=False’ to Session

This should automatically open a browser to the single document page for this plot, it will look something like this:

    [http://localhost:5006/bokeh/doc/](http://localhost:5006/bokeh/doc/)<big long UUID>/<another big UUID>

However, maybe it does not work if the server is running on a remote computer. However in any case, now if you navigate to the Bokeh server main page:

    [http://localhost:5006/bokeh/](http://localhost:5006/bokeh/)

You should see the color scatterplot in the list of plots. Note, above it has “localhost” but if you are passing the --ip parameter to the server, then then you would use whatever ip address you specified for the server to listen on instead of “localhost”. However, Bokeh outputs to the localhost server by default, so you will also have to modify the “color_scatterplot.py” example to point it at your specific server address by passing in a “url” parameter to the output_server(…) function (there’s no way for it to magically know where you are running your server). I would suggest trying everything on a single machine with the default server settings, first.

Let me know if this does not work for you.

Byran

On Sep 24, 2014, at 9:46 AM, [email protected] wrote:

Hi,

I’m running Python2.7 on an ArchLinux distro (no X) on a Raspberry Pi and am trying to get bokeh-server working. Unfortunately, I only seem to get the same message “Bokeh Documents for default user” on my browser (running on a different computer). When I fire up bokeh-server I get the following:

[[email protected] server]$ bokeh-server --ip 192.168.1.136

Bokeh Server Configuration

==========================

python version : 2.7.8

bokeh version : 0.6.0

listening : 192.168.1.136:5006

backend : shelve

python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF

js options : splitjs:OFF, debugjs:OFF

data-directory : None

zmqpub starting

Starting Bokeh plot server on port 5006…

View http://192.168.1.136:5006/bokeh to see plots

Bryan, you suggested downloading some of the example plots from Github. I’ve done that… now where should I put these example plots on the RPi? How do I tell bokeh-server where to look? I tried

bokeh-server --ip 192.168.1.136 --data-directory /home/jasmith/temp/bokeh-master/examples/plotting/server

but I got the same “Bokeh Documents for default user” message on my browser.

Any suggestions for how to get the bokeh-server to find those example files and display them on the browser would be much appreciated.

all the best,

James

On Saturday, August 16, 2014 12:05:08 PM UTC-4, Bryan Van de ven wrote:

Hi HS,

Thanks for your interest in bokeh! Running the server does not create any plots, just makes a place for plots to be stored. You need to actually create a plot and store it on the server. You can see lots of examples in the examples/plotting/server directory of the GitHub source tree:

    [https://github.com/ContinuumIO/bokeh/tree/master/examples/plotting/server](https://github.com/ContinuumIO/bokeh/tree/master/examples/plotting/server)

Let us know if we can help more!

Bryan

On Aug 16, 2014, at 11:01 AM, [email protected] wrote:

Hi,
I am new to Anaconda and Bokeh and I just installed a fresh Anaconda 3.4 x64.
‘3.4.1 |Anaconda 2.0.1 (64-bit)| (default, Jun 11 2014, 17:27:11) [MSC v.1600 64 bit (AMD64)]’
I installed bokeh using “conda bokeh”

bokeh.server.run()
and got:
Bokeh Server Configuration

listening : 127.0.0.1:5006

backend : shelve
python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF
js options : splitjs:OFF, debugjs:OFF
data-directory : None

Starting Bokeh plot server on port 5006…127.0.0.1 - - [16/Aug/2014 18:53:28] “GET / HTTP/1.1” 302 221
127.0.0.1 - - [16/Aug/2014 18:53:28] “GET /bokeh/ HTTP/1.1” 200 479
127.0.0.1 - - [16/Aug/2014 18:53:30] “GET /bokeh/userinfo/ HTTP/1.1” 200 39
127.0.0.1 - - [16/Aug/2014 18:53:46] “GET /bokeh/sub HTTP/1.1” 200 4

View http://127.0.0.1:5006/bokeh to see plots

I then visited http://localhost:5006/bokeh/ but I see only “Bokeh Documents for defaultuser” and “logout” with no examples appearing.

I have also tried to run
bokeh-server.exe

but it didn’t help.

Additionally, how do I upload new plot to the server, assuming it is working correctly?
Moreover, why do I need redis.io for?

Thanks,
HS.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a0d1995e-9767-4700-a823-12ca3d799a50%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/89b3d159-e97d-4bc9-9265-5ced5e37fbc6%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

That's awesome! Mind if I tweet that youtube link out?

Bryan

···

On Sep 24, 2014, at 12:09 PM, [email protected] wrote:

Hi Bryan,

thanks for the quick reply. It seems to work (Raspberry Pi is the server, MacBook Pro is the client). I have the bokeh-server running in one ssh terminal, and I call the python graph script example in a second terminal. I just need to be patient while the page loads in Safari on my MacBook. Here's a screen capture of it working:

http://youtu.be/da_loaEaytc

I've modified the color_scatter.py example as follows:

import numpy as np
from six.moves import zip
from bokeh.plotting import *

# new line added: -js
from bokeh.session import Session

N = 4000

# new line added: -js
session = Session(load_from_config=False)

x = np.random.random(size=N) * 100
y = np.random.random(size=N) * 100
radii = np.random.random(size=N) * 1.5
colors = ["#%02x%02x%02x" % (r, g, 150) for r, g in zip(np.floor(50+2*x), np.floor(30+2*y))]

# change line: -js
output_server("color_scatter",url='http://192.168.1.136:5006')

scatter(x,y, radius=radii, radius_units="data",
        fill_color=colors, fill_alpha=0.6,
        line_color=None, tools="select,pan,wheel_zoom,box_zoom,reset,previewsave", name="color_scatter_example")

show() # open a browser

all the best,

James

On Wednesday, September 24, 2014 10:01:56 AM UTC-4, Bryan Van de ven wrote:
Hi James,

I think you have exposed a need for better documentation about a core component. I mentioned before that "Running the server does not create any plots, just makes a place for plots to be stored" but that's only half the story, I left out the other half, which is that once you have a server running, you can run all the scripts in the example directory, separately, in a new shell. *Those* scripts store plots on the server when you run them, and they should open a browser for you to the right link by default. Let's run through a complete example:

* In a first terminal, do this:

[email protected] (git:feature/selection) ~/work/bokeh $ bokeh-server

    Bokeh Server Configuration
    ==========================
    python version : 2.7.8
    bokeh version : 0.6.1.dev.20140923
    listening : 127.0.0.1:5006
    backend : shelve
    python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF
    js options : splitjs:OFF, debugjs:OFF
    data-directory : None
    
zmqpub starting

Starting Bokeh plot server on port 5006...
View http://127.0.0.1:5006/bokeh to see plots

* Leave the server running, in a NEW terminal, do this:

[email protected] (git:feature/selection) ~/work/bokeh/examples/plotting/server $ python color_scatter.py
Using saved session configuration for http://localhost:5006/
To override, pass 'load_from_config=False' to Session

This should automatically open a browser to the single document page for this plot, it will look something like this:

        http://localhost:5006/bokeh/doc/<big long UUID>/<another big UUID>

However, maybe it does not work if the server is running on a remote computer. However in any case, now if you navigate to the Bokeh server main page:

        http://localhost:5006/bokeh/

You should see the color scatterplot in the list of plots. Note, above it has "localhost" but if you are passing the --ip parameter to the server, then then you would use whatever ip address you specified for the server to listen on instead of "localhost". However, Bokeh outputs to the localhost server by default, so you will also have to modify the "color_scatterplot.py" example to point it at your specific server address by passing in a "url" parameter to the output_server(...) function (there's no way for it to magically know where you are running your server). I would suggest trying everything on a single machine with the default server settings, first.

Let me know if this does not work for you.

Byran

On Sep 24, 2014, at 9:46 AM, [email protected] wrote:

> Hi,
>
> I'm running Python2.7 on an ArchLinux distro (no X) on a Raspberry Pi and am trying to get bokeh-server working. Unfortunately, I only seem to get the same message "Bokeh Documents for default user" on my browser (running on a different computer). When I fire up bokeh-server I get the following:
>
> [[email protected] server]$ bokeh-server --ip 192.168.1.136
>
> Bokeh Server Configuration
> ==========================
> python version : 2.7.8
> bokeh version : 0.6.0
> listening : 192.168.1.136:5006
> backend : shelve
> python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF
> js options : splitjs:OFF, debugjs:OFF
> data-directory : None
>
> zmqpub starting
>
> Starting Bokeh plot server on port 5006...
> View http://192.168.1.136:5006/bokeh to see plots
>
> Bryan, you suggested downloading some of the example plots from Github. I've done that... now where should I put these example plots on the RPi? How do I tell bokeh-server where to look? I tried
>
> bokeh-server --ip 192.168.1.136 --data-directory /home/jasmith/temp/bokeh-master/examples/plotting/server
>
> but I got the same "Bokeh Documents for default user" message on my browser.
>
> Any suggestions for how to get the bokeh-server to find those example files and display them on the browser would be much appreciated.
>
> all the best,
>
> James
>
> On Saturday, August 16, 2014 12:05:08 PM UTC-4, Bryan Van de ven wrote:
> Hi HS,
>
> Thanks for your interest in bokeh! Running the server does not create any plots, just makes a place for plots to be stored. You need to actually create a plot and store it on the server. You can see lots of examples in the examples/plotting/server directory of the GitHub source tree:
>
> https://github.com/ContinuumIO/bokeh/tree/master/examples/plotting/server
>
> Let us know if we can help more!
>
> Bryan
>
>
> On Aug 16, 2014, at 11:01 AM, [email protected] wrote:
>
> > Hi,
> > I am new to Anaconda and Bokeh and I just installed a fresh Anaconda 3.4 x64.
> > '3.4.1 |Anaconda 2.0.1 (64-bit)| (default, Jun 11 2014, 17:27:11) [MSC v.1600 64 bit (AMD64)]'
> > I installed bokeh using "conda bokeh"
> >
> > bokeh.server.run()
> > and got:
> > Bokeh Server Configuration
> > ==========================
> > listening : 127.0.0.1:5006
> > backend : shelve
> > python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF
> > js options : splitjs:OFF, debugjs:OFF
> > data-directory : None
> >
> >
> >
> >
> > Starting Bokeh plot server on port 5006...127.0.0.1 - - [16/Aug/2014 18:53:28] "GET / HTTP/1.1" 302 221
> > 127.0.0.1 - - [16/Aug/2014 18:53:28] "GET /bokeh/ HTTP/1.1" 200 479
> > 127.0.0.1 - - [16/Aug/2014 18:53:30] "GET /bokeh/userinfo/ HTTP/1.1" 200 39
> > 127.0.0.1 - - [16/Aug/2014 18:53:46] "GET /bokeh/sub HTTP/1.1" 200 4
> >
> >
> > View http://127.0.0.1:5006/bokeh to see plots
> >
> > I then visited http://localhost:5006/bokeh/ but I see only "Bokeh Documents for defaultuser" and "logout" with no examples appearing.
> >
> > I have also tried to run
> > bokeh-server.exe
> >
> > but it didn't help.
> >
> > Additionally, how do I upload new plot to the server, assuming it is working correctly?
> > Moreover, why do I need redis.io for?
> >
> > Thanks,
> > HS.
> >
> > --
> > You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> > To post to this group, send email to [email protected].
> > To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a0d1995e-9767-4700-a823-12ca3d799a50%40continuum.io.
> > For more options, visit https://groups.google.com/a/continuum.io/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/89b3d159-e97d-4bc9-9265-5ced5e37fbc6%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected]um.io.
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/209e53e5-e009-4c68-bc28-7bf0bee57606%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Hi Bryan,

You’ve been very helpful – it would be rude of me not to return the favour! Feel free to tweet. :slight_smile:

all the best,

James

···

On Wednesday, September 24, 2014 12:40:27 PM UTC-4, Bryan Van de ven wrote:

That’s awesome! Mind if I tweet that youtube link out?

Bryan

On Sep 24, 2014, at 12:09 PM, [email protected] wrote:

Hi Bryan,

thanks for the quick reply. It seems to work (Raspberry Pi is the server, MacBook Pro is the client). I have the bokeh-server running in one ssh terminal, and I call the python graph script example in a second terminal. I just need to be patient while the page loads in Safari on my MacBook. Here’s a screen capture of it working:

http://youtu.be/da_loaEaytc

I’ve modified the color_scatter.py example as follows:

import numpy as np

from six.moves import zip

from bokeh.plotting import *

new line added: -js

from bokeh.session import Session

N = 4000

new line added: -js

session = Session(load_from_config=False)

x = np.random.random(size=N) * 100

y = np.random.random(size=N) * 100

radii = np.random.random(size=N) * 1.5

colors = ["#%02x%02x%02x" % (r, g, 150) for r, g in zip(np.floor(50+2x), np.floor(30+2y))]

change line: -js

output_server(“color_scatter”,url=‘http://192.168.1.136:5006’)

scatter(x,y, radius=radii, radius_units=“data”,

    fill_color=colors, fill_alpha=0.6,
    line_color=None, tools="select,pan,wheel_zoom,box_zoom,reset,previewsave", name="color_scatter_example")

show() # open a browser

all the best,

James

On Wednesday, September 24, 2014 10:01:56 AM UTC-4, Bryan Van de ven wrote:

Hi James,

I think you have exposed a need for better documentation about a core component. I mentioned before that “Running the server does not create any plots, just makes a place for plots to be stored” but that’s only half the story, I left out the other half, which is that once you have a server running, you can run all the scripts in the example directory, separately, in a new shell. Those scripts store plots on the server when you run them, and they should open a browser for you to the right link by default. Let’s run through a complete example:

  • In a first terminal, do this:

[email protected] (git:feature/selection) ~/work/bokeh $ bokeh-server

Bokeh Server Configuration
==========================
python version : 2.7.8
bokeh version  : 0.6.1.dev.20140923
listening      : [127.0.0.1:5006](http://127.0.0.1:5006)
backend        : shelve
python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF
js options     : splitjs:OFF, debugjs:OFF
data-directory : None

zmqpub starting

Starting Bokeh plot server on port 5006…
View http://127.0.0.1:5006/bokeh to see plots

  • Leave the server running, in a NEW terminal, do this:

[email protected] (git:feature/selection) ~/work/bokeh/examples/plotting/server $ python color_scatter.py
Using saved session configuration for http://localhost:5006/

To override, pass ‘load_from_config=False’ to Session

This should automatically open a browser to the single document page for this plot, it will look something like this:

    [http://localhost:5006/bokeh/doc/](http://localhost:5006/bokeh/doc/)<big long UUID>/<another big UUID>

However, maybe it does not work if the server is running on a remote computer. However in any case, now if you navigate to the Bokeh server main page:

    [http://localhost:5006/bokeh/](http://localhost:5006/bokeh/)

You should see the color scatterplot in the list of plots. Note, above it has “localhost” but if you are passing the --ip parameter to the server, then then you would use whatever ip address you specified for the server to listen on instead of “localhost”. However, Bokeh outputs to the localhost server by default, so you will also have to modify the “color_scatterplot.py” example to point it at your specific server address by passing in a “url” parameter to the output_server(…) function (there’s no way for it to magically know where you are running your server). I would suggest trying everything on a single machine with the default server settings, first.

Let me know if this does not work for you.

Byran

On Sep 24, 2014, at 9:46 AM, [email protected] wrote:

Hi,

I’m running Python2.7 on an ArchLinux distro (no X) on a Raspberry Pi and am trying to get bokeh-server working. Unfortunately, I only seem to get the same message “Bokeh Documents for default user” on my browser (running on a different computer). When I fire up bokeh-server I get the following:

[[email protected] server]$ bokeh-server --ip 192.168.1.136

Bokeh Server Configuration

python version : 2.7.8
bokeh version : 0.6.0
listening : 192.168.1.136:5006

backend : shelve
python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF
js options : splitjs:OFF, debugjs:OFF
data-directory : None

zmqpub starting

Starting Bokeh plot server on port 5006…
View http://192.168.1.136:5006/bokeh to see plots

Bryan, you suggested downloading some of the example plots from Github. I’ve done that… now where should I put these example plots on the RPi? How do I tell bokeh-server where to look? I tried

bokeh-server --ip 192.168.1.136 --data-directory /home/jasmith/temp/bokeh-master/examples/plotting/server

but I got the same “Bokeh Documents for default user” message on my browser.

Any suggestions for how to get the bokeh-server to find those example files and display them on the browser would be much appreciated.

all the best,

James

On Saturday, August 16, 2014 12:05:08 PM UTC-4, Bryan Van de ven wrote:
Hi HS,

Thanks for your interest in bokeh! Running the server does not create any plots, just makes a place for plots to be stored. You need to actually create a plot and store it on the server. You can see lots of examples in the examples/plotting/server directory of the GitHub source tree:

    [https://github.com/ContinuumIO/bokeh/tree/master/examples/plotting/server](https://github.com/ContinuumIO/bokeh/tree/master/examples/plotting/server)

Let us know if we can help more!

Bryan

On Aug 16, 2014, at 11:01 AM, [email protected] wrote:

Hi,
I am new to Anaconda and Bokeh and I just installed a fresh Anaconda 3.4 x64.
‘3.4.1 |Anaconda 2.0.1 (64-bit)| (default, Jun 11 2014, 17:27:11) [MSC v.1600 64 bit (AMD64)]’
I installed bokeh using “conda bokeh”

bokeh.server.run()
and got:
Bokeh Server Configuration

listening : 127.0.0.1:5006

backend : shelve
python options : debug:OFF, verbose:OFF, filter-logs:OFF, multi-user:OFF
js options : splitjs:OFF, debugjs:OFF
data-directory : None

Starting Bokeh plot server on port 5006…127.0.0.1 - - [16/Aug/2014 18:53:28] “GET / HTTP/1.1” 302 221
127.0.0.1 - - [16/Aug/2014 18:53:28] “GET /bokeh/ HTTP/1.1” 200 479
127.0.0.1 - - [16/Aug/2014 18:53:30] “GET /bokeh/userinfo/ HTTP/1.1” 200 39
127.0.0.1 - - [16/Aug/2014 18:53:46] “GET /bokeh/sub HTTP/1.1” 200 4

View http://127.0.0.1:5006/bokeh to see plots

I then visited http://localhost:5006/bokeh/ but I see only “Bokeh Documents for defaultuser” and “logout” with no examples appearing.

I have also tried to run
bokeh-server.exe

but it didn’t help.

Additionally, how do I upload new plot to the server, assuming it is working correctly?
Moreover, why do I need redis.io for?

Thanks,
HS.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a0d1995e-9767-4700-a823-12ca3d799a50%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/89b3d159-e97d-4bc9-9265-5ced5e37fbc6%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/209e53e5-e009-4c68-bc28-7bf0bee57606%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.