Can't access bokeh server from other computer

I refer to the below user guide to learn available options for bokeh server :
https://bokeh.pydata.org/en/0.12.7/docs/reference/command/subcommands/serve.html

I ran the following command to allow for any IP address to access the bokeh app:

bokeh serve testuni.py --address 0.0.0.0

2017-08-31 15:55:11,974 Starting Bokeh server version 0.12.7 (running on Tornado 4.5.1)

2017-08-31 15:55:11,976 Bokeh app running at: http://0.0.0.0:5006/testuni

2017-08-31 15:55:11,976 Starting Bokeh server with process id: 13335

But I failed to connect to the app (called testuni) from other computer.

The error message is this as soon as I type in 10.253.239.137:5006/testuni to the browser :

2017-08-31 15:57:29,470 200 GET /testuni (10.253.239.137) 102.34ms

2017-08-31 15:57:29,757 Refusing websocket connection from Origin ‘http://10.253.239.137:5006’; use --allow-websocket-origin=10.253.239.137:5006 to permit this; currently we allow origins {‘localhost:5006’}

2017-08-31 15:57:29,757 403 GET /testuni/ws?bokeh-protocol-version=1.0&bokeh-session-id=DeNyll8GljAN1nhaTCPmuNNVPHFziocLpmF6oCcr8UvZ (10.253.239.137) 0.66ms

I remember it (–address 0.0.0.0) used to work with bokeh version older than 0.12.7.

This is really frustrating me…how can I solve this?

Thank you

I could make it by running the following command:

bokeh serve myapp --allow-websocket-origin=:5006

Previously I wrongly specified as:

–allow-websocket-origin=

Then I still wonder what --address option is used for: I suppose it is used to block a range of remote IP address.

2017년 8월 31일 목요일 오후 4시 19분 6초 UTC+9, Sijun Cho 님의 말:

···

I refer to the below user guide to learn available options for bokeh server :
https://bokeh.pydata.org/en/0.12.7/docs/reference/command/subcommands/serve.html

I ran the following command to allow for any IP address to access the bokeh app:

bokeh serve testuni.py --address 0.0.0.0

2017-08-31 15:55:11,974 Starting Bokeh server version 0.12.7 (running on Tornado 4.5.1)

2017-08-31 15:55:11,976 Bokeh app running at: http://0.0.0.0:5006/testuni

2017-08-31 15:55:11,976 Starting Bokeh server with process id: 13335

But I failed to connect to the app (called testuni) from other computer.

The error message is this as soon as I type in 10.253.239.137:5006/testuni to the browser :

2017-08-31 15:57:29,470 200 GET /testuni (10.253.239.137) 102.34ms

2017-08-31 15:57:29,757 Refusing websocket connection from Origin ‘http://10.253.239.137:5006’; use --allow-websocket-origin=10.253.239.137:5006 to permit this; currently we allow origins {‘localhost:5006’}

2017-08-31 15:57:29,757 403 GET /testuni/ws?bokeh-protocol-version=1.0&bokeh-session-id=DeNyll8GljAN1nhaTCPmuNNVPHFziocLpmF6oCcr8UvZ (10.253.239.137) 0.66ms

I remember it (–address 0.0.0.0) used to work with bokeh version older than 0.12.7.

This is really frustrating me…how can I solve this?

Thank you

Hi,

The --address option specifies what network interfaces the Bokeh server should *listen* on. By contrast --allow-websocket-origin tells the Bokeh server what reported origins are OK to accept web socket connections from. i.e., if your browser URL bar says "foo.com:5006" then "foo.com" needs to be listed explicitly as an allowed origin. By default, Bokeh has a conservative configuration that only includes "localhost".

If you are connecting remotely directly to a Bokeh server these will often be the same (or address might be 0.0.0.0) but that's not true in general, e.g. if you are connecting to a Bokeh server that is running behind a proxy like NGinx that has a different public facing IP/address.

Thanks,

Bryan

···

On Aug 31, 2017, at 02:52, Sijun Cho <[email protected]> wrote:

I could make it by running the following command:

   bokeh serve myapp --allow-websocket-origin=<IP address on which myapp runs>:5006

Previously I wrongly specified as:
   --allow-websocket-origin=<IP address from which I try to connect to myapp>

Then I still wonder what --address option is used for: I suppose it is used to block a range of remote IP address.

2017년 8월 31일 목요일 오후 4시 19분 6초 UTC+9, Sijun Cho 님의 말:
I refer to the below user guide to learn available options for bokeh server :
    https://bokeh.pydata.org/en/0.12.7/docs/reference/command/subcommands/serve.html

I ran the following command to allow for any IP address to access the bokeh app:
   bokeh serve testuni.py --address 0.0.0.0

2017-08-31 15:55:11,974 Starting Bokeh server version 0.12.7 (running on Tornado 4.5.1)
2017-08-31 15:55:11,976 Bokeh app running at: http://0.0.0.0:5006/testuni
2017-08-31 15:55:11,976 Starting Bokeh server with process id: 13335

But I failed to connect to the app (called testuni) from other computer.

The error message is this as soon as I type in 10.253.239.137:5006/testuni to the browser :

2017-08-31 15:57:29,470 200 GET /testuni (10.253.239.137) 102.34ms
2017-08-31 15:57:29,757 Refusing websocket connection from Origin 'http://10.253.239.137:5006'; use --allow-websocket-origin=10.253.239.137:5006 to permit this; currently we allow origins {'localhost:5006'}
2017-08-31 15:57:29,757 403 GET /testuni/ws?bokeh-protocol-version=1.0&bokeh-session-id=DeNyll8GljAN1nhaTCPmuNNVPHFziocLpmF6oCcr8UvZ (10.253.239.137) 0.66ms

I remember it (--address 0.0.0.0) used to work with bokeh version older than 0.12.7.

This is really frustrating me....how can I solve this?

Thank you

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/dd90a4a1-3778-4ac9-9e28-7a3d59594e1d%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Thank you Bryan. Now it is very clear to me.

Sijun

2017년 8월 31일 목요일 오후 11시 36분 13초 UTC+9, Bryan Van de ven 님의 말:

···

Hi,

The --address option specifies what network interfaces the Bokeh server should listen on. By contrast --allow-websocket-origin tells the Bokeh server what reported origins are OK to accept web socket connections from. i.e., if your browser URL bar says “foo.com:5006” then “foo.com” needs to be listed explicitly as an allowed origin. By default, Bokeh has a conservative configuration that only includes “localhost”.

If you are connecting remotely directly to a Bokeh server these will often be the same (or address might be 0.0.0.0) but that’s not true in general, e.g. if you are connecting to a Bokeh server that is running behind a proxy like NGinx that has a different public facing IP/address.

Thanks,

Bryan

On Aug 31, 2017, at 02:52, Sijun Cho [email protected] wrote:

I could make it by running the following command:

bokeh serve myapp --allow-websocket-origin=:5006

Previously I wrongly specified as:

–allow-websocket-origin=

Then I still wonder what --address option is used for: I suppose it is used to block a range of remote IP address.

2017년 8월 31일 목요일 오후 4시 19분 6초 UTC+9, Sijun Cho 님의 말:

I refer to the below user guide to learn available options for bokeh server :

[https://bokeh.pydata.org/en/0.12.7/docs/reference/command/subcommands/serve.html](https://bokeh.pydata.org/en/0.12.7/docs/reference/command/subcommands/serve.html)

I ran the following command to allow for any IP address to access the bokeh app:

bokeh serve testuni.py --address 0.0.0.0

2017-08-31 15:55:11,974 Starting Bokeh server version 0.12.7 (running on Tornado 4.5.1)

2017-08-31 15:55:11,976 Bokeh app running at: http://0.0.0.0:5006/testuni

2017-08-31 15:55:11,976 Starting Bokeh server with process id: 13335

But I failed to connect to the app (called testuni) from other computer.

The error message is this as soon as I type in 10.253.239.137:5006/testuni to the browser :

2017-08-31 15:57:29,470 200 GET /testuni (10.253.239.137) 102.34ms

2017-08-31 15:57:29,757 Refusing websocket connection from Origin ‘http://10.253.239.137:5006’; use --allow-websocket-origin=10.253.239.137:5006 to permit this; currently we allow origins {‘localhost:5006’}

2017-08-31 15:57:29,757 403 GET /testuni/ws?bokeh-protocol-version=1.0&bokeh-session-id=DeNyll8GljAN1nhaTCPmuNNVPHFziocLpmF6oCcr8UvZ (10.253.239.137) 0.66ms

I remember it (–address 0.0.0.0) used to work with bokeh version older than 0.12.7.

This is really frustrating me…how can I solve this?

Thank you


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/dd90a4a1-3778-4ac9-9e28-7a3d59594e1d%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Hello Bryan,

Now I have run into a new situation.

I ran the following command:

bokeh serve myapp1 --address 0.0.0.0 --allow-websocket-origin=10.253.239.137:5006

and then ran:

bokeh serve myapp2 --address 0.0.0.0 --allow-websocket-origin=10.253.239.137 --port 5007

I can access myapp1 but I can’t access myapp2. I am getting the following error messages for myapp2:

2017-09-11 22:23:36,722 Refusing websocket connection from Origin ‘http://10.253.239.137:5007’; use --allow-websocket-origin=10.253.239.137:5007 to permit this; currently we allow origins {‘10.253.239.137:80’}

2017-09-11 22:23:36,722 403 GET /myapp2/ws?bokeh-protocol-version=1.0&bokeh-session-id=kEAFMVfYJ7yvYxcFt4GGylru0URi5WH0REYznyBpIHUm (10.253.69.141) 0.72ms

How could I solve this problem?

Thanks

– Sijun

2017년 9월 1일 금요일 오후 4시 48분 52초 UTC+9, Sijun Cho 님의 말:

···

Thank you Bryan. Now it is very clear to me.

Sijun

2017년 8월 31일 목요일 오후 11시 36분 13초 UTC+9, Bryan Van de ven 님의 말:

Hi,

The --address option specifies what network interfaces the Bokeh server should listen on. By contrast --allow-websocket-origin tells the Bokeh server what reported origins are OK to accept web socket connections from. i.e., if your browser URL bar says “foo.com:5006” then “foo.com” needs to be listed explicitly as an allowed origin. By default, Bokeh has a conservative configuration that only includes “localhost”.

If you are connecting remotely directly to a Bokeh server these will often be the same (or address might be 0.0.0.0) but that’s not true in general, e.g. if you are connecting to a Bokeh server that is running behind a proxy like NGinx that has a different public facing IP/address.

Thanks,

Bryan

On Aug 31, 2017, at 02:52, Sijun Cho [email protected] wrote:

I could make it by running the following command:

bokeh serve myapp --allow-websocket-origin=:5006

Previously I wrongly specified as:

–allow-websocket-origin=

Then I still wonder what --address option is used for: I suppose it is used to block a range of remote IP address.

2017년 8월 31일 목요일 오후 4시 19분 6초 UTC+9, Sijun Cho 님의 말:

I refer to the below user guide to learn available options for bokeh server :

[https://bokeh.pydata.org/en/0.12.7/docs/reference/command/subcommands/serve.html](https://bokeh.pydata.org/en/0.12.7/docs/reference/command/subcommands/serve.html)

I ran the following command to allow for any IP address to access the bokeh app:

bokeh serve testuni.py --address 0.0.0.0

2017-08-31 15:55:11,974 Starting Bokeh server version 0.12.7 (running on Tornado 4.5.1)

2017-08-31 15:55:11,976 Bokeh app running at: http://0.0.0.0:5006/testuni

2017-08-31 15:55:11,976 Starting Bokeh server with process id: 13335

But I failed to connect to the app (called testuni) from other computer.

The error message is this as soon as I type in 10.253.239.137:5006/testuni to the browser :

2017-08-31 15:57:29,470 200 GET /testuni (10.253.239.137) 102.34ms

2017-08-31 15:57:29,757 Refusing websocket connection from Origin ‘http://10.253.239.137:5006’; use --allow-websocket-origin=10.253.239.137:5006 to permit this; currently we allow origins {‘localhost:5006’}

2017-08-31 15:57:29,757 403 GET /testuni/ws?bokeh-protocol-version=1.0&bokeh-session-id=DeNyll8GljAN1nhaTCPmuNNVPHFziocLpmF6oCcr8UvZ (10.253.239.137) 0.66ms

I remember it (–address 0.0.0.0) used to work with bokeh version older than 0.12.7.

This is really frustrating me…how can I solve this?

Thank you


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/dd90a4a1-3778-4ac9-9e28-7a3d59594e1d%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Hi,

The corrective action is included in the message. If you want to allow connections from the origin "10.253.239.137:5007" then you need to have

  --allow-websocket-origin=10.253.239.137:5007

which is different from what you've shown.

--port specifies what port the Bokeh server should *listen* on

--allow-websocket-origin specifies what origins (i.e. URL bar locations) are allowed to *connect*

Thanks,

Bryan

···

On Sep 11, 2017, at 08:26, Sijun Cho <[email protected]> wrote:

Hello Bryan,

Now I have run into a new situation.

I ran the following command:
    
   bokeh serve myapp1 --address 0.0.0.0 --allow-websocket-origin=10.253.239.137:5006

and then ran:
   bokeh serve myapp2 --address 0.0.0.0 --allow-websocket-origin=10.253.239.137 --port 5007

I can access myapp1 but I can't access myapp2. I am getting the following error messages for myapp2:

2017-09-11 22:23:36,722 Refusing websocket connection from Origin 'http://10.253.239.137:5007'; use --allow-websocket-origin=10.253.239.137:5007 to permit this; currently we allow origins {'10.253.239.137:80'}
2017-09-11 22:23:36,722 403 GET /myapp2/ws?bokeh-protocol-version=1.0&bokeh-session-id=kEAFMVfYJ7yvYxcFt4GGylru0URi5WH0REYznyBpIHUm (10.253.69.141) 0.72ms

How could I solve this problem?

Thanks
-- Sijun

2017년 9월 1일 금요일 오후 4시 48분 52초 UTC+9, Sijun Cho 님의 말:
Thank you Bryan. Now it is very clear to me.

Sijun

2017년 8월 31일 목요일 오후 11시 36분 13초 UTC+9, Bryan Van de ven 님의 말:
Hi,

The --address option specifies what network interfaces the Bokeh server should *listen* on. By contrast --allow-websocket-origin tells the Bokeh server what reported origins are OK to accept web socket connections from. i.e., if your browser URL bar says "foo.com:5006" then "foo.com" needs to be listed explicitly as an allowed origin. By default, Bokeh has a conservative configuration that only includes "localhost".

If you are connecting remotely directly to a Bokeh server these will often be the same (or address might be 0.0.0.0) but that's not true in general, e.g. if you are connecting to a Bokeh server that is running behind a proxy like NGinx that has a different public facing IP/address.

Thanks,

Bryan

> On Aug 31, 2017, at 02:52, Sijun Cho <[email protected]> wrote:
>
> I could make it by running the following command:
>
> bokeh serve myapp --allow-websocket-origin=<IP address on which myapp runs>:5006
>
> Previously I wrongly specified as:
> --allow-websocket-origin=<IP address from which I try to connect to myapp>
>
> Then I still wonder what --address option is used for: I suppose it is used to block a range of remote IP address.
>
>
> 2017년 8월 31일 목요일 오후 4시 19분 6초 UTC+9, Sijun Cho 님의 말:
> I refer to the below user guide to learn available options for bokeh server :
> https://bokeh.pydata.org/en/0.12.7/docs/reference/command/subcommands/serve.html
>
> I ran the following command to allow for any IP address to access the bokeh app:
> bokeh serve testuni.py --address 0.0.0.0
>
> 2017-08-31 15:55:11,974 Starting Bokeh server version 0.12.7 (running on Tornado 4.5.1)
> 2017-08-31 15:55:11,976 Bokeh app running at: http://0.0.0.0:5006/testuni
> 2017-08-31 15:55:11,976 Starting Bokeh server with process id: 13335
>
> But I failed to connect to the app (called testuni) from other computer.
>
> The error message is this as soon as I type in 10.253.239.137:5006/testuni to the browser :
>
> 2017-08-31 15:57:29,470 200 GET /testuni (10.253.239.137) 102.34ms
> 2017-08-31 15:57:29,757 Refusing websocket connection from Origin 'http://10.253.239.137:5006'; use --allow-websocket-origin=10.253.239.137:5006 to permit this; currently we allow origins {'localhost:5006'}
> 2017-08-31 15:57:29,757 403 GET /testuni/ws?bokeh-protocol-version=1.0&bokeh-session-id=DeNyll8GljAN1nhaTCPmuNNVPHFziocLpmF6oCcr8UvZ (10.253.239.137) 0.66ms
>
> I remember it (--address 0.0.0.0) used to work with bokeh version older than 0.12.7.
>
> This is really frustrating me....how can I solve this?
>
> Thank you
>
>
>
>
>
>
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/dd90a4a1-3778-4ac9-9e28-7a3d59594e1d%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/86e2c582-439e-4237-8d3f-3966f0505c62%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

I tried:

bokeh serve myapp2 --address 0.0.0.0 --host=10.253.239.137:5007

But I am getting still another error:

/home/sijun.cho/anaconda3/lib/python3.6/site-packages/bokeh/command/subcommands/serve.py:320: UserWarning: The --host parameter is deprecated because it is no longer needed. It will be removed and trigger an error in a future release. Values set now will be copied to --allow-websocket-origin. Depending on your use case, you may need to set current --host values for ‘allow_websocket_origin’ instead.

"The --host parameter is deprecated because it is no longer needed. "

2017-09-11 22:57:02,695 Starting Bokeh server version 0.12.7 (running on Tornado 4.5.1)

2017-09-11 22:57:02,696 Cannot start Bokeh server, port 5006 is already in use

2017년 9월 11일 월요일 오후 10시 38분 17초 UTC+9, Bryan Van de ven 님의 말:

···

Hi,

The corrective action is included in the message. If you want to allow connections from the origin “10.253.239.137:5007” then you need to have

    --allow-websocket-origin=[10.253.239.137:5007](http://10.253.239.137:5007)

which is different from what you’ve shown.

–port specifies what port the Bokeh server should listen on

–allow-websocket-origin specifies what origins (i.e. URL bar locations) are allowed to connect

Thanks,

Bryan

On Sep 11, 2017, at 08:26, Sijun Cho [email protected] wrote:

Hello Bryan,

Now I have run into a new situation.

I ran the following command:

bokeh serve myapp1 --address 0.0.0.0 --allow-websocket-origin=10.253.239.137:5006

and then ran:

bokeh serve myapp2 --address 0.0.0.0 --allow-websocket-origin=10.253.239.137 --port 5007

I can access myapp1 but I can’t access myapp2. I am getting the following error messages for myapp2:

2017-09-11 22:23:36,722 Refusing websocket connection from Origin ‘http://10.253.239.137:5007’; use --allow-websocket-origin=10.253.239.137:5007 to permit this; currently we allow origins {‘10.253.239.137:80’}

2017-09-11 22:23:36,722 403 GET /myapp2/ws?bokeh-protocol-version=1.0&bokeh-session-id=kEAFMVfYJ7yvYxcFt4GGylru0URi5WH0REYznyBpIHUm (10.253.69.141) 0.72ms

How could I solve this problem?

Thanks

– Sijun

2017년 9월 1일 금요일 오후 4시 48분 52초 UTC+9, Sijun Cho 님의 말:

Thank you Bryan. Now it is very clear to me.

Sijun

2017년 8월 31일 목요일 오후 11시 36분 13초 UTC+9, Bryan Van de ven 님의 말:

Hi,

The --address option specifies what network interfaces the Bokeh server should listen on. By contrast --allow-websocket-origin tells the Bokeh server what reported origins are OK to accept web socket connections from. i.e., if your browser URL bar says “foo.com:5006” then “foo.com” needs to be listed explicitly as an allowed origin. By default, Bokeh has a conservative configuration that only includes “localhost”.

If you are connecting remotely directly to a Bokeh server these will often be the same (or address might be 0.0.0.0) but that’s not true in general, e.g. if you are connecting to a Bokeh server that is running behind a proxy like NGinx that has a different public facing IP/address.

Thanks,

Bryan

On Aug 31, 2017, at 02:52, Sijun Cho [email protected] wrote:

I could make it by running the following command:

bokeh serve myapp --allow-websocket-origin=:5006

Previously I wrongly specified as:
–allow-websocket-origin=

Then I still wonder what --address option is used for: I suppose it is used to block a range of remote IP address.

2017년 8월 31일 목요일 오후 4시 19분 6초 UTC+9, Sijun Cho 님의 말:
I refer to the below user guide to learn available options for bokeh server :
https://bokeh.pydata.org/en/0.12.7/docs/reference/command/subcommands/serve.html

I ran the following command to allow for any IP address to access the bokeh app:
bokeh serve testuni.py --address 0.0.0.0

2017-08-31 15:55:11,974 Starting Bokeh server version 0.12.7 (running on Tornado 4.5.1)
2017-08-31 15:55:11,976 Bokeh app running at: http://0.0.0.0:5006/testuni

2017-08-31 15:55:11,976 Starting Bokeh server with process id: 13335

But I failed to connect to the app (called testuni) from other computer.

The error message is this as soon as I type in 10.253.239.137:5006/testuni to the browser :

2017-08-31 15:57:29,470 200 GET /testuni (10.253.239.137) 102.34ms
2017-08-31 15:57:29,757 Refusing websocket connection from Origin ‘http://10.253.239.137:5006’; use --allow-websocket-origin=10.253.239.137:5006 to permit this; currently we allow origins {‘localhost:5006’}
2017-08-31 15:57:29,757 403 GET /testuni/ws?bokeh-protocol-version=1.0&bokeh-session-id=DeNyll8GljAN1nhaTCPmuNNVPHFziocLpmF6oCcr8UvZ (10.253.239.137) 0.66ms

I remember it (–address 0.0.0.0) used to work with bokeh version older than 0.12.7.

This is really frustrating me…how can I solve this?

Thank you


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/dd90a4a1-3778-4ac9-9e28-7a3d59594e1d%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/86e2c582-439e-4237-8d3f-3966f0505c62%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Sorry I made a typo.

Here is what I did:

bokeh serve myapp2 --address 0.0.0.0 –allow-websocket-origin=10.253.239.137:5007

And the following is the error:

2017-09-11 23:03:18,733 Starting Bokeh server version 0.12.7 (running on Tornado 4.5.1)

2017-09-11 23:03:18,733 Cannot start Bokeh server, port 5006 is already in use

2017년 9월 11일 월요일 오후 11시 0분 39초 UTC+9, Sijun Cho 님의 말:

···

I tried:

bokeh serve myapp2 --address 0.0.0.0 --host=10.253.239.137:5007

But I am getting still another error:

/home/sijun.cho/anaconda3/lib/python3.6/site-packages/bokeh/command/subcommands/serve.py:320: UserWarning: The --host parameter is deprecated because it is no longer needed. It will be removed and trigger an error in a future release. Values set now will be copied to --allow-websocket-origin. Depending on your use case, you may need to set current --host values for ‘allow_websocket_origin’ instead.

"The --host parameter is deprecated because it is no longer needed. "

2017-09-11 22:57:02,695 Starting Bokeh server version 0.12.7 (running on Tornado 4.5.1)

2017-09-11 22:57:02,696 Cannot start Bokeh server, port 5006 is already in use

2017년 9월 11일 월요일 오후 10시 38분 17초 UTC+9, Bryan Van de ven 님의 말:

Hi,

The corrective action is included in the message. If you want to allow connections from the origin “10.253.239.137:5007” then you need to have

    --allow-websocket-origin=[10.253.239.137:5007](http://10.253.239.137:5007)

which is different from what you’ve shown.

–port specifies what port the Bokeh server should listen on

–allow-websocket-origin specifies what origins (i.e. URL bar locations) are allowed to connect

Thanks,

Bryan

On Sep 11, 2017, at 08:26, Sijun Cho [email protected] wrote:

Hello Bryan,

Now I have run into a new situation.

I ran the following command:

bokeh serve myapp1 --address 0.0.0.0 --allow-websocket-origin=10.253.239.137:5006

and then ran:

bokeh serve myapp2 --address 0.0.0.0 --allow-websocket-origin=10.253.239.137 --port 5007

I can access myapp1 but I can’t access myapp2. I am getting the following error messages for myapp2:

2017-09-11 22:23:36,722 Refusing websocket connection from Origin ‘http://10.253.239.137:5007’; use --allow-websocket-origin=10.253.239.137:5007 to permit this; currently we allow origins {‘10.253.239.137:80’}

2017-09-11 22:23:36,722 403 GET /myapp2/ws?bokeh-protocol-version=1.0&bokeh-session-id=kEAFMVfYJ7yvYxcFt4GGylru0URi5WH0REYznyBpIHUm (10.253.69.141) 0.72ms

How could I solve this problem?

Thanks

– Sijun

2017년 9월 1일 금요일 오후 4시 48분 52초 UTC+9, Sijun Cho 님의 말:

Thank you Bryan. Now it is very clear to me.

Sijun

2017년 8월 31일 목요일 오후 11시 36분 13초 UTC+9, Bryan Van de ven 님의 말:

Hi,

The --address option specifies what network interfaces the Bokeh server should listen on. By contrast --allow-websocket-origin tells the Bokeh server what reported origins are OK to accept web socket connections from. i.e., if your browser URL bar says “foo.com:5006” then “foo.com” needs to be listed explicitly as an allowed origin. By default, Bokeh has a conservative configuration that only includes “localhost”.

If you are connecting remotely directly to a Bokeh server these will often be the same (or address might be 0.0.0.0) but that’s not true in general, e.g. if you are connecting to a Bokeh server that is running behind a proxy like NGinx that has a different public facing IP/address.

Thanks,

Bryan

On Aug 31, 2017, at 02:52, Sijun Cho [email protected] wrote:

I could make it by running the following command:

bokeh serve myapp --allow-websocket-origin=:5006

Previously I wrongly specified as:
–allow-websocket-origin=

Then I still wonder what --address option is used for: I suppose it is used to block a range of remote IP address.

2017년 8월 31일 목요일 오후 4시 19분 6초 UTC+9, Sijun Cho 님의 말:
I refer to the below user guide to learn available options for bokeh server :
https://bokeh.pydata.org/en/0.12.7/docs/reference/command/subcommands/serve.html

I ran the following command to allow for any IP address to access the bokeh app:
bokeh serve testuni.py --address 0.0.0.0

2017-08-31 15:55:11,974 Starting Bokeh server version 0.12.7 (running on Tornado 4.5.1)
2017-08-31 15:55:11,976 Bokeh app running at: http://0.0.0.0:5006/testuni

2017-08-31 15:55:11,976 Starting Bokeh server with process id: 13335

But I failed to connect to the app (called testuni) from other computer.

The error message is this as soon as I type in 10.253.239.137:5006/testuni to the browser :

2017-08-31 15:57:29,470 200 GET /testuni (10.253.239.137) 102.34ms
2017-08-31 15:57:29,757 Refusing websocket connection from Origin ‘http://10.253.239.137:5006’; use --allow-websocket-origin=10.253.239.137:5006 to permit this; currently we allow origins {‘localhost:5006’}
2017-08-31 15:57:29,757 403 GET /testuni/ws?bokeh-protocol-version=1.0&bokeh-session-id=DeNyll8GljAN1nhaTCPmuNNVPHFziocLpmF6oCcr8UvZ (10.253.239.137) 0.66ms

I remember it (–address 0.0.0.0) used to work with bokeh version older than 0.12.7.

This is really frustrating me…how can I solve this?

Thank you


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/dd90a4a1-3778-4ac9-9e28-7a3d59594e1d%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/86e2c582-439e-4237-8d3f-3966f0505c62%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Oh I got it.

I should have done as follows:

bokeh serve myapp2 --address 0.0.0.0 –allow-websocket-origin=10.253.239.137:5007 --port 5007

Thanks!

Sijun

2017년 9월 11일 월요일 오후 11시 5분 5초 UTC+9, Sijun Cho 님의 말:

···

Sorry I made a typo.

Here is what I did:

bokeh serve myapp2 --address 0.0.0.0 –allow-websocket-origin=10.253.239.137:5007

And the following is the error:

2017-09-11 23:03:18,733 Starting Bokeh server version 0.12.7 (running on Tornado 4.5.1)

2017-09-11 23:03:18,733 Cannot start Bokeh server, port 5006 is already in use

2017년 9월 11일 월요일 오후 11시 0분 39초 UTC+9, Sijun Cho 님의 말:

I tried:

bokeh serve myapp2 --address 0.0.0.0 --host=10.253.239.137:5007

But I am getting still another error:

/home/sijun.cho/anaconda3/lib/python3.6/site-packages/bokeh/command/subcommands/serve.py:320: UserWarning: The --host parameter is deprecated because it is no longer needed. It will be removed and trigger an error in a future release. Values set now will be copied to --allow-websocket-origin. Depending on your use case, you may need to set current --host values for ‘allow_websocket_origin’ instead.

"The --host parameter is deprecated because it is no longer needed. "

2017-09-11 22:57:02,695 Starting Bokeh server version 0.12.7 (running on Tornado 4.5.1)

2017-09-11 22:57:02,696 Cannot start Bokeh server, port 5006 is already in use

2017년 9월 11일 월요일 오후 10시 38분 17초 UTC+9, Bryan Van de ven 님의 말:

Hi,

The corrective action is included in the message. If you want to allow connections from the origin “10.253.239.137:5007” then you need to have

    --allow-websocket-origin=[10.253.239.137:5007](http://10.253.239.137:5007)

which is different from what you’ve shown.

–port specifies what port the Bokeh server should listen on

–allow-websocket-origin specifies what origins (i.e. URL bar locations) are allowed to connect

Thanks,

Bryan

On Sep 11, 2017, at 08:26, Sijun Cho [email protected] wrote:

Hello Bryan,

Now I have run into a new situation.

I ran the following command:

bokeh serve myapp1 --address 0.0.0.0 --allow-websocket-origin=10.253.239.137:5006

and then ran:

bokeh serve myapp2 --address 0.0.0.0 --allow-websocket-origin=10.253.239.137 --port 5007

I can access myapp1 but I can’t access myapp2. I am getting the following error messages for myapp2:

2017-09-11 22:23:36,722 Refusing websocket connection from Origin ‘http://10.253.239.137:5007’; use --allow-websocket-origin=10.253.239.137:5007 to permit this; currently we allow origins {‘10.253.239.137:80’}

2017-09-11 22:23:36,722 403 GET /myapp2/ws?bokeh-protocol-version=1.0&bokeh-session-id=kEAFMVfYJ7yvYxcFt4GGylru0URi5WH0REYznyBpIHUm (10.253.69.141) 0.72ms

How could I solve this problem?

Thanks

– Sijun

2017년 9월 1일 금요일 오후 4시 48분 52초 UTC+9, Sijun Cho 님의 말:

Thank you Bryan. Now it is very clear to me.

Sijun

2017년 8월 31일 목요일 오후 11시 36분 13초 UTC+9, Bryan Van de ven 님의 말:

Hi,

The --address option specifies what network interfaces the Bokeh server should listen on. By contrast --allow-websocket-origin tells the Bokeh server what reported origins are OK to accept web socket connections from. i.e., if your browser URL bar says “foo.com:5006” then “foo.com” needs to be listed explicitly as an allowed origin. By default, Bokeh has a conservative configuration that only includes “localhost”.

If you are connecting remotely directly to a Bokeh server these will often be the same (or address might be 0.0.0.0) but that’s not true in general, e.g. if you are connecting to a Bokeh server that is running behind a proxy like NGinx that has a different public facing IP/address.

Thanks,

Bryan

On Aug 31, 2017, at 02:52, Sijun Cho [email protected] wrote:

I could make it by running the following command:

bokeh serve myapp --allow-websocket-origin=:5006

Previously I wrongly specified as:
–allow-websocket-origin=

Then I still wonder what --address option is used for: I suppose it is used to block a range of remote IP address.

2017년 8월 31일 목요일 오후 4시 19분 6초 UTC+9, Sijun Cho 님의 말:
I refer to the below user guide to learn available options for bokeh server :
https://bokeh.pydata.org/en/0.12.7/docs/reference/command/subcommands/serve.html

I ran the following command to allow for any IP address to access the bokeh app:
bokeh serve testuni.py --address 0.0.0.0

2017-08-31 15:55:11,974 Starting Bokeh server version 0.12.7 (running on Tornado 4.5.1)
2017-08-31 15:55:11,976 Bokeh app running at: http://0.0.0.0:5006/testuni

2017-08-31 15:55:11,976 Starting Bokeh server with process id: 13335

But I failed to connect to the app (called testuni) from other computer.

The error message is this as soon as I type in 10.253.239.137:5006/testuni to the browser :

2017-08-31 15:57:29,470 200 GET /testuni (10.253.239.137) 102.34ms
2017-08-31 15:57:29,757 Refusing websocket connection from Origin ‘http://10.253.239.137:5006’; use --allow-websocket-origin=10.253.239.137:5006 to permit this; currently we allow origins {‘localhost:5006’}
2017-08-31 15:57:29,757 403 GET /testuni/ws?bokeh-protocol-version=1.0&bokeh-session-id=DeNyll8GljAN1nhaTCPmuNNVPHFziocLpmF6oCcr8UvZ (10.253.239.137) 0.66ms

I remember it (–address 0.0.0.0) used to work with bokeh version older than 0.12.7.

This is really frustrating me…how can I solve this?

Thank you


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/dd90a4a1-3778-4ac9-9e28-7a3d59594e1d%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/86e2c582-439e-4237-8d3f-3966f0505c62%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.