Change Canvas Z-Index

Bokeh sets z-indices for the plots that look like:

<div class="bk-canvas-wrapper" style="z-index: 50;"...

I’ve noticed that when I scroll, the canvas covers the navigation menu on my page (which has no z-index). However, assigning a z-index of 10,000 to my navigation menu did not help and only changing the bk-canvas-wrapper to z-index: 0 solved the problem (done in Chrome developer mode). I couldn’t find a transparent way to set the z-index for the bokeh canvas so I’m posting here.

Any help would be greatly appreciated!

As a stop-gap, I’m using a custom.css file that specifies:

div.bk-canvas-wrapper{z-index: 0!important;}

This solves the problem but it’s not pretty…

···

On Friday, May 27, 2016 at 11:02:51 AM UTC-4, [email protected] wrote:

Bokeh sets z-indices for the plots that look like:

<div class="bk-canvas-wrapper" style="z-index: 50;"...

I’ve noticed that when I scroll, the canvas covers the navigation menu on my page (which has no z-index). However, assigning a z-index of 10,000 to my navigation menu did not help and only changing the bk-canvas-wrapper to z-index: 0 solved the problem (done in Chrome developer mode). I couldn’t find a transparent way to set the z-index for the bokeh canvas so I’m posting here.

Any help would be greatly appreciated!

Sean this seems like it might be a nice thing to expose as a configurable. Not needed often, but when it is, it is. Can you open a feature request on GH describing this?

Bryan

···

On May 27, 2016, at 10:08 AM, [email protected] wrote:

As a stop-gap, I'm using a custom.css file that specifies:

div.bk-canvas-wrapper{z-index: 0!important;}

This solves the problem but it's not pretty...

On Friday, May 27, 2016 at 11:02:51 AM UTC-4, [email protected] wrote:
Bokeh sets z-indices for the plots that look like:

<div class="bk-canvas-wrapper" style="z-index: 50;"...

I've noticed that when I scroll, the canvas covers the navigation menu on my page (which has no z-index). However, assigning a z-index of 10,000 to my navigation menu did not help and only changing the bk-canvas-wrapper to z-index: 0 solved the problem (done in Chrome developer mode). I couldn't find a transparent way to set the z-index for the bokeh canvas so I'm posting here.

Any help would be greatly appreciated!

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/21fefbeb-e92b-40f7-92ad-5559bb9a3fc1%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Hi Sean.

z-indexes are still som ething
that everyt ime i think i’ve
understood it gets me. two
things that can pla y
into it are position
(absolute and relat ive)
and the nesting.

                                              Try

setting position
relative on your nav or your
nav’s parents?

For the future: in the PR that just merged, the z-index is now
set in bokeh’s css, so you should be able to override it without the important.
Here are the lines:
(note that everything in bokeh

                                                      Sorry to

not be more
help. It’s tough without a page
to look at.

                                                      Best,

                                                      Bird
···

https://github.com/bokeh/bokeh/blob/master/bokehjs/src/less/bokeh-layout.less#L17css i s nested
inside .bk-root)
On 5/27/16 8:13 AM, Bryan Van de Ven
wrote:


Sean this seems like it might be a nice thing to expose as a configurable. Not needed often, but when it is, it is. Can you open a feature request on GH describing this?
Bryan

On May 27, 2016, at 10:08 AM, wrote:
As a stop-gap, I'm using a custom.css file that specifies:
div.bk-canvas-wrapper{z-index: 0!important;}
This solves the problem but it's not pretty...
On Friday, May 27, 2016 at 11:02:51 AM UTC-4, wrote:
Bokeh sets z-indices for the plots that look like:
<div class="bk-canvas-wrapper" style="z-index: 50;"...
I've noticed that when I scroll, the canvas covers the navigation menu on my page (which has no z-index). However, assigning a z-index of 10,000 to my navigation menu did not help and only changing the bk-canvas-wrapper to z-index: 0 solved the problem (done in Chrome developer mode). I couldn't find a transparent way to set the z-index for the bokeh canvas so I'm posting here.
Any help would be greatly appreciated!
-- You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to .
To post to this group, send email to .
To view this discussion on the web visit .
For more options, visit .


Sarah Bird
Developer, Bokeh

    [
      ![Continuum Analytics](http://docs.continuum.io/_static/img/ContinuumWordmark.png)
    ](http://continuum.io)

[email protected]…@[email protected]@continuum.iohttps://groups.google.com/a/continuum.io/d/msgid/bokeh/21fefbeb-e92b-40f7-92ad-5559bb9a3fc1%40continuum.iohttps://groups.google.com/a/continuum.io/d/optout