Custom CSS doesn't work in Docker but is fine locally

The structure of the app is a repository with several bokeh apps (as directories).

There’s a in the current directory and it’s a bit messy with regards to HTML and CSS but is working.

Another developer has then added a templates folder (current/templates) and that contains an index.html and a styles.css.

The index.html does a Jinja include to get the styles.css inside of it.

When I run this locally with:

_bokeh serve current testing hypothesis_kit mixpanel testing_timestamps multivariant_corrections --address --port 5006 --host '*'_

The custom styling works and you can inspect it with dev tools etc.
But when I run the *exact* same command within a local Docker container (same Python version as local and has been working fine in production up until now..):
The *templates/index.html* seems to be completely ignored, or is somehow overwritten (assumably) by the mess that is current/**

On both occasions I'm accessing it the same way, via *localhost:5006/current*.
I can appreciate that it's probably the messy ** that's causing this.. but I would have expected the same behaviour with and without the Docker container.

Any ideas why I'm seeing different things?

Ok so turns out it was because of the casing.
It should have been templates and not Templates.

Why would that work locally and not when deployed though?