Embedding a plot on in a web-facing application ERR CONNECTION REFUSED.

Hi Everyone,

I have been updating my application to work with bokeh 0.11, although I am still not able to get anything to run on an actual web-facing application. I have a very simple plot coming from a Flask view.

@main.route(’/_get_chart’, methods=[‘POST’])
def get_chart():

plot = Line(data=df)
session = push_session(curdoc())
script = autoload_server(plot, session_id=session.id)
return jsonify({‘plot_tag’: script })

This works on my development server (local machine), although once I try to put it on an actual web-facing server, the autoload.js is refused.

On the development machine, I start the server with (env)$ bokeh serve --allow-websocket-origin=127.0.0.1:5000

On the server, I start it with (env)$ bokeh serve --allow-websocket-origin=45...**:8098

The error I am getting from the web-facing server in the javascript console is:

GET http://localhost:5006/autoload.js?bokeh-autoload-element=09ab05db-8a33-4295…eh-session-id=i0ZMNFuvUMmhYpaIVaeG2po4PWWU9KuyX1TQ8sswuA6m&_=1458238746733 net::ERR_CONNECTION_REFUSED

When the chart is requested, The web-facing bokeh server debug log is showing the following:

INFO:bokeh.server.views.ws:WebSocket connection opened

DEBUG:bokeh.server.views.ws:Receiver created for Protocol(u’1.0’)

DEBUG:bokeh.server.views.ws:ServerHandler created for Protocol(u’1.0’)

INFO:bokeh.server.views.ws:ServerConnection created

DEBUG:bokeh.server.tornado:[pid 25191] 1 clients connected

DEBUG:bokeh.server.tornado:[pid 25191] / has 1 sessions with 0 unused

DEBUG:bokeh.server.session:pushing doc to session u’4g6Yj2kQ2CwULKDBqJo39s1XT2g9YusTDeNnKACvKVo6’

DEBUG:bokeh.server.tornado:[pid 25191] 1 clients connected

DEBUG:bokeh.server.tornado:[pid 25191] / has 1 sessions with 0 unused

And this is from the bokeh server output on the local development server:

INFO:bokeh.server.views.ws:WebSocket connection opened

DEBUG:bokeh.server.views.ws:Receiver created for Protocol(u’1.0’)

DEBUG:bokeh.server.views.ws:ServerHandler created for Protocol(u’1.0’)

INFO:bokeh.server.views.ws:ServerConnection created

DEBUG:bokeh.server.tornado:[pid 21464] 1 clients connected

DEBUG:bokeh.server.session:pushing doc to session u’Laj6FCXEhKYYtBjf4k9Pmi1LiLbsrES4YDX3hVAgB1Eh’

INFO:tornado.access:200 GET /autoload.js?bokeh-autoload-element=6f65f30d-f9a9-4512-8d1c-bbb292ad8337&bokeh-session-id=Laj6FCXEhKYYtBjf4k9Pmi1LiLbsrES4YDX3hVAgB1Eh&_=1458240123400 (127.0.0.1) 5.94ms

INFO:tornado.access:200 GET /static/js/bokeh.min.js?v=b0e2720e424bae5562ceecc6d83c2044 (127.0.0.1) 4.01ms

INFO:tornado.access:200 GET /static/js/bokeh-compiler.min.js?v=34cb81b761c2c28f1955c7bb98dab3a9 (127.0.0.1) 1.21ms

INFO:tornado.access:200 GET /static/js/bokeh-widgets.min.js?v=8e88133dddc48883a815d4278dd80f9a (127.0.0.1) 1.27ms

INFO:bokeh.server.views.ws:WebSocket connection opened

DEBUG:bokeh.server.views.ws:Receiver created for Protocol(u’1.0’)

DEBUG:bokeh.server.views.ws:ServerHandler created for Protocol(u’1.0’)

INFO:bokeh.server.views.ws:ServerConnection created

INFO:tornado.access:200 GET /static/css/bokeh.min.css?v=486d3195473d3e39ad36f2888fefe389 (127.0.0.1) 0.78ms

DEBUG:bokeh.server.session:Sending pull-doc-reply from session u’Laj6FCXEhKYYtBjf4k9Pmi1LiLbsrES4YDX3hVAgB1Eh’

INFO:tornado.access:200 GET /static/css/bokeh-widgets.min.css?v=0bbd11cf0fab2f648f3918c073bc9c3d (127.0.0.1) 1.55ms

On the development server, if I enter $ curl http://localhost:5006/autoload.js?bokeh-autoload-element=78f39b60-5d55-4248…eh-session-id=JwjPY7koQTzKx2yXGOC1ZY2qlodDbdZgPcMMDnrxFSLg, I will get the javascript file returned just fine.

From what I understood, changing to the Tornado server in V 0.11 was going to address these CORS issues. Is anyone aware of a bokeh application that is running on an actual web-facing server? All I have seen to this point are demos running on local machines or in iPython notebooks.

Hi Brian,

I am afraid I am in a bit of a hurry, but will try to write more later. For now I will mention that all of the demos at

  http://demo.bokehplots.com

are running on a public, web-facing server on AWS. They were deployed according to the material at:

  http://bokeh.pydata.org/en/latest/docs/user_guide/server.html#deployment-scenarios

(In fact much of the material there is merely a recording/cleanup of the steps taken to deploy the demo site.)

If you are asking about embedding using autoload_server, I have demonstrated that personally, but have not had the opportunity to create any demonstration. More details will probably be needed from you, for instance depending on your deployment scenario you may (probably?) also need a --hosts option specified.

Thanks,

Bryan

···

On Mar 17, 2016, at 1:49 PM, Brian Leach <[email protected]> wrote:

Hi Everyone,

I have been updating my application to work with bokeh 0.11, although I am still not able to get anything to run on an actual web-facing application. I have a very simple plot coming from a Flask view.

@main.route('/_get_chart', methods=['POST'])
def get_chart():
    ...
    plot = Line(data=df)
    session = push_session(curdoc())
    script = autoload_server(plot, session_id=session.id)
    return jsonify({'plot_tag': script })

This works on my development server (local machine), although once I try to put it on an actual web-facing server, the autoload.js is refused.

On the development machine, I start the server with (env)$ bokeh serve --allow-websocket-origin=127.0.0.1:5000

On the server, I start it with (env)$ bokeh serve --allow-websocket-origin=45.**.***.***:8098

The error I am getting from the web-facing server in the javascript console is:

GET http://localhost:5006/autoload.js?bokeh-autoload-element=09ab05db-8a33-4295…eh-session-id=i0ZMNFuvUMmhYpaIVaeG2po4PWWU9KuyX1TQ8sswuA6m&_=1458238746733 net::ERR_CONNECTION_REFUSED

When the chart is requested, The web-facing bokeh server debug log is showing the following:

INFO:bokeh.server.views.ws:WebSocket connection opened
DEBUG:bokeh.server.views.ws:Receiver created for Protocol(u'1.0')
DEBUG:bokeh.server.views.ws:ServerHandler created for Protocol(u'1.0')
INFO:bokeh.server.views.ws:ServerConnection created
DEBUG:bokeh.server.tornado:[pid 25191] 1 clients connected
DEBUG:bokeh.server.tornado:[pid 25191] / has 1 sessions with 0 unused
DEBUG:bokeh.server.session:pushing doc to session u'4g6Yj2kQ2CwULKDBqJo39s1XT2g9YusTDeNnKACvKVo6'
DEBUG:bokeh.server.tornado:[pid 25191] 1 clients connected
DEBUG:bokeh.server.tornado:[pid 25191] / has 1 sessions with 0 unused

And this is from the bokeh server output on the local development server:

INFO:bokeh.server.views.ws:WebSocket connection opened
DEBUG:bokeh.server.views.ws:Receiver created for Protocol(u'1.0')
DEBUG:bokeh.server.views.ws:ServerHandler created for Protocol(u'1.0')
INFO:bokeh.server.views.ws:ServerConnection created
DEBUG:bokeh.server.tornado:[pid 21464] 1 clients connected
DEBUG:bokeh.server.session:pushing doc to session u'Laj6FCXEhKYYtBjf4k9Pmi1LiLbsrES4YDX3hVAgB1Eh'
INFO:tornado.access:200 GET /autoload.js?bokeh-autoload-element=6f65f30d-f9a9-4512-8d1c-bbb292ad8337&bokeh-session-id=Laj6FCXEhKYYtBjf4k9Pmi1LiLbsrES4YDX3hVAgB1Eh&_=1458240123400 (127.0.0.1) 5.94ms
INFO:tornado.access:200 GET /static/js/bokeh.min.js?v=b0e2720e424bae5562ceecc6d83c2044 (127.0.0.1) 4.01ms
INFO:tornado.access:200 GET /static/js/bokeh-compiler.min.js?v=34cb81b761c2c28f1955c7bb98dab3a9 (127.0.0.1) 1.21ms
INFO:tornado.access:200 GET /static/js/bokeh-widgets.min.js?v=8e88133dddc48883a815d4278dd80f9a (127.0.0.1) 1.27ms
INFO:bokeh.server.views.ws:WebSocket connection opened
DEBUG:bokeh.server.views.ws:Receiver created for Protocol(u'1.0')
DEBUG:bokeh.server.views.ws:ServerHandler created for Protocol(u'1.0')
INFO:bokeh.server.views.ws:ServerConnection created
INFO:tornado.access:200 GET /static/css/bokeh.min.css?v=486d3195473d3e39ad36f2888fefe389 (127.0.0.1) 0.78ms
DEBUG:bokeh.server.session:Sending pull-doc-reply from session u'Laj6FCXEhKYYtBjf4k9Pmi1LiLbsrES4YDX3hVAgB1Eh'
INFO:tornado.access:200 GET /static/css/bokeh-widgets.min.css?v=0bbd11cf0fab2f648f3918c073bc9c3d (127.0.0.1) 1.55ms

On the development server, if I enter $ curl http://localhost:5006/autoload.js?bokeh-autoload-element=78f39b60-5d55-4248…eh-session-id=JwjPY7koQTzKx2yXGOC1ZY2qlodDbdZgPcMMDnrxFSLg, I will get the javascript file returned just fine.

From what I understood, changing to the Tornado server in V 0.11 was going to address these CORS issues. Is anyone aware of a bokeh application that is running on an actual web-facing server? All I have seen to this point are demos running on local machines or in iPython notebooks.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8c67f390-a255-458f-aa9f-b8c85164e382%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Thank you for the reply, Bryan. That makes sense that all of the demos are being hosted just fine, sorry for the confusion!

I have tried specifying a few different --host options in addition to the “allow-websocket-origin” option, although I am still getting the connection refused when trying to fetch the autoload.js. (is there a way to specify multiple hosts? Would this ever be needed?)

I am wondering if I need to make any changes to my nginx configuration (since I am trying to embed the plot in one of my pages), which is included below:

server {

listen 45.**.***.***:8098 default_server;

charset     utf-8;

client_max_body_size 30M;

location ~ ^/(app_config.py|.git) {

    deny all;

    return 404;

}

location / {

    index index.html index.htm;

    root /home/myuser/mydevelopment/git/data_app;

    try_files $uri @app;

}

location /static {

    alias /home/myuser/mydevelopment/git/data_app/webapp/static;

}

location @app {

    include uwsgi_params;

    uwsgi_pass unix:/home/myuser/mydevelopment/git/data_app/uwsgi.sock;

    uwsgi_connect_timeout 18000;

    uwsgi_read_timeout 18000;

    uwsgi_send_timeout 18000;

 }

}

Let me know what additional info I can provide for you / anyone else.

Brian L

···

On Thu, Mar 17, 2016 at 12:56 PM, Bryan Van de Ven [email protected] wrote:

Hi Brian,

I am afraid I am in a bit of a hurry, but will try to write more later. For now I will mention that all of the demos at

    [http://demo.bokehplots.com](http://demo.bokehplots.com)

are running on a public, web-facing server on AWS. They were deployed according to the material at:

    [http://bokeh.pydata.org/en/latest/docs/user_guide/server.html#deployment-scenarios](http://bokeh.pydata.org/en/latest/docs/user_guide/server.html#deployment-scenarios)

(In fact much of the material there is merely a recording/cleanup of the steps taken to deploy the demo site.)

If you are asking about embedding using autoload_server, I have demonstrated that personally, but have not had the opportunity to create any demonstration. More details will probably be needed from you, for instance depending on your deployment scenario you may (probably?) also need a --hosts option specified.

Thanks,

Bryan

On Mar 17, 2016, at 1:49 PM, Brian Leach [email protected] wrote:

Hi Everyone,

I have been updating my application to work with bokeh 0.11, although I am still not able to get anything to run on an actual web-facing application. I have a very simple plot coming from a Flask view.

@main.route(’/_get_chart’, methods=[‘POST’])

def get_chart():

...
plot = Line(data=df)
session = push_session(curdoc())
script = autoload_server(plot, session_id=[session.id](http://session.id))
return jsonify({'plot_tag': script })

This works on my development server (local machine), although once I try to put it on an actual web-facing server, the autoload.js is refused.

On the development machine, I start the server with (env)$ bokeh serve --allow-websocket-origin=127.0.0.1:5000

On the server, I start it with (env)$ bokeh serve --allow-websocket-origin=45...**:8098

The error I am getting from the web-facing server in the javascript console is:

GET http://localhost:5006/autoload.js?bokeh-autoload-element=09ab05db-8a33-4295…eh-session-id=i0ZMNFuvUMmhYpaIVaeG2po4PWWU9KuyX1TQ8sswuA6m&_=1458238746733 net::ERR_CONNECTION_REFUSED

When the chart is requested, The web-facing bokeh server debug log is showing the following:

INFO:bokeh.server.views.ws:WebSocket connection opened

DEBUG:bokeh.server.views.ws:Receiver created for Protocol(u’1.0’)

DEBUG:bokeh.server.views.ws:ServerHandler created for Protocol(u’1.0’)

INFO:bokeh.server.views.ws:ServerConnection created

DEBUG:bokeh.server.tornado:[pid 25191] 1 clients connected

DEBUG:bokeh.server.tornado:[pid 25191] / has 1 sessions with 0 unused

DEBUG:bokeh.server.session:pushing doc to session u’4g6Yj2kQ2CwULKDBqJo39s1XT2g9YusTDeNnKACvKVo6’

DEBUG:bokeh.server.tornado:[pid 25191] 1 clients connected

DEBUG:bokeh.server.tornado:[pid 25191] / has 1 sessions with 0 unused

And this is from the bokeh server output on the local development server:

INFO:bokeh.server.views.ws:WebSocket connection opened

DEBUG:bokeh.server.views.ws:Receiver created for Protocol(u’1.0’)

DEBUG:bokeh.server.views.ws:ServerHandler created for Protocol(u’1.0’)

INFO:bokeh.server.views.ws:ServerConnection created

DEBUG:bokeh.server.tornado:[pid 21464] 1 clients connected

DEBUG:bokeh.server.session:pushing doc to session u’Laj6FCXEhKYYtBjf4k9Pmi1LiLbsrES4YDX3hVAgB1Eh’

INFO:tornado.access:200 GET /autoload.js?bokeh-autoload-element=6f65f30d-f9a9-4512-8d1c-bbb292ad8337&bokeh-session-id=Laj6FCXEhKYYtBjf4k9Pmi1LiLbsrES4YDX3hVAgB1Eh&_=1458240123400 (127.0.0.1) 5.94ms

INFO:tornado.access:200 GET /static/js/bokeh.min.js?v=b0e2720e424bae5562ceecc6d83c2044 (127.0.0.1) 4.01ms

INFO:tornado.access:200 GET /static/js/bokeh-compiler.min.js?v=34cb81b761c2c28f1955c7bb98dab3a9 (127.0.0.1) 1.21ms

INFO:tornado.access:200 GET /static/js/bokeh-widgets.min.js?v=8e88133dddc48883a815d4278dd80f9a (127.0.0.1) 1.27ms

INFO:bokeh.server.views.ws:WebSocket connection opened

DEBUG:bokeh.server.views.ws:Receiver created for Protocol(u’1.0’)

DEBUG:bokeh.server.views.ws:ServerHandler created for Protocol(u’1.0’)

INFO:bokeh.server.views.ws:ServerConnection created

INFO:tornado.access:200 GET /static/css/bokeh.min.css?v=486d3195473d3e39ad36f2888fefe389 (127.0.0.1) 0.78ms

DEBUG:bokeh.server.session:Sending pull-doc-reply from session u’Laj6FCXEhKYYtBjf4k9Pmi1LiLbsrES4YDX3hVAgB1Eh’

INFO:tornado.access:200 GET /static/css/bokeh-widgets.min.css?v=0bbd11cf0fab2f648f3918c073bc9c3d (127.0.0.1) 1.55ms

On the development server, if I enter $ curl http://localhost:5006/autoload.js?bokeh-autoload-element=78f39b60-5d55-4248…eh-session-id=JwjPY7koQTzKx2yXGOC1ZY2qlodDbdZgPcMMDnrxFSLg, I will get the javascript file returned just fine.

From what I understood, changing to the Tornado server in V 0.11 was going to address these CORS issues. Is anyone aware of a bokeh application that is running on an actual web-facing server? All I have seen to this point are demos running on local machines or in iPython notebooks.

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8c67f390-a255-458f-aa9f-b8c85164e382%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/CEC22AC3-FD5C-44CD-A949-EF2599AA36A3%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Hi Brian,

I have tried specifying a few different --host options in addition to the "allow-websocket-origin" option, although I am still getting the connection refused when trying to fetch the autoload.js. (is there a way to specify multiple hosts? Would this ever be needed?)

Definitely possible, you can add as many --host options as you need, e.g:

  bokeh serve --host foo.com --host bar.com myapp.py

This would be needed if you want to make the app accessible to users via multiple hostnames. With the above configuration, only HTML requests that report "foo.com" or "bar.com" as the value of their HOST header are accepted.

Now, if you are running a Bokeh server behind Nginx, Bokeh still has to check and verify the HOST header. Looking at your config below, I wonder if one problem might be that you are not forwarding the HOST header on to the Bokeh server. Additionally, I think you explicitly need to add some options to enable Nginx to perform websocket forwarding. Check out the sample Nginx config here:

  http://bokeh.pydata.org/en/latest/docs/user_guide/server.html#reverse-proxying-with-nginx

I would suggest adding all the options there under "location /" to your app location block as a first attempt.

Thanks,

Bryan

···

On Mar 17, 2016, at 3:35 PM, Brian Leach <[email protected]> wrote:

I am wondering if I need to make any changes to my nginx configuration (since I am trying to embed the plot in one of my pages), which is included below:

server {

    listen 45.**.***.***:8098 default_server;
    charset utf-8;
    client_max_body_size 30M;

    location ~ ^/(app_config.py|.git) {
        deny all;
        return 404;
    }

    location / {
        index index.html index.htm;
        root /home/myuser/mydevelopment/git/data_app;
        try_files $uri @app;

    }

    location /static {
        alias /home/myuser/mydevelopment/git/data_app/webapp/static;
    }

    location @app {
        include uwsgi_params;
        uwsgi_pass unix:/home/myuser/mydevelopment/git/data_app/uwsgi.sock;
        uwsgi_connect_timeout 18000;
        uwsgi_read_timeout 18000;
        uwsgi_send_timeout 18000;

     }
}

Let me know what additional info I can provide for you / anyone else.

Brian L

On Thu, Mar 17, 2016 at 12:56 PM, Bryan Van de Ven <[email protected]> wrote:
Hi Brian,

I am afraid I am in a bit of a hurry, but will try to write more later. For now I will mention that all of the demos at

        http://demo.bokehplots.com

are running on a public, web-facing server on AWS. They were deployed according to the material at:

        http://bokeh.pydata.org/en/latest/docs/user_guide/server.html#deployment-scenarios

(In fact much of the material there is merely a recording/cleanup of the steps taken to deploy the demo site.)

If you are asking about embedding using autoload_server, I have demonstrated that personally, but have not had the opportunity to create any demonstration. More details will probably be needed from you, for instance depending on your deployment scenario you may (probably?) also need a --hosts option specified.

Thanks,

Bryan

> On Mar 17, 2016, at 1:49 PM, Brian Leach <brian.leac[email protected]> wrote:
>
> Hi Everyone,
>
> I have been updating my application to work with bokeh 0.11, although I am still not able to get anything to run on an actual web-facing application. I have a very simple plot coming from a Flask view.
>
> @main.route('/_get_chart', methods=['POST'])
> def get_chart():
> ...
> plot = Line(data=df)
> session = push_session(curdoc())
> script = autoload_server(plot, session_id=session.id)
> return jsonify({'plot_tag': script })
>
> This works on my development server (local machine), although once I try to put it on an actual web-facing server, the autoload.js is refused.
>
> On the development machine, I start the server with (env) bokeh serve \-\-allow\-websocket\-origin=127\.0\.0\.1:5000 &gt; &gt; On the server, I start it with \(env\) bokeh serve --allow-websocket-origin=45.**.***.***:8098
>
> The error I am getting from the web-facing server in the javascript console is:
>
> GET http://localhost:5006/autoload.js?bokeh-autoload-element=09ab05db-8a33-4295…eh-session-id=i0ZMNFuvUMmhYpaIVaeG2po4PWWU9KuyX1TQ8sswuA6m&_=1458238746733 net::ERR_CONNECTION_REFUSED
>
> When the chart is requested, The web-facing bokeh server debug log is showing the following:
>
> INFO:bokeh.server.views.ws:WebSocket connection opened
> DEBUG:bokeh.server.views.ws:Receiver created for Protocol(u'1.0')
> DEBUG:bokeh.server.views.ws:ServerHandler created for Protocol(u'1.0')
> INFO:bokeh.server.views.ws:ServerConnection created
> DEBUG:bokeh.server.tornado:[pid 25191] 1 clients connected
> DEBUG:bokeh.server.tornado:[pid 25191] / has 1 sessions with 0 unused
> DEBUG:bokeh.server.session:pushing doc to session u'4g6Yj2kQ2CwULKDBqJo39s1XT2g9YusTDeNnKACvKVo6'
> DEBUG:bokeh.server.tornado:[pid 25191] 1 clients connected
> DEBUG:bokeh.server.tornado:[pid 25191] / has 1 sessions with 0 unused
>
> And this is from the bokeh server output on the local development server:
>
> INFO:bokeh.server.views.ws:WebSocket connection opened
> DEBUG:bokeh.server.views.ws:Receiver created for Protocol(u'1.0')
> DEBUG:bokeh.server.views.ws:ServerHandler created for Protocol(u'1.0')
> INFO:bokeh.server.views.ws:ServerConnection created
> DEBUG:bokeh.server.tornado:[pid 21464] 1 clients connected
> DEBUG:bokeh.server.session:pushing doc to session u'Laj6FCXEhKYYtBjf4k9Pmi1LiLbsrES4YDX3hVAgB1Eh'
> INFO:tornado.access:200 GET /autoload.js?bokeh-autoload-element=6f65f30d-f9a9-4512-8d1c-bbb292ad8337&bokeh-session-id=Laj6FCXEhKYYtBjf4k9Pmi1LiLbsrES4YDX3hVAgB1Eh&_=1458240123400 (127.0.0.1) 5.94ms
> INFO:tornado.access:200 GET /static/js/bokeh.min.js?v=b0e2720e424bae5562ceecc6d83c2044 (127.0.0.1) 4.01ms
> INFO:tornado.access:200 GET /static/js/bokeh-compiler.min.js?v=34cb81b761c2c28f1955c7bb98dab3a9 (127.0.0.1) 1.21ms
> INFO:tornado.access:200 GET /static/js/bokeh-widgets.min.js?v=8e88133dddc48883a815d4278dd80f9a (127.0.0.1) 1.27ms
> INFO:bokeh.server.views.ws:WebSocket connection opened
> DEBUG:bokeh.server.views.ws:Receiver created for Protocol(u'1.0')
> DEBUG:bokeh.server.views.ws:ServerHandler created for Protocol(u'1.0')
> INFO:bokeh.server.views.ws:ServerConnection created
> INFO:tornado.access:200 GET /static/css/bokeh.min.css?v=486d3195473d3e39ad36f2888fefe389 (127.0.0.1) 0.78ms
> DEBUG:bokeh.server.session:Sending pull-doc-reply from session u'Laj6FCXEhKYYtBjf4k9Pmi1LiLbsrES4YDX3hVAgB1Eh'
> INFO:tornado.access:200 GET /static/css/bokeh-widgets.min.css?v=0bbd11cf0fab2f648f3918c073bc9c3d (127.0.0.1) 1.55ms
>
> On the development server, if I enter $ curl http://localhost:5006/autoload.js?bokeh-autoload-element=78f39b60-5d55-4248…eh-session-id=JwjPY7koQTzKx2yXGOC1ZY2qlodDbdZgPcMMDnrxFSLg, I will get the javascript file returned just fine.
>
> From what I understood, changing to the Tornado server in V 0.11 was going to address these CORS issues. Is anyone aware of a bokeh application that is running on an actual web-facing server? All I have seen to this point are demos running on local machines or in iPython notebooks.
>
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8c67f390-a255-458f-aa9f-b8c85164e382%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/CEC22AC3-FD5C-44CD-A949-EF2599AA36A3%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/CAPHP2gS0Nh-RZ9Z3O4RJ7fFtzX2ov5Rsoqeb0TYCkyf-omiStw%40mail.gmail.com.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.