Gallery Surface3D case seems not working?

What are you trying to do?

  • replicate sample here but tscode in the long string is replaced by bokeh-3.3.0’s corresponding ts code.

#wrapping-a-javascript-library
What have you tried that did NOT work as expected? If you have also posted this question elsewhere (e.g. StackOverflow), please include a link to that post.

  • search using error message, got nothing useful.

If this is a question about Bokeh code, please include a complete Minimal, Reproducible Example so that reviewers can test and see what you see.

  • in aforementioned link

In some cases, a screenshot of your plot will also be helpful.

bokeh version: 3.3.0

@captain The .ts file is part of a Bokeh server application, can you confirm that you ran it as a Bokeh server application, using bokeh serve? It’s really unclear exactly what steps you have taken, please elaborate in more detail about exactly what you ran, and how (i.e. the specific commands you issued).

Thanks for your reply, Bryan. I ran it in jupyter notebook not in server mode.

After some struggling, I believe I made a mistake here(use mismatching bokeh version). Everything works fine when update bokeh version to 3.3.0 in jupyter notebook.

1 Like