Glyph image_uri in BokehJs

Hello all,

I’m trying to get this function to work and am not having much luck. Has anyone done this? Am I missing something?

Here’s a link to the JSfiddle: http://jsfiddle.net/bokeh/EVAjb/

Here’s the code as well:

data = {

x: [3]

y: [3]

rotate: [0]

url: [‘https://www.google.com/images/srpr/logo11w.png’]

}

options = {

dims: [600, 600]

xrange: [0, 6]

yrange: [0, 6]

xaxes: “min”

yaxes: “min”

tools: false

}

spec = {

type: ‘image_uri’

x: ‘x’

y: ‘y’

rotate: ‘rotate’

url : ‘url’

}

plot = Bokeh.Plotting.make_plot(spec, data, options)

Bokeh.Plotting.show(plot)

Thanks,

Matt

That actually looks like it should be good to me, it may be that there is a bug in 0.4.4. I know this glyph works in master because I just tried it form the python example. We will be adding nightly builds soon (early next week, I hope) so you could try it from a newer bokeh.js then (or I would be happy to help you build it from GH master, too)

Note the glyph name is changing to "image_url" as well.

Thanks,

Bryan

···

On May 16, 2014, at 12:56 PM, Matt Kankainen <[email protected]> wrote:

Hello all,

I'm trying to get this function to work and am not having much luck. Has anyone done this? Am I missing something?

Here's a link to the JSfiddle: http://jsfiddle.net/bokeh/EVAjb/

Here's the code as well:

data = {
  x: [3]
  y: [3]
  rotate: [0]
  url: ['https://www.google.com/images/srpr/logo11w.png']
}

options = {
  dims: [600, 600]
  xrange: [0, 6]
  yrange: [0, 6]
  xaxes: "min"
  yaxes: "min"
  tools: false
}
    
spec = {
  type: 'image_uri'
  x: 'x'
  y: 'y'
  rotate: 'rotate'
  url : 'url'
}
    
plot = Bokeh.Plotting.make_plot(spec, data, options)
Bokeh.Plotting.show(plot)

Thanks,

Matt

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/f8d9b1bd-312e-44ae-8606-b758aa9a04d7%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Bryan,

Thanks for the reply. I noticed the jsfiddle was using 0.4.3 so I updated it to the latest 0.4.4. Still no luck. We tried to build the latest version from the master branch, but we can’t seem to get it working. I pasted the wrong jsfiddle last time. Here’s a working link:

http://jsfiddle.net/EVAjb/4/

We’re thinking there’s a bug.

Best,

Matt

···

On Friday, May 16, 2014 12:52:35 PM UTC-6, Bryan Van de ven wrote:

That actually looks like it should be good to me, it may be that there is a bug in 0.4.4. I know this glyph works in master because I just tried it form the python example. We will be adding nightly builds soon (early next week, I hope) so you could try it from a newer bokeh.js then (or I would be happy to help you build it from GH master, too)

Note the glyph name is changing to “image_url” as well.

Thanks,

Bryan

On May 16, 2014, at 12:56 PM, Matt Kankainen [email protected] wrote:

Hello all,

I’m trying to get this function to work and am not having much luck. Has anyone done this? Am I missing something?

Here’s a link to the JSfiddle: http://jsfiddle.net/bokeh/EVAjb/

Here’s the code as well:

data = {

x: [3]

y: [3]

rotate: [0]

url: [‘https://www.google.com/images/srpr/logo11w.png’]

}

options = {

dims: [600, 600]

xrange: [0, 6]

yrange: [0, 6]

xaxes: “min”

yaxes: “min”

tools: false

}

spec = {

type: ‘image_uri’

x: ‘x’

y: ‘y’

rotate: ‘rotate’

url : ‘url’

}

plot = Bokeh.Plotting.make_plot(spec, data, options)

Bokeh.Plotting.show(plot)

Thanks,

Matt


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/f8d9b1bd-312e-44ae-8606-b758aa9a04d7%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Correction, we compiled a version from master branch according to:

http://bokeh.pydata.org/docs/dev_guide.html#devguide

Cloned from:

https://github.com/ContinuumIO/bokeh

It is not working with that either.

Best,

Matt

···

On Friday, May 16, 2014 2:30:04 PM UTC-6, Matt Kankainen wrote:

Bryan,

Thanks for the reply. I noticed the jsfiddle was using 0.4.3 so I updated it to the latest 0.4.4. Still no luck. We tried to build the latest version from the master branch, but we can’t seem to get it working. I pasted the wrong jsfiddle last time. Here’s a working link:

http://jsfiddle.net/EVAjb/4/

We’re thinking there’s a bug.

Best,

Matt

On Friday, May 16, 2014 12:52:35 PM UTC-6, Bryan Van de ven wrote:

That actually looks like it should be good to me, it may be that there is a bug in 0.4.4. I know this glyph works in master because I just tried it form the python example. We will be adding nightly builds soon (early next week, I hope) so you could try it from a newer bokeh.js then (or I would be happy to help you build it from GH master, too)

Note the glyph name is changing to “image_url” as well.

Thanks,

Bryan

On May 16, 2014, at 12:56 PM, Matt Kankainen [email protected] wrote:

Hello all,

I’m trying to get this function to work and am not having much luck. Has anyone done this? Am I missing something?

Here’s a link to the JSfiddle: http://jsfiddle.net/bokeh/EVAjb/

Here’s the code as well:

data = {

x: [3]

y: [3]

rotate: [0]

url: [‘https://www.google.com/images/srpr/logo11w.png’]

}

options = {

dims: [600, 600]

xrange: [0, 6]

yrange: [0, 6]

xaxes: “min”

yaxes: “min”

tools: false

}

spec = {

type: ‘image_uri’

x: ‘x’

y: ‘y’

rotate: ‘rotate’

url : ‘url’

}

plot = Bokeh.Plotting.make_plot(spec, data, options)

Bokeh.Plotting.show(plot)

Thanks,

Matt


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/f8d9b1bd-312e-44ae-8606-b758aa9a04d7%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Matt,

Thanks for the feedback. Did you update to "image_url" when using master? If so, since this does work from examples/plotting/file/image_url.py then I think the problem is probably somewhere in Bokeh.make_plot. I will make an issue to investigate.

Thanks,

Bryan

···

On May 16, 2014, at 3:32 PM, Matt Kankainen <[email protected]> wrote:

Correction, we compiled a version from master branch according to:

http://bokeh.pydata.org/docs/dev_guide.html#devguide

Cloned from:

https://github.com/ContinuumIO/bokeh

It is not working with that either.

Best,

Matt

On Friday, May 16, 2014 2:30:04 PM UTC-6, Matt Kankainen wrote:
Bryan,

Thanks for the reply. I noticed the jsfiddle was using 0.4.3 so I updated it to the latest 0.4.4. Still no luck. We tried to build the latest version from the master branch, but we can't seem to get it working. I pasted the wrong jsfiddle last time. Here's a working link:

http://jsfiddle.net/EVAjb/4/

We're thinking there's a bug.

Best,

Matt

On Friday, May 16, 2014 12:52:35 PM UTC-6, Bryan Van de ven wrote:
That actually looks like it should be good to me, it may be that there is a bug in 0.4.4. I know this glyph works in master because I just tried it form the python example. We will be adding nightly builds soon (early next week, I hope) so you could try it from a newer bokeh.js then (or I would be happy to help you build it from GH master, too)

Note the glyph name is changing to "image_url" as well.

Thanks,

Bryan

On May 16, 2014, at 12:56 PM, Matt Kankainen <[email protected]> wrote:

> Hello all,
>
> I'm trying to get this function to work and am not having much luck. Has anyone done this? Am I missing something?
>
> Here's a link to the JSfiddle: http://jsfiddle.net/bokeh/EVAjb/
>
> Here's the code as well:
>
> data = {
> x: [3]
> y: [3]
> rotate: [0]
> url: ['https://www.google.com/images/srpr/logo11w.png']
> }
>
> options = {
> dims: [600, 600]
> xrange: [0, 6]
> yrange: [0, 6]
> xaxes: "min"
> yaxes: "min"
> tools: false
> }
>
> spec = {
> type: 'image_uri'
> x: 'x'
> y: 'y'
> rotate: 'rotate'
> url : 'url'
> }
>
> plot = Bokeh.Plotting.make_plot(spec, data, options)
> Bokeh.Plotting.show(plot)
>
> Thanks,
>
> Matt
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/f8d9b1bd-312e-44ae-8606-b758aa9a04d7%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/54432925-42e4-4dc8-a7c9-38799a8e3aeb%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Bryan,

It’s still “image_uri” in the master.

Best,

Matt

···

On Friday, May 16, 2014 2:35:27 PM UTC-6, Bryan Van de ven wrote:

Matt,

Thanks for the feedback. Did you update to “image_url” when using master? If so, since this does work from examples/plotting/file/image_url.py then I think the problem is probably somewhere in Bokeh.make_plot. I will make an issue to investigate.

Thanks,

Bryan

On May 16, 2014, at 3:32 PM, Matt Kankainen [email protected] wrote:

Correction, we compiled a version from master branch according to:

http://bokeh.pydata.org/docs/dev_guide.html#devguide

Cloned from:

https://github.com/ContinuumIO/bokeh

It is not working with that either.

Best,

Matt

On Friday, May 16, 2014 2:30:04 PM UTC-6, Matt Kankainen wrote:

Bryan,

Thanks for the reply. I noticed the jsfiddle was using 0.4.3 so I updated it to the latest 0.4.4. Still no luck. We tried to build the latest version from the master branch, but we can’t seem to get it working. I pasted the wrong jsfiddle last time. Here’s a working link:

http://jsfiddle.net/EVAjb/4/

We’re thinking there’s a bug.

Best,

Matt

On Friday, May 16, 2014 12:52:35 PM UTC-6, Bryan Van de ven wrote:

That actually looks like it should be good to me, it may be that there is a bug in 0.4.4. I know this glyph works in master because I just tried it form the python example. We will be adding nightly builds soon (early next week, I hope) so you could try it from a newer bokeh.js then (or I would be happy to help you build it from GH master, too)

Note the glyph name is changing to “image_url” as well.

Thanks,

Bryan

On May 16, 2014, at 12:56 PM, Matt Kankainen [email protected] wrote:

Hello all,

I’m trying to get this function to work and am not having much luck. Has anyone done this? Am I missing something?

Here’s a link to the JSfiddle: http://jsfiddle.net/bokeh/EVAjb/

Here’s the code as well:

data = {
x: [3]
y: [3]
rotate: [0]
url: [‘https://www.google.com/images/srpr/logo11w.png’]
}

options = {
dims: [600, 600]
xrange: [0, 6]
yrange: [0, 6]
xaxes: “min”
yaxes: “min”
tools: false
}

spec = {
type: ‘image_uri’
x: ‘x’
y: ‘y’
rotate: ‘rotate’
url : ‘url’
}

plot = Bokeh.Plotting.make_plot(spec, data, options)
Bokeh.Plotting.show(plot)

Thanks,

Matt


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/f8d9b1bd-312e-44ae-8606-b758aa9a04d7%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/54432925-42e4-4dc8-a7c9-38799a8e3aeb%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Matt,

I am not sure what is going on for you:

[email protected] (git:master) ~/work/bokeh $ cd bokehjs/src/coffee/
[email protected] (git:master) ~/work/bokeh/bokehjs/src/coffee $ grin image_uri
[email protected] (git:master) ~/work/bokeh/bokehjs/src/coffee $ cd ../../../bokeh
[email protected] (git:master) ~/work/bokeh/bokeh $ grin image_uri
[email protected] (git:master) ~/work/bokeh/bokeh $ cd ../examples/
[email protected] (git:master) ~/work/bokeh/examples $ grin image_uri
[email protected] (git:master) ~/work/bokeh/examples $

The only place "image_uri" still shows up is in bokehjs/release, which is the previously released version that is checked in. Are you using that version by chance? The built versions with "grunt deploy" get placed under bokehjs/build

Thanks,

Bryan

···

On May 16, 2014, at 3:45 PM, Matt Kankainen <[email protected]> wrote:

Bryan,

It's still "image_uri" in the master.

Best,

Matt

On Friday, May 16, 2014 2:35:27 PM UTC-6, Bryan Van de ven wrote:
Matt,

Thanks for the feedback. Did you update to "image_url" when using master? If so, since this does work from examples/plotting/file/image_url.py then I think the problem is probably somewhere in Bokeh.make_plot. I will make an issue to investigate.

Thanks,

Bryan

On May 16, 2014, at 3:32 PM, Matt Kankainen <[email protected]> wrote:

> Correction, we compiled a version from master branch according to:
>
> http://bokeh.pydata.org/docs/dev_guide.html#devguide
>
> Cloned from:
>
> https://github.com/ContinuumIO/bokeh
>
> It is not working with that either.
>
> Best,
>
> Matt
>
>
> On Friday, May 16, 2014 2:30:04 PM UTC-6, Matt Kankainen wrote:
> Bryan,
>
> Thanks for the reply. I noticed the jsfiddle was using 0.4.3 so I updated it to the latest 0.4.4. Still no luck. We tried to build the latest version from the master branch, but we can't seem to get it working. I pasted the wrong jsfiddle last time. Here's a working link:
>
> http://jsfiddle.net/EVAjb/4/
>
> We're thinking there's a bug.
>
> Best,
>
> Matt
>
> On Friday, May 16, 2014 12:52:35 PM UTC-6, Bryan Van de ven wrote:
> That actually looks like it should be good to me, it may be that there is a bug in 0.4.4. I know this glyph works in master because I just tried it form the python example. We will be adding nightly builds soon (early next week, I hope) so you could try it from a newer bokeh.js then (or I would be happy to help you build it from GH master, too)
>
> Note the glyph name is changing to "image_url" as well.
>
> Thanks,
>
> Bryan
>
>
> On May 16, 2014, at 12:56 PM, Matt Kankainen <[email protected]> wrote:
>
> > Hello all,
> >
> > I'm trying to get this function to work and am not having much luck. Has anyone done this? Am I missing something?
> >
> > Here's a link to the JSfiddle: http://jsfiddle.net/bokeh/EVAjb/
> >
> > Here's the code as well:
> >
> > data = {
> > x: [3]
> > y: [3]
> > rotate: [0]
> > url: ['https://www.google.com/images/srpr/logo11w.png']
> > }
> >
> > options = {
> > dims: [600, 600]
> > xrange: [0, 6]
> > yrange: [0, 6]
> > xaxes: "min"
> > yaxes: "min"
> > tools: false
> > }
> >
> > spec = {
> > type: 'image_uri'
> > x: 'x'
> > y: 'y'
> > rotate: 'rotate'
> > url : 'url'
> > }
> >
> > plot = Bokeh.Plotting.make_plot(spec, data, options)
> > Bokeh.Plotting.show(plot)
> >
> > Thanks,
> >
> > Matt
> >
> > --
> > You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> > To post to this group, send email to [email protected].
> > To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/f8d9b1bd-312e-44ae-8606-b758aa9a04d7%40continuum.io.
> > For more options, visit https://groups.google.com/a/continuum.io/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/54432925-42e4-4dc8-a7c9-38799a8e3aeb%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/65a7d2be-6229-47c9-bc6b-01f1efd342d5%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Bryan,

You were right. We were using the release version. We tried the build version that has “image_url” and the problem persists. Thanks again for your help.

Best,

Matt

···

On Friday, May 16, 2014 2:50:57 PM UTC-6, Bryan Van de ven wrote:

Matt,

I am not sure what is going on for you:

[email protected] (git:master) ~/work/bokeh $ cd bokehjs/src/coffee/

[email protected] (git:master) ~/work/bokeh/bokehjs/src/coffee $ grin image_uri

[email protected] (git:master) ~/work/bokeh/bokehjs/src/coffee $ cd …/…/…/bokeh

[email protected] (git:master) ~/work/bokeh/bokeh $ grin image_uri

[email protected] (git:master) ~/work/bokeh/bokeh $ cd …/examples/

[email protected] (git:master) ~/work/bokeh/examples $ grin image_uri

[email protected] (git:master) ~/work/bokeh/examples $

The only place “image_uri” still shows up is in bokehjs/release, which is the previously released version that is checked in. Are you using that version by chance? The built versions with “grunt deploy” get placed under bokehjs/build

Thanks,

Bryan

On May 16, 2014, at 3:45 PM, Matt Kankainen [email protected] wrote:

Bryan,

It’s still “image_uri” in the master.

Best,

Matt

On Friday, May 16, 2014 2:35:27 PM UTC-6, Bryan Van de ven wrote:

Matt,

Thanks for the feedback. Did you update to “image_url” when using master? If so, since this does work from examples/plotting/file/image_url.py then I think the problem is probably somewhere in Bokeh.make_plot. I will make an issue to investigate.

Thanks,

Bryan

On May 16, 2014, at 3:32 PM, Matt Kankainen [email protected] wrote:

Correction, we compiled a version from master branch according to:

http://bokeh.pydata.org/docs/dev_guide.html#devguide

Cloned from:

https://github.com/ContinuumIO/bokeh

It is not working with that either.

Best,

Matt

On Friday, May 16, 2014 2:30:04 PM UTC-6, Matt Kankainen wrote:
Bryan,

Thanks for the reply. I noticed the jsfiddle was using 0.4.3 so I updated it to the latest 0.4.4. Still no luck. We tried to build the latest version from the master branch, but we can’t seem to get it working. I pasted the wrong jsfiddle last time. Here’s a working link:

http://jsfiddle.net/EVAjb/4/

We’re thinking there’s a bug.

Best,

Matt

On Friday, May 16, 2014 12:52:35 PM UTC-6, Bryan Van de ven wrote:
That actually looks like it should be good to me, it may be that there is a bug in 0.4.4. I know this glyph works in master because I just tried it form the python example. We will be adding nightly builds soon (early next week, I hope) so you could try it from a newer bokeh.js then (or I would be happy to help you build it from GH master, too)

Note the glyph name is changing to “image_url” as well.

Thanks,

Bryan

On May 16, 2014, at 12:56 PM, Matt Kankainen [email protected] wrote:

Hello all,

I’m trying to get this function to work and am not having much luck. Has anyone done this? Am I missing something?

Here’s a link to the JSfiddle: http://jsfiddle.net/bokeh/EVAjb/

Here’s the code as well:

data = {
x: [3]
y: [3]
rotate: [0]
url: [‘https://www.google.com/images/srpr/logo11w.png’]
}

options = {
dims: [600, 600]
xrange: [0, 6]
yrange: [0, 6]
xaxes: “min”
yaxes: “min”
tools: false
}

spec = {
type: ‘image_uri’
x: ‘x’
y: ‘y’
rotate: ‘rotate’
url : ‘url’
}

plot = Bokeh.Plotting.make_plot(spec, data, options)
Bokeh.Plotting.show(plot)

Thanks,

Matt


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/f8d9b1bd-312e-44ae-8606-b758aa9a04d7%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/54432925-42e4-4dc8-a7c9-38799a8e3aeb%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/65a7d2be-6229-47c9-bc6b-01f1efd342d5%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Matt,

FYI I have made an issue to look into this you can track:

  https://github.com/ContinuumIO/bokeh/issues/634

Bryan

···

On May 16, 2014, at 4:25 PM, Matt Kankainen <[email protected]> wrote:

Bryan,

You were right. We were using the release version. We tried the build version that has "image_url" and the problem persists. Thanks again for your help.

Best,

Matt

On Friday, May 16, 2014 2:50:57 PM UTC-6, Bryan Van de ven wrote:
Matt,

I am not sure what is going on for you:

[email protected] (git:master) ~/work/bokeh $ cd bokehjs/src/coffee/
[email protected] (git:master) ~/work/bokeh/bokehjs/src/coffee $ grin image_uri
[email protected] (git:master) ~/work/bokeh/bokehjs/src/coffee $ cd ../../../bokeh
[email protected] (git:master) ~/work/bokeh/bokeh $ grin image_uri
[email protected] (git:master) ~/work/bokeh/bokeh $ cd ../examples/
[email protected] (git:master) ~/work/bokeh/examples $ grin image_uri
[email protected] (git:master) ~/work/bokeh/examples $

The only place "image_uri" still shows up is in bokehjs/release, which is the previously released version that is checked in. Are you using that version by chance? The built versions with "grunt deploy" get placed under bokehjs/build

Thanks,

Bryan

On May 16, 2014, at 3:45 PM, Matt Kankainen <[email protected]> wrote:

> Bryan,
>
> It's still "image_uri" in the master.
>
> Best,
>
> Matt
>
> On Friday, May 16, 2014 2:35:27 PM UTC-6, Bryan Van de ven wrote:
> Matt,
>
> Thanks for the feedback. Did you update to "image_url" when using master? If so, since this does work from examples/plotting/file/image_url.py then I think the problem is probably somewhere in Bokeh.make_plot. I will make an issue to investigate.
>
> Thanks,
>
> Bryan
>
> On May 16, 2014, at 3:32 PM, Matt Kankainen <[email protected]> wrote:
>
> > Correction, we compiled a version from master branch according to:
> >
> > http://bokeh.pydata.org/docs/dev_guide.html#devguide
> >
> > Cloned from:
> >
> > https://github.com/ContinuumIO/bokeh
> >
> > It is not working with that either.
> >
> > Best,
> >
> > Matt
> >
> >
> > On Friday, May 16, 2014 2:30:04 PM UTC-6, Matt Kankainen wrote:
> > Bryan,
> >
> > Thanks for the reply. I noticed the jsfiddle was using 0.4.3 so I updated it to the latest 0.4.4. Still no luck. We tried to build the latest version from the master branch, but we can't seem to get it working. I pasted the wrong jsfiddle last time. Here's a working link:
> >
> > http://jsfiddle.net/EVAjb/4/
> >
> > We're thinking there's a bug.
> >
> > Best,
> >
> > Matt
> >
> > On Friday, May 16, 2014 12:52:35 PM UTC-6, Bryan Van de ven wrote:
> > That actually looks like it should be good to me, it may be that there is a bug in 0.4.4. I know this glyph works in master because I just tried it form the python example. We will be adding nightly builds soon (early next week, I hope) so you could try it from a newer bokeh.js then (or I would be happy to help you build it from GH master, too)
> >
> > Note the glyph name is changing to "image_url" as well.
> >
> > Thanks,
> >
> > Bryan
> >
> >
> > On May 16, 2014, at 12:56 PM, Matt Kankainen <[email protected]> wrote:
> >
> > > Hello all,
> > >
> > > I'm trying to get this function to work and am not having much luck. Has anyone done this? Am I missing something?
> > >
> > > Here's a link to the JSfiddle: http://jsfiddle.net/bokeh/EVAjb/
> > >
> > > Here's the code as well:
> > >
> > > data = {
> > > x: [3]
> > > y: [3]
> > > rotate: [0]
> > > url: ['https://www.google.com/images/srpr/logo11w.png']
> > > }
> > >
> > > options = {
> > > dims: [600, 600]
> > > xrange: [0, 6]
> > > yrange: [0, 6]
> > > xaxes: "min"
> > > yaxes: "min"
> > > tools: false
> > > }
> > >
> > > spec = {
> > > type: 'image_uri'
> > > x: 'x'
> > > y: 'y'
> > > rotate: 'rotate'
> > > url : 'url'
> > > }
> > >
> > > plot = Bokeh.Plotting.make_plot(spec, data, options)
> > > Bokeh.Plotting.show(plot)
> > >
> > > Thanks,
> > >
> > > Matt
> > >
> > > --
> > > You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > > To unsubscribe from this group and stop receiving emails from it, send an email to [email protected]ntinuum.io.
> > > To post to this group, send email to [email protected].
> > > To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/f8d9b1bd-312e-44ae-8606-b758aa9a04d7%40continuum.io.
> > > For more options, visit https://groups.google.com/a/continuum.io/d/optout.
> >
> >
> > --
> > You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> > To post to this group, send email to [email protected].
> > To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/54432925-42e4-4dc8-a7c9-38799a8e3aeb%40continuum.io.
> > For more options, visit https://groups.google.com/a/continuum.io/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/65a7d2be-6229-47c9-bc6b-01f1efd342d5%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/ef21dddc-2062-47c2-aa79-1d8534b8ad4f%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.