Looking for standard Jinja2 Template working example

I am trying to extend a working app to use Jinja2 templates.

MY directory structure is:


  • main.py
  • static
    • images
    • fonts
    • templates

main.py is really big and not easily posted - the issue is not in the main python code


{% extends base %}

{% block preamble %}

	<link rel="apple-touch-icon" sizes="180x180" href="static/images/apple-touch-icon.png"/>
	<link rel="icon" type="image/png" sizes="32x32" href="static/images/favicon-32x32.png"/>
	<link rel="icon" type="image/png" sizes="16x16" href="static/images/favicon-16x16.png"/>
	<link rel="manifest" href="static/site.webmanifest"/>
	<meta name="msapplication-TileColor" content="#da532c"/>
	<meta name="theme-color" content="#ffffff"/>

{% endblock %}

Note that I have tried every frigging possible combination of href path names for those .png files and everything returns 404 (likewise for the webmanifest)


Any hints?

I have looked at every single example and not one of them seems to replicate the full structure as outlined at https://docs.bokeh.org/en/latest/docs/user_guide/server.html

I am running this from the directory above ceoperformance using…

$ bokeh serve --allow-websocket-origin="*" --num-procs=2 --port 5006 ceoperformance


Okay - dash example had a hint…

ceoperformance/static/images… worked

I think the templates directory is expected to be outside the static directory. See here.

I think the templates directory is expected to be outside the static directory.

This is correct, the templates subdirectory should be a sibling to the static subdirectory as described there in the docs.