Miniconda fails to install bokeh (and numpy) on a Raspberry Pi 2

I’m getting the message below when trying to install bokeh on a Raspberry Pi 2 (on Rasboan Wheezy) running the recommended version of Miniconda: http://repo.continuum.io/miniconda/Miniconda-latest-Linux-armv7l.sh. I’ve then installed anaconda-client, but that wants to force me to create a user account on anaconda.org as it seems. Is that the way it should be?

[email protected] ~ $ conda install bokeh
Fetching package metadata: …
Error: No packages found in current linux-armv7l channels matching: bokeh

You can search for this package on anaconda.org with

anaconda search -t conda bokeh

You may need to install the anaconda-client command line client with

conda install anaconda-client

Maybe worse, when I try to install numpy I get the following SSL errors right now. Is there any issue with https://repo.continuum.io/pkgs/free/linux-armv7l ?

[email protected] ~ $ conda install numpy
Fetching package metadata: SSL verification error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)
.SSL verification error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)
.SSL verification error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)
.SSL verification error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)
.
Solving package specifications: .
Package plan for installation in environment /home/pi/miniconda:

The following packages will be downloaded:

package                    |            build
---------------------------|-----------------
libgfortran-1.0            |                0         206 KB
openblas-0.2.14            |                1         6.2 MB
numpy-1.9.2                |           py27_1         5.2 MB
···
------------------------------------------------------------
                                       Total:        11.6 MB

The following NEW packages will be INSTALLED:

libgfortran: 1.0-0      
numpy:       1.9.2-py27_1
openblas:    0.2.14-1   

Proceed ([y]/n)? y

Fetching packages …
Could not connect to https://repo.continuum.io/pkgs/free/linux-armv7l/libgfortran-1.0-0.tar.bz2
Error: Connection error: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590): https://repo.continuum.io/pkgs/free/linux-armv7l/libgfortran-1.0-0.tar.bz2

I'm not aware that Continuum publishes a rasb-pi package for Bokeh. You could definitely create your own conda package, some useful information about building the full library from source is in the developer's guide:

  http://bokeh.pydata.org/en/latest/docs/dev_guide.html

In any case questions about conda packages from the Continuum package repo should be directed to the Anaconda mailing list: [email protected]

Bryan

···

On Oct 13, 2015, at 8:58 AM, [email protected] wrote:

I'm getting the message below when trying to install bokeh on a Raspberry Pi 2 (on Rasboan Wheezy) running the recommended version of Miniconda: http://repo.continuum.io/miniconda/Miniconda-latest-Linux-armv7l.sh. I've then installed anaconda-client, but that wants to force me to create a user account on anaconda.org as it seems. Is that the way it should be?

[email protected] ~ $ conda install bokeh
Fetching package metadata: ....
Error: No packages found in current linux-armv7l channels matching: bokeh

You can search for this package on anaconda.org with

    anaconda search -t conda bokeh

You may need to install the anaconda-client command line client with

    conda install anaconda-client

Maybe worse, when I try to install numpy I get the following SSL errors right now. Is there any issue with https://repo.continuum.io/pkgs/free/linux-armv7l ?

[email protected] ~ $ conda install numpy
Fetching package metadata: SSL verification error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)
.SSL verification error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)
.SSL verification error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)
.SSL verification error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)
.
Solving package specifications: .
Package plan for installation in environment /home/pi/miniconda:

The following packages will be downloaded:

    package | build
    ---------------------------|-----------------
    libgfortran-1.0 | 0 206 KB
    openblas-0.2.14 | 1 6.2 MB
    numpy-1.9.2 | py27_1 5.2 MB
    ------------------------------------------------------------
                                           Total: 11.6 MB

The following NEW packages will be INSTALLED:

    libgfortran: 1.0-0
    numpy: 1.9.2-py27_1
    openblas: 0.2.14-1

Proceed ([y]/n)? y

Fetching packages ...
Could not connect to https://repo.continuum.io/pkgs/free/linux-armv7l/libgfortran-1.0-0.tar.bz2
Error: Connection error: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590): https://repo.continuum.io/pkgs/free/linux-armv7l/libgfortran-1.0-0.tar.bz2

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/04ec34f5-4025-4079-a51f-4297dc3b2c3d%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

I used pip on pi 1 B. Working through some issues with the server but it generates the graphs fine.

[email protected]:~# pip install bokeh

Requirement already satisfied (use --upgrade to upgrade): bokeh in /usr/local/lib/python2.7/dist-packages

Requirement already satisfied (use --upgrade to upgrade): six>=1.5.2 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): requests>=1.2.3 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): PyYAML>=3.10 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): python-dateutil>=2.1 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.7 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): numpy>=1.7.1 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): pandas>=0.11.0 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): Flask>=0.10.1 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): pyzmq>=14.3.1 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): tornado>=4.0.1 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): MarkupSafe in /usr/local/lib/python2.7/dist-packages (from Jinja2>=2.7->bokeh)

Requirement already satisfied (use --upgrade to upgrade): pytz>=2011k in /usr/local/lib/python2.7/dist-packages (from pandas>=0.11.0->bokeh)

Requirement already satisfied (use --upgrade to upgrade): Werkzeug>=0.7 in /usr/local/lib/python2.7/dist-packages (from Flask>=0.10.1->bokeh)

Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.21 in /usr/local/lib/python2.7/dist-packages (from Flask>=0.10.1->bokeh)

Requirement already satisfied (use --upgrade to upgrade): backports.ssl-match-hostname in /usr/local/lib/python2.7/dist-packages (from tornado>=4.0.1->bokeh)

Requirement already satisfied (use --upgrade to upgrade): certifi in /usr/local/lib/python2.7/dist-packages (from tornado>=4.0.1->bokeh)

[email protected]:~#

···

On Tuesday, October 13, 2015 at 9:58:39 AM UTC-4, [email protected] wrote:

I’m getting the message below when trying to install bokeh on a Raspberry Pi 2 (on Rasboan Wheezy) running the recommended version of Miniconda: http://repo.continuum.io/miniconda/Miniconda-latest-Linux-armv7l.sh. I’ve then installed anaconda-client, but that wants to force me to create a user account on anaconda.org as it seems. Is that the way it should be?

[email protected] ~ $ conda install bokeh
Fetching package metadata: …
Error: No packages found in current linux-armv7l channels matching: bokeh

You can search for this package on anaconda.org with

anaconda search -t conda bokeh

You may need to install the anaconda-client command line client with

conda install anaconda-client

Maybe worse, when I try to install numpy I get the following SSL errors right now. Is there any issue with https://repo.continuum.io/pkgs/free/linux-armv7l ?

[email protected] ~ $ conda install numpy
Fetching package metadata: SSL verification error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)
.SSL verification error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)
.SSL verification error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)
.SSL verification error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)
.
Solving package specifications: .
Package plan for installation in environment /home/pi/miniconda:

The following packages will be downloaded:

package                    |            build
---------------------------|-----------------
libgfortran-1.0            |                0         206 KB
openblas-0.2.14            |                1         6.2 MB
numpy-1.9.2                |           py27_1         5.2 MB
------------------------------------------------------------
                                       Total:        11.6 MB

The following NEW packages will be INSTALLED:

libgfortran: 1.0-0      
numpy:       1.9.2-py27_1
openblas:    0.2.14-1   

Proceed ([y]/n)? y

Fetching packages …
Could not connect to https://repo.continuum.io/pkgs/free/linux-armv7l/libgfortran-1.0-0.tar.bz2
Error: Connection error: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590): https://repo.continuum.io/pkgs/free/linux-armv7l/libgfortran-1.0-0.tar.bz2

The ssl certificate issue I described was likely a purely local issue. And yes, I know I can pip install bokeh, but using conda install instead gives me a speed-up of 60 for numpy and pandas already (ca. 40 seconds instead of 40 minutes), so it would help to have bokeh packaged for conda on armv7l as well.

Ron Knapp:

···

I used pip on pi 1 B. Working through some issues with the server but it generates the graphs fine.

[email protected]:~# pip install bokeh

Requirement already satisfied (use --upgrade to upgrade): bokeh in /usr/local/lib/python2.7/dist-packages

Requirement already satisfied (use --upgrade to upgrade): six>=1.5.2 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): requests>=1.2.3 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): PyYAML>=3.10 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): python-dateutil>=2.1 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.7 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): numpy>=1.7.1 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): pandas>=0.11.0 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): Flask>=0.10.1 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): pyzmq>=14.3.1 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): tornado>=4.0.1 in /usr/local/lib/python2.7/dist-packages (from bokeh)

Requirement already satisfied (use --upgrade to upgrade): MarkupSafe in /usr/local/lib/python2.7/dist-packages (from Jinja2>=2.7->bokeh)

Requirement already satisfied (use --upgrade to upgrade): pytz>=2011k in /usr/local/lib/python2.7/dist-packages (from pandas>=0.11.0->bokeh)

Requirement already satisfied (use --upgrade to upgrade): Werkzeug>=0.7 in /usr/local/lib/python2.7/dist-packages (from Flask>=0.10.1->bokeh)

Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.21 in /usr/local/lib/python2.7/dist-packages (from Flask>=0.10.1->bokeh)

Requirement already satisfied (use --upgrade to upgrade): backports.ssl-match-hostname in /usr/local/lib/python2.7/dist-packages (from tornado>=4.0.1->bokeh)

Requirement already satisfied (use --upgrade to upgrade): certifi in /usr/local/lib/python2.7/dist-packages (from tornado>=4.0.1->bokeh)

[email protected]:~#