newly discovered Bokeh incompatibility with new Tornado v4.5 release

Hi Bokeh Users -

We’ve confirmed an incompatibility with Bokeh Server applications and the new Tornado v4.5 release. A current workaround is to downgrade Tornado to v4.4.2 as we work to diagnose and resolve this issue. You can track the progress of this issue at https://github.com/bokeh/bokeh/issues/6152

If you’re knowledgeable about tornado applications, we’d appreciate any help. Otherwise, we appreciate your patience and are glad that you’re part of the Bokeh community.

  • lukec
···

Luke Canavan

Software Developer

FYI all, this is fixed in master and the latest dev build. Additionally the conda package in the defaults channel has had its dependencies updated to exclude Tornado 4.5

Thanks,

Bryan

···

On Apr 17, 2017, at 18:09, Luke Canavan <[email protected]> wrote:

Hi Bokeh Users -

We've confirmed an incompatibility with Bokeh Server applications and the new Tornado v4.5 release. A current workaround is to downgrade Tornado to v4.4.2 as we work to diagnose and resolve this issue. You can track the progress of this issue at https://github.com/bokeh/bokeh/issues/6152

If you're knowledgeable about tornado applications, we'd appreciate any help. Otherwise, we appreciate your patience and are glad that you're part of the Bokeh community.

- lukec

--

Luke Canavan
Software Developer

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/CABzwKL5fqQL73dVfgu7tOUCAdFxTCxmDML6xWu20ZHSfwGSygw%40mail.gmail.com.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

I’ve had the same problem here and took some time to figure out

If you install bokeh via pip, you still need to downgrade Tornado to 4.4.2

best,

···

On Sat, Apr 22, 2017 at 2:45 PM, Bryan Van de ven [email protected] wrote:

FYI all, this is fixed in master and the latest dev build. Additionally the conda package in the defaults channel has had its dependencies updated to exclude Tornado 4.5

Thanks,

Bryan

On Apr 17, 2017, at 18:09, Luke Canavan [email protected] wrote:

Hi Bokeh Users -

We’ve confirmed an incompatibility with Bokeh Server applications and the new Tornado v4.5 release. A current workaround is to downgrade Tornado to v4.4.2 as we work to diagnose and resolve this issue. You can track the progress of this issue at https://github.com/bokeh/bokeh/issues/6152

If you’re knowledgeable about tornado applications, we’d appreciate any help. Otherwise, we appreciate your patience and are glad that you’re part of the Bokeh community.

  • lukec

Luke Canavan

Software Developer

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/CABzwKL5fqQL73dVfgu7tOUCAdFxTCxmDML6xWu20ZHSfwGSygw%40mail.gmail.com.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/7C09FD9F-22D1-4485-8DBE-BA1F8169969C%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Angelo Fausti Neto
LIneA/LSST