Passing websocket_max_message_size when embedding bokeh server in a notebook

When bokeh server is embedded in a notebook (like here https://github.com/bokeh/bokeh/blob/master/examples/howto/server_embed/notebook_embed.ipynb) there are connection errors when plots are large, like in this issue: https://github.com/bokeh/bokeh/issues/7374 (and smaller plots work just fine). I see from the docs I can use --websocket-max-message-size argument with larger value for standalone bokeh server.

I wonder is there a possibility to use such argument when embedding bokeh server in a notebook, or maybe there is at least some workaround?

Hi,

All the command line arguments are also keyword parameters, e.g. websocket_max_message_size

Thanks,

Bryan

···

On Jan 14, 2019, at 08:14, [email protected] wrote:

When bokeh server is embedded in a notebook (like here https://github.com/bokeh/bokeh/blob/master/examples/howto/server_embed/notebook_embed.ipynb) there are connection errors when plots are large, like in this issue: https://github.com/bokeh/bokeh/issues/7374 (and smaller plots work just fine). I see from the docs I can use --websocket-max-message-size argument with larger value for standalone bokeh server.

I wonder is there a possibility to use such argument when embedding bokeh server in a notebook, or maybe there is at least some workaround?

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a926d80a-6edf-423d-9585-4cf67ef4e7af%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Hi Bryan,

I’ve noticed that the websocket_max_message_size is a keyword argument for Server class, but I wonder how to pass it that Server class from notebook when using bokeh.io.show(app, notebook_url).

I’ve checked Bokeh sources, it looks like this line is where the Server is created:

https://github.com/bokeh/bokeh/blob/d260c429451a04b1fc00f593ef98f10ce1392e57/bokeh/io/notebook.py#L475

and no **kwargs are passed to it from the outer function. Looks like there is no straightforward way to pass websocket_max_message_size to the created server.

···

понедельник, 14 января 2019 г., 19:23:43 UTC+3 пользователь Bryan Van de ven написал:

Hi,

All the command line arguments are also keyword parameters, e.g. websocket_max_message_size

Thanks,

Bryan

On Jan 14, 2019, at 08:14, [email protected] wrote:

When bokeh server is embedded in a notebook (like here https://github.com/bokeh/bokeh/blob/master/examples/howto/server_embed/notebook_embed.ipynb) there are connection errors when plots are large, like in this issue: https://github.com/bokeh/bokeh/issues/7374 (and smaller plots work just fine). I see from the docs I can use --websocket-max-message-size argument with larger value for standalone bokeh server.

I wonder is there a possibility to use such argument when embedding bokeh server in a notebook, or maybe there is at least some workaround?


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a926d80a-6edf-423d-9585-4cf67ef4e7af%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Hi,

I think for now you will have to make your own version of the show_app function that passes the parameter. If you wanted to make PR that makes things more user-configurable, e.g. add a generic **kwargs parameter to show_app that gets passed on to Server, we would certainly consider it.

Thanks,

Bryan

···

On Jan 15, 2019, at 04:40, [email protected] wrote:

Hi Bryan,

I've noticed that the websocket_max_message_size is a keyword argument for Server class, but I wonder how to pass it that Server class from notebook when using bokeh.io.show(app, notebook_url).

I've checked Bokeh sources, it looks like this line is where the Server is created:
https://github.com/bokeh/bokeh/blob/d260c429451a04b1fc00f593ef98f10ce1392e57/bokeh/io/notebook.py#L475

and no **kwargs are passed to it from the outer function. Looks like there is no straightforward way to pass websocket_max_message_size to the created server.

понедельник, 14 января 2019 г., 19:23:43 UTC+3 пользователь Bryan Van de ven написал:
Hi,

All the command line arguments are also keyword parameters, e.g. websocket_max_message_size

Thanks,

Bryan

> On Jan 14, 2019, at 08:14, [email protected] wrote:
>
> When bokeh server is embedded in a notebook (like here https://github.com/bokeh/bokeh/blob/master/examples/howto/server_embed/notebook_embed.ipynb) there are connection errors when plots are large, like in this issue: https://github.com/bokeh/bokeh/issues/7374 (and smaller plots work just fine). I see from the docs I can use --websocket-max-message-size argument with larger value for standalone bokeh server.
>
> I wonder is there a possibility to use such argument when embedding bokeh server in a notebook, or maybe there is at least some workaround?
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a926d80a-6edf-423d-9585-4cf67ef4e7af%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/20a30296-9c28-46d1-b857-5c62b00ec8e8%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Hi Bryan,

Yes, I’ll try to make a PR that does that. The corresponding issue is https://github.com/bokeh/bokeh/issues/8583

Best,

Eugene

···

понедельник, 21 января 2019 г., 20:45:28 UTC+3 пользователь Bryan Van de ven написал:

Hi,

I think for now you will have to make your own version of the show_app function that passes the parameter. If you wanted to make PR that makes things more user-configurable, e.g. add a generic **kwargs parameter to show_app that gets passed on to Server, we would certainly consider it.

Thanks,

Bryan

On Jan 15, 2019, at 04:40, [email protected] wrote:

Hi Bryan,

I’ve noticed that the websocket_max_message_size is a keyword argument for Server class, but I wonder how to pass it that Server class from notebook when using bokeh.io.show(app, notebook_url).

I’ve checked Bokeh sources, it looks like this line is where the Server is created:

https://github.com/bokeh/bokeh/blob/d260c429451a04b1fc00f593ef98f10ce1392e57/bokeh/io/notebook.py#L475

and no **kwargs are passed to it from the outer function. Looks like there is no straightforward way to pass websocket_max_message_size to the created server.

понедельник, 14 января 2019 г., 19:23:43 UTC+3 пользователь Bryan Van de ven написал:

Hi,

All the command line arguments are also keyword parameters, e.g. websocket_max_message_size

Thanks,

Bryan

On Jan 14, 2019, at 08:14, [email protected] wrote:

When bokeh server is embedded in a notebook (like here https://github.com/bokeh/bokeh/blob/master/examples/howto/server_embed/notebook_embed.ipynb) there are connection errors when plots are large, like in this issue: https://github.com/bokeh/bokeh/issues/7374 (and smaller plots work just fine). I see from the docs I can use --websocket-max-message-size argument with larger value for standalone bokeh server.

I wonder is there a possibility to use such argument when embedding bokeh server in a notebook, or maybe there is at least some workaround?


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a926d80a-6edf-423d-9585-4cf67ef4e7af%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/20a30296-9c28-46d1-b857-5c62b00ec8e8%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.