Several toolbar buttons nonfunctional in Jupyter notebook

I’m trying to create a simple line plot. No special interactions. And neither pan or box zoom are working. Wheel zoom, and refresh work.

OS: Linux Mint 20
Python: 3.10
Bokeh: 3.3.4
Jupyter: 7.0.7
Browser: Chrome 121.0.6167.160 and Firefox 122.0.1
Installation: venv via pip

I have another installation via Anaconda with Python 3.10, Jupyter 6.5.2 and Bokeh 2.4.3 that works, but trying those version in my new installation causes some other incompatibilities.

Nothing happens in the JS console when I try to use these interactions.

What does this mean? The latest version of Jupyter Lab is 4.1.0 I guess you are talking about something else? Please provide a complete and exact list of all jupyter-related packages.

Sorry, that’s notebook 7.0.7. I’m not sure why they don’t just call it jupyter-notebook :man_shrugging:

jupyter_client            7.4.9
jupyter_core              5.7.1
jupyter-events            0.9.0
jupyter-lsp               2.2.2
jupyter_server            2.12.5
jupyter_server_terminals  0.5.2
jupyterlab                4.1.0
jupyterlab_pygments       0.3.0
jupyterlab_server         2.25.2

I guess you mean this inexplicable revival of “plain” notebook? I can’t reproduce any issues with this on OSX with either Safari or Chrome. All the tools from this example work fine when I try them in the notebook. All I can suggest is to make a GitHub Issue with more details (e.g. exact code to reproduce).

I get the same result with jupyterlab. I also tried installing jupyter_bokeh, as the docs suggest. No difference. I’ll create an issue. Thanks.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.