VBar colors in legend

Hi,

I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?

Thanks,

Reuben

Here is what my chart and it’s legend look like currently:

As you can see the associated colors are not in the legend…

···

On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben Jacobs wrote:

Hi,

I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?

Thanks,

Reuben

Hi Reuben,

I believe t his is a
bug because there isn’t a
draw_legend method for vbar/hbar .

I noticed this just the other day and forgot.
Can you open an issue?

          It will be very easy to

fix.

Best,

Bird

···

On 9/7/16 11:39 AM, Reuben Jacobs
wrote:

    Here is what my chart and it's legend look like

currently:

      As you can see the associated colors are not in the

legend…

      On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben

Jacobs wrote:

Hi,

          I was able to make a stacked bar chart with various hover

tooltips using plotting and VBars. I also enabled a legend
for the plot. However, my vbars are colored and the colors
for each vbar (each stack) are not appearing in the
legend. Only the names for the stack in the legend are
appearing. Is this not an implemented feature yet?

Thanks,

Reuben

  You received this message because you are subscribed to the Google

Groups “Bokeh Discussion - Public” group.

  To unsubscribe from this group and stop receiving emails from it,

send an email to [email protected].

  To post to this group, send email to [email protected]

  To view this discussion on the web visit [https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io](https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io?utm_medium=email&utm_source=footer).

  For more options, visit [https://groups.google.com/a/continuum.io/d/optout](https://groups.google.com/a/continuum.io/d/optout).


Sarah Bird
Developer, Bokeh

    [
      ![Continuum Analytics](http://docs.continuum.io/_static/img/ContinuumWordmark.png)
    ](http://continuum.io)

As a side note, you might want to desaturate some your colors.

Regards,

Francois

···

On Wednesday, September 7, 2016 at 2:39:34 PM UTC-4, Reuben Jacobs wrote:

Here is what my chart and it’s legend look like currently:

As you can see the associated colors are not in the legend…

On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben Jacobs wrote:

Hi,

I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?

Thanks,

Reuben

I opened an issue and
submitted a PR fixing it:

···

https://github.com/bokeh/bokeh/pull/5114
On 9/7/16 1:16 PM, Sarah Bird -
Continuum wrote:

Hi Reuben,

I
believe this is a bug because there isn’t a draw_legend method fo r
vbar/hbar.

                I

noticed this just the
other day and forgot.
Can you open an issue?

            It will

be very easy to fix.

Best,

Bird


Sarah Bird
Developer, Bokeh

    [
      ![Continuum Analytics](http://docs.continuum.io/_static/img/ContinuumWordmark.png)
    ](http://continuum.io)

    On 9/7/16 11:39 AM, Reuben Jacobs

wrote:

      Here is what my chart and it's legend look like

currently:

        As you can see the associated colors are not in the

legend…

        On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben

Jacobs wrote:

Hi,

            I was able to make a stacked bar chart with various

hover tooltips using plotting and VBars. I also enabled
a legend for the plot. However, my vbars are colored and
the colors for each vbar (each stack) are not appearing
in the legend. Only the names for the stack in the
legend are appearing. Is this not an implemented feature
yet?

Thanks,

Reuben

    You received this message because you are subscribed to the

Google Groups “Bokeh Discussion - Public” group.

    To unsubscribe from this group and stop receiving emails from

it, send an email to [email protected].

    To post to this group, send email to [email protected]

    To view this discussion on the web visit [https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io](https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io?utm_medium=email&utm_source=footer).

    For more options, visit [https://groups.google.com/a/continuum.io/d/optout](https://groups.google.com/a/continuum.io/d/optout).


Sarah Bird
Developer, Bokeh

      [ ![Continuum Analytics](http://docs.continuum.io/_static/img/ContinuumWordmark.png) ](http://continuum.io)

Sarah,

Thank you so much! I was going to open an issue today as I was fairly busy yesterday, but you beat me to it! I think I will make these changes in my local bokeh for the time being.

Thanks again,

Reuben

···

On Thursday, September 8, 2016 at 2:01:18 AM UTC-4, Sarah Bird wrote:

      I opened an issue and

submitted a PR fixing it:
https://github.com/bokeh/bokeh/pull/5114

  On 9/7/16 1:16 PM, Sarah Bird - > Continuum wrote:

Hi Reuben,

I
believe this is a bug because there isn’t a draw_legend method fo r
vbar/hbar.

                I

noticed this just the
other day and forgot.
Can you open an issue?

            It will

be very easy to fix.

Best,

Bird

    On 9/7/16 11:39 AM, Reuben Jacobs > > wrote:
      Here is what my chart and it's legend look like

currently:

        As you can see the associated colors are not in the

legend…

        On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben > > > Jacobs wrote:

Hi,

            I was able to make a stacked bar chart with various

hover tooltips using plotting and VBars. I also enabled
a legend for the plot. However, my vbars are colored and
the colors for each vbar (each stack) are not appearing
in the legend. Only the names for the stack in the
legend are appearing. Is this not an implemented feature
yet?

Thanks,

Reuben

    You received this message because you are subscribed to the

Google Groups “Bokeh Discussion - Public” group.

    To unsubscribe from this group and stop receiving emails from

it, send an email to [email protected].

    To post to this group, send email to [email protected]

    To view this discussion on the web visit [https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io](https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io?utm_medium=email&utm_source=footer).

    For more options, visit [https://groups.google.com/a/continuum.io/d/optout](https://groups.google.com/a/continuum.io/d/optout).


Sarah Bird
Developer, Bokeh

      [ <img alt="Continuum Analytics" src="https://lh6.googleusercontent.com/proxy/VYgVjggTk1hCXSN9wFkffE3I6kxTvJ51tT4KvDXOuKbs1WyFG66k7kt2-vkDimbyxfWtP-d1paJmstMYhPPnDYSUF4rLPoYM2GM2QFM=w5000-h5000" style="width:150px;min-height:30px" height="30px" width="150px"> ](http://continuum.io)


Sarah Bird
Developer, Bokeh

    [
      <img alt="Continuum Analytics" src="https://lh6.googleusercontent.com/proxy/VYgVjggTk1hCXSN9wFkffE3I6kxTvJ51tT4KvDXOuKbs1WyFG66k7kt2-vkDimbyxfWtP-d1paJmstMYhPPnDYSUF4rLPoYM2GM2QFM=w5000-h5000" style="width:150px;min-height:30px" height="30px" width="150px">
    ](http://continuum.io)

Hi Sarah,

So I made your changes in a local bokeh repo and then built the package from that repo. I verify that in my python’s new version of bokeh (built) I see the line of code :

VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {

return this._generic_area_legend(ctx, x0, x1, y0, y1, index);

};

``

within “/usr/local/lib/python2.7/dist-packages/bokeh/server/static/js/tree/models/glyphs/vbar.js”. However, even with this code in my version of bokeh, my vbar plot still has no colors in the legend.

Any thoughts?

Thanks,

Reuben

···

On Thursday, September 8, 2016 at 9:30:14 AM UTC-4, Reuben Jacobs wrote:

Sarah,

Thank you so much! I was going to open an issue today as I was fairly busy yesterday, but you beat me to it! I think I will make these changes in my local bokeh for the time being.

Thanks again,

Reuben

On Thursday, September 8, 2016 at 2:01:18 AM UTC-4, Sarah Bird wrote:

      I opened an issue and

submitted a PR fixing it:
https://github.com/bokeh/bokeh/pull/5114

  On 9/7/16 1:16 PM, Sarah Bird - > > Continuum wrote:

Hi Reuben,

I
believe this is a bug because there isn’t a draw_legend method fo r
vbar/hbar.

                I

noticed this just the
other day and forgot.
Can you open an issue?

            It will

be very easy to fix.

Best,

Bird

    On 9/7/16 11:39 AM, Reuben Jacobs > > > wrote:
      Here is what my chart and it's legend look like

currently:

        As you can see the associated colors are not in the

legend…

        On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben > > > > Jacobs wrote:

Hi,

            I was able to make a stacked bar chart with various

hover tooltips using plotting and VBars. I also enabled
a legend for the plot. However, my vbars are colored and
the colors for each vbar (each stack) are not appearing
in the legend. Only the names for the stack in the
legend are appearing. Is this not an implemented feature
yet?

Thanks,

Reuben

    You received this message because you are subscribed to the

Google Groups “Bokeh Discussion - Public” group.

    To unsubscribe from this group and stop receiving emails from

it, send an email to [email protected].

    To post to this group, send email to [email protected]

    To view this discussion on the web visit [https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io](https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io?utm_medium=email&utm_source=footer).

    For more options, visit [https://groups.google.com/a/continuum.io/d/optout](https://groups.google.com/a/continuum.io/d/optout).


Sarah Bird
Developer, Bokeh

      [ <img alt="Continuum Analytics" src="https://lh6.googleusercontent.com/proxy/VYgVjggTk1hCXSN9wFkffE3I6kxTvJ51tT4KvDXOuKbs1WyFG66k7kt2-vkDimbyxfWtP-d1paJmstMYhPPnDYSUF4rLPoYM2GM2QFM=w5000-h5000" style="width:150px;min-height:30px" height="30px" width="150px"> ](http://continuum.io)


Sarah Bird
Developer, Bokeh

    [
      <img alt="Continuum Analytics" src="https://lh6.googleusercontent.com/proxy/VYgVjggTk1hCXSN9wFkffE3I6kxTvJ51tT4KvDXOuKbs1WyFG66k7kt2-vkDimbyxfWtP-d1paJmstMYhPPnDYSUF4rLPoYM2GM2QFM=w5000-h5000" style="width:150px;min-height:30px" height="30px" width="150px">
    ](http://continuum.io)

You'll need to set the environment variable `BOKEH_RESOURCES=inline` to pick up your locally built BokehJS, otherwise it will try to use the last released BokehJS from CDN.

Thanks,

Bryan

···

On Sep 8, 2016, at 9:36 AM, Reuben Jacobs <[email protected]> wrote:

Hi Sarah,

So I made your changes in a local bokeh repo and then built the package from that repo. I verify that in my python's new version of bokeh (built) I see the line of code :

  VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {
    return this._generic_area_legend(ctx, x0, x1, y0, y1, index);
  };

within "/usr/local/lib/python2.7/dist-packages/bokeh/server/static/js/tree/models/glyphs/vbar.js". However, even with this code in my version of bokeh, my vbar plot still has no colors in the legend.

Any thoughts?

Thanks,
Reuben

On Thursday, September 8, 2016 at 9:30:14 AM UTC-4, Reuben Jacobs wrote:
Sarah,

Thank you so much! I was going to open an issue today as I was fairly busy yesterday, but you beat me to it! I think I will make these changes in my local bokeh for the time being.

Thanks again,
Reuben

On Thursday, September 8, 2016 at 2:01:18 AM UTC-4, Sarah Bird wrote:
I opened an issue and submitted a PR fixing it: https://github.com/bokeh/bokeh/pull/5114

On 9/7/16 1:16 PM, Sarah Bird - Continuum wrote:

Hi Reuben,

I believe this is a bug because there isn't a draw_legend method for vbar/hbar.

I noticed this just the other day and forgot. Can you open an issue?

It will be very easy to fix.

Best,

Bird

On 9/7/16 11:39 AM, Reuben Jacobs wrote:

Here is what my chart and it's legend look like currently:

As you can see the associated colors are not in the legend..

On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben Jacobs wrote:
Hi,

I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?

Thanks,
Reuben
--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
Sarah Bird
Developer, Bokeh

--
Sarah Bird
Developer, Bokeh

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f695d5a-785d-4216-9816-f3786a3ddd20%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Bryan,

Upon installation of bokeh (running "python setup.py install) I selected the option “2) install last built BokehJS from bokeh/bokehjs/build”

I just exported BOKEH_RESOURCES=inline and uninstalled and reinstalled bokeh selecting that option, but this issue is still occurring.

Reuben

···

On Thursday, September 8, 2016 at 10:49:27 AM UTC-4, Bryan Van de ven wrote:

You’ll need to set the environment variable BOKEH_RESOURCES=inline to pick up your locally built BokehJS, otherwise it will try to use the last released BokehJS from CDN.

Thanks,

Bryan

On Sep 8, 2016, at 9:36 AM, Reuben Jacobs [email protected] wrote:

Hi Sarah,

So I made your changes in a local bokeh repo and then built the package from that repo. I verify that in my python’s new version of bokeh (built) I see the line of code :

VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {

return this._generic_area_legend(ctx, x0, x1, y0, y1, index);

};

within “/usr/local/lib/python2.7/dist-packages/bokeh/server/static/js/tree/models/glyphs/vbar.js”. However, even with this code in my version of bokeh, my vbar plot still has no colors in the legend.

Any thoughts?

Thanks,

Reuben

On Thursday, September 8, 2016 at 9:30:14 AM UTC-4, Reuben Jacobs wrote:

Sarah,

Thank you so much! I was going to open an issue today as I was fairly busy yesterday, but you beat me to it! I think I will make these changes in my local bokeh for the time being.

Thanks again,

Reuben

On Thursday, September 8, 2016 at 2:01:18 AM UTC-4, Sarah Bird wrote:

I opened an issue and submitted a PR fixing it: https://github.com/bokeh/bokeh/pull/5114

On 9/7/16 1:16 PM, Sarah Bird - Continuum wrote:

Hi Reuben,

I believe this is a bug because there isn’t a draw_legend method for vbar/hbar.

I noticed this just the other day and forgot. Can you open an issue?

It will be very easy to fix.

Best,

Bird

On 9/7/16 11:39 AM, Reuben Jacobs wrote:

Here is what my chart and it’s legend look like currently:

As you can see the associated colors are not in the legend…

On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben Jacobs wrote:

Hi,

I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?

Thanks,

Reuben


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.


Sarah Bird

Developer, Bokeh


Sarah Bird

Developer, Bokeh


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f695d5a-785d-4216-9816-f3786a3ddd20%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Did you previously select option 1? The changes are in BokehJS so BokehJS has to be rebuilt locally for you to see them take effect. You'd need to have installed npm, run "npm install" in the bokehjs subdir first.

Thanks,

Bryan

···

On Sep 8, 2016, at 10:09 AM, Reuben Jacobs <[email protected]> wrote:

Bryan,

Upon installation of bokeh (running "python setup.py install) I selected the option "2) install last built BokehJS from bokeh/bokehjs/build"

I just exported `BOKEH_RESOURCES=inline` and uninstalled and reinstalled bokeh selecting that option, but this issue is still occurring.

Reuben

On Thursday, September 8, 2016 at 10:49:27 AM UTC-4, Bryan Van de ven wrote:
You'll need to set the environment variable `BOKEH_RESOURCES=inline` to pick up your locally built BokehJS, otherwise it will try to use the last released BokehJS from CDN.

Thanks,

Bryan

> On Sep 8, 2016, at 9:36 AM, Reuben Jacobs <[email protected]> wrote:
>
> Hi Sarah,
>
> So I made your changes in a local bokeh repo and then built the package from that repo. I verify that in my python's new version of bokeh (built) I see the line of code :
>
> VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {
> return this._generic_area_legend(ctx, x0, x1, y0, y1, index);
> };
>
>
> within "/usr/local/lib/python2.7/dist-packages/bokeh/server/static/js/tree/models/glyphs/vbar.js". However, even with this code in my version of bokeh, my vbar plot still has no colors in the legend.
>
> Any thoughts?
>
> Thanks,
> Reuben
>
> On Thursday, September 8, 2016 at 9:30:14 AM UTC-4, Reuben Jacobs wrote:
> Sarah,
>
> Thank you so much! I was going to open an issue today as I was fairly busy yesterday, but you beat me to it! I think I will make these changes in my local bokeh for the time being.
>
> Thanks again,
> Reuben
>
> On Thursday, September 8, 2016 at 2:01:18 AM UTC-4, Sarah Bird wrote:
> I opened an issue and submitted a PR fixing it: https://github.com/bokeh/bokeh/pull/5114
>
>
> On 9/7/16 1:16 PM, Sarah Bird - Continuum wrote:
>> Hi Reuben,
>>
>> I believe this is a bug because there isn't a draw_legend method for vbar/hbar.
>>
>> I noticed this just the other day and forgot. Can you open an issue?
>>
>> It will be very easy to fix.
>>
>> Best,
>>
>> Bird
>>
>> On 9/7/16 11:39 AM, Reuben Jacobs wrote:
>>> Here is what my chart and it's legend look like currently:
>>>
>>> As you can see the associated colors are not in the legend..
>>>
>>>
>>>
>>>
>>> On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben Jacobs wrote:
>>> Hi,
>>>
>>> I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?
>>>
>>> Thanks,
>>> Reuben
>>> --
>>> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
>>> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
>>> To post to this group, send email to [email protected].
>>> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io.
>>> For more options, visit https://groups.google.com/a/continuum.io/d/optout.
>>
>> --
>> Sarah Bird
>> Developer, Bokeh
>>
>>
>>
>
> --
> Sarah Bird
> Developer, Bokeh
>
>
>
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f695d5a-785d-4216-9816-f3786a3ddd20%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected]continuum.io.
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f0efd8e-f7ec-428b-98bd-48688f13676c%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Never installed option 1. I followed all the instructions to the letter including isntalling npm and all dependencies needed with npm. I made my change in BokehJS, built bokeh JS locally, and I see the changes reflected in the built js file in “dist-packages/bokeh/” after installing. However, the changes do not seem to be doing anything when I create the plot.

···

On Thursday, September 8, 2016 at 11:11:43 AM UTC-4, Bryan Van de ven wrote:

Did you previously select option 1? The changes are in BokehJS so BokehJS has to be rebuilt locally for you to see them take effect. You’d need to have installed npm, run “npm install” in the bokehjs subdir first.

Thanks,

Bryan

On Sep 8, 2016, at 10:09 AM, Reuben Jacobs [email protected] wrote:

Bryan,

Upon installation of bokeh (running "python setup.py install) I selected the option “2) install last built BokehJS from bokeh/bokehjs/build”

I just exported BOKEH_RESOURCES=inline and uninstalled and reinstalled bokeh selecting that option, but this issue is still occurring.

Reuben

On Thursday, September 8, 2016 at 10:49:27 AM UTC-4, Bryan Van de ven wrote:

You’ll need to set the environment variable BOKEH_RESOURCES=inline to pick up your locally built BokehJS, otherwise it will try to use the last released BokehJS from CDN.

Thanks,

Bryan

On Sep 8, 2016, at 9:36 AM, Reuben Jacobs [email protected] wrote:

Hi Sarah,

So I made your changes in a local bokeh repo and then built the package from that repo. I verify that in my python’s new version of bokeh (built) I see the line of code :

VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {
return this._generic_area_legend(ctx, x0, x1, y0, y1, index);
};

within “/usr/local/lib/python2.7/dist-packages/bokeh/server/static/js/tree/models/glyphs/vbar.js”. However, even with this code in my version of bokeh, my vbar plot still has no colors in the legend.

Any thoughts?

Thanks,
Reuben

On Thursday, September 8, 2016 at 9:30:14 AM UTC-4, Reuben Jacobs wrote:
Sarah,

Thank you so much! I was going to open an issue today as I was fairly busy yesterday, but you beat me to it! I think I will make these changes in my local bokeh for the time being.

Thanks again,
Reuben

On Thursday, September 8, 2016 at 2:01:18 AM UTC-4, Sarah Bird wrote:
I opened an issue and submitted a PR fixing it: https://github.com/bokeh/bokeh/pull/5114

On 9/7/16 1:16 PM, Sarah Bird - Continuum wrote:

Hi Reuben,

I believe this is a bug because there isn’t a draw_legend method for vbar/hbar.

I noticed this just the other day and forgot. Can you open an issue?

It will be very easy to fix.

Best,

Bird

On 9/7/16 11:39 AM, Reuben Jacobs wrote:

Here is what my chart and it’s legend look like currently:

As you can see the associated colors are not in the legend…

On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben Jacobs wrote:
Hi,

I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?

Thanks,
Reuben

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


Sarah Bird
Developer, Bokeh


Sarah Bird
Developer, Bokeh


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f695d5a-785d-4216-9816-f3786a3ddd20%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f0efd8e-f7ec-428b-98bd-48688f13676c%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

So the change in vbar.js does not actually matter, can you also add BOKEH_MINIFIED=no to the other env var I mentioned, and then verify that the changes are in the inline JS in the HTML page souce (e.g. by searching for "VBarView.prototype.draw_legend_for_index")?

Thanks,

Bryan

···

On Sep 8, 2016, at 10:15 AM, Reuben Jacobs <[email protected]> wrote:

Never installed option 1. I followed all the instructions to the letter including isntalling npm and all dependencies needed with npm. I made my change in BokehJS, built bokeh JS locally, and I see the changes reflected in the built js file in "dist-packages/bokeh/" after installing. However, the changes do not seem to be doing anything when I create the plot.

On Thursday, September 8, 2016 at 11:11:43 AM UTC-4, Bryan Van de ven wrote:
Did you previously select option 1? The changes are in BokehJS so BokehJS has to be rebuilt locally for you to see them take effect. You'd need to have installed npm, run "npm install" in the bokehjs subdir first.

Thanks,

Bryan

> On Sep 8, 2016, at 10:09 AM, Reuben Jacobs <[email protected]> wrote:
>
> Bryan,
>
> Upon installation of bokeh (running "python setup.py install) I selected the option "2) install last built BokehJS from bokeh/bokehjs/build"
>
> I just exported `BOKEH_RESOURCES=inline` and uninstalled and reinstalled bokeh selecting that option, but this issue is still occurring.
>
> Reuben
>
> On Thursday, September 8, 2016 at 10:49:27 AM UTC-4, Bryan Van de ven wrote:
> You'll need to set the environment variable `BOKEH_RESOURCES=inline` to pick up your locally built BokehJS, otherwise it will try to use the last released BokehJS from CDN.
>
> Thanks,
>
> Bryan
>
> > On Sep 8, 2016, at 9:36 AM, Reuben Jacobs <[email protected]> wrote:
> >
> > Hi Sarah,
> >
> > So I made your changes in a local bokeh repo and then built the package from that repo. I verify that in my python's new version of bokeh (built) I see the line of code :
> >
> > VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {
> > return this._generic_area_legend(ctx, x0, x1, y0, y1, index);
> > };
> >
> >
> > within "/usr/local/lib/python2.7/dist-packages/bokeh/server/static/js/tree/models/glyphs/vbar.js". However, even with this code in my version of bokeh, my vbar plot still has no colors in the legend.
> >
> > Any thoughts?
> >
> > Thanks,
> > Reuben
> >
> > On Thursday, September 8, 2016 at 9:30:14 AM UTC-4, Reuben Jacobs wrote:
> > Sarah,
> >
> > Thank you so much! I was going to open an issue today as I was fairly busy yesterday, but you beat me to it! I think I will make these changes in my local bokeh for the time being.
> >
> > Thanks again,
> > Reuben
> >
> > On Thursday, September 8, 2016 at 2:01:18 AM UTC-4, Sarah Bird wrote:
> > I opened an issue and submitted a PR fixing it: https://github.com/bokeh/bokeh/pull/5114
> >
> >
> > On 9/7/16 1:16 PM, Sarah Bird - Continuum wrote:
> >> Hi Reuben,
> >>
> >> I believe this is a bug because there isn't a draw_legend method for vbar/hbar.
> >>
> >> I noticed this just the other day and forgot. Can you open an issue?
> >>
> >> It will be very easy to fix.
> >>
> >> Best,
> >>
> >> Bird
> >>
> >> On 9/7/16 11:39 AM, Reuben Jacobs wrote:
> >>> Here is what my chart and it's legend look like currently:
> >>>
> >>> As you can see the associated colors are not in the legend..
> >>>
> >>>
> >>>
> >>>
> >>> On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben Jacobs wrote:
> >>> Hi,
> >>>
> >>> I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?
> >>>
> >>> Thanks,
> >>> Reuben
> >>> --
> >>> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> >>> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> >>> To post to this group, send email to [email protected].
> >>> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io.
> >>> For more options, visit https://groups.google.com/a/continuum.io/d/optout.
> >>
> >> --
> >> Sarah Bird
> >> Developer, Bokeh
> >>
> >>
> >>
> >
> > --
> > Sarah Bird
> > Developer, Bokeh
> >
> >
> >
> >
> > --
> > You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> > To post to this group, send email to [email protected].
> > To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f695d5a-785d-4216-9816-f3786a3ddd20%40continuum.io.
> > For more options, visit https://groups.google.com/a/continuum.io/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f0efd8e-f7ec-428b-98bd-48688f13676c%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/50ad7a37-136b-4d08-9771-edbe0db25873%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

I added both env vars and verified they existed before rebuilding and reinstalling. I then rebuilt BokehJS and reinstalled selecting option 2 (install last built BokehJS from bokeh/bokehjs/build"). I then launched my application and viewed the vbar plot on the page without colors in the legend. I hit ctrl+u in chrome to view the page source (the page with my vbar plot on it) and searched for “VBarView” which returned no results. It seems like to me the page source is still somewhat minified code. Maybe these env vars are not taking effect for some reason?

Thanks,
Reuben

···

On Thursday, September 8, 2016 at 11:29:01 AM UTC-4, Bryan Van de ven wrote:

So the change in vbar.js does not actually matter, can you also add BOKEH_MINIFIED=no to the other env var I mentioned, and then verify that the changes are in the inline JS in the HTML page souce (e.g. by searching for “VBarView.prototype.draw_legend_for_index”)?

Thanks,

Bryan

On Sep 8, 2016, at 10:15 AM, Reuben Jacobs [email protected] wrote:

Never installed option 1. I followed all the instructions to the letter including isntalling npm and all dependencies needed with npm. I made my change in BokehJS, built bokeh JS locally, and I see the changes reflected in the built js file in “dist-packages/bokeh/” after installing. However, the changes do not seem to be doing anything when I create the plot.

On Thursday, September 8, 2016 at 11:11:43 AM UTC-4, Bryan Van de ven wrote:

Did you previously select option 1? The changes are in BokehJS so BokehJS has to be rebuilt locally for you to see them take effect. You’d need to have installed npm, run “npm install” in the bokehjs subdir first.

Thanks,

Bryan

On Sep 8, 2016, at 10:09 AM, Reuben Jacobs [email protected] wrote:

Bryan,

Upon installation of bokeh (running "python setup.py install) I selected the option “2) install last built BokehJS from bokeh/bokehjs/build”

I just exported BOKEH_RESOURCES=inline and uninstalled and reinstalled bokeh selecting that option, but this issue is still occurring.

Reuben

On Thursday, September 8, 2016 at 10:49:27 AM UTC-4, Bryan Van de ven wrote:
You’ll need to set the environment variable BOKEH_RESOURCES=inline to pick up your locally built BokehJS, otherwise it will try to use the last released BokehJS from CDN.

Thanks,

Bryan

On Sep 8, 2016, at 9:36 AM, Reuben Jacobs [email protected] wrote:

Hi Sarah,

So I made your changes in a local bokeh repo and then built the package from that repo. I verify that in my python’s new version of bokeh (built) I see the line of code :

VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {
return this._generic_area_legend(ctx, x0, x1, y0, y1, index);
};

within “/usr/local/lib/python2.7/dist-packages/bokeh/server/static/js/tree/models/glyphs/vbar.js”. However, even with this code in my version of bokeh, my vbar plot still has no colors in the legend.

Any thoughts?

Thanks,
Reuben

On Thursday, September 8, 2016 at 9:30:14 AM UTC-4, Reuben Jacobs wrote:
Sarah,

Thank you so much! I was going to open an issue today as I was fairly busy yesterday, but you beat me to it! I think I will make these changes in my local bokeh for the time being.

Thanks again,
Reuben

On Thursday, September 8, 2016 at 2:01:18 AM UTC-4, Sarah Bird wrote:
I opened an issue and submitted a PR fixing it: https://github.com/bokeh/bokeh/pull/5114

On 9/7/16 1:16 PM, Sarah Bird - Continuum wrote:

Hi Reuben,

I believe this is a bug because there isn’t a draw_legend method for vbar/hbar.

I noticed this just the other day and forgot. Can you open an issue?

It will be very easy to fix.

Best,

Bird

On 9/7/16 11:39 AM, Reuben Jacobs wrote:

Here is what my chart and it’s legend look like currently:

As you can see the associated colors are not in the legend…

On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben Jacobs wrote:
Hi,

I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?

Thanks,
Reuben

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


Sarah Bird
Developer, Bokeh


Sarah Bird
Developer, Bokeh


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f695d5a-785d-4216-9816-f3786a3ddd20%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f0efd8e-f7ec-428b-98bd-48688f13676c%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/50ad7a37-136b-4d08-9771-edbe0db25873%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

What platform are you on? How are you setting the env vars? I run things like this:

    $ BOKEH_MINIFIED=no BOKEH_RESOURCES=inline python foo.py

on bash/zsh

Bryan

···

On Sep 8, 2016, at 10:52 AM, Reuben Jacobs <[email protected]> wrote:

I added both env vars and verified they existed before rebuilding and reinstalling. I then rebuilt BokehJS and reinstalled selecting option 2 (install last built BokehJS from bokeh/bokehjs/build"). I then launched my application and viewed the vbar plot on the page without colors in the legend. I hit ctrl+u in chrome to view the page source (the page with my vbar plot on it) and searched for "VBarView" which returned no results. It seems like to me the page source is still somewhat minified code. Maybe these env vars are not taking effect for some reason?

Thanks,
Reuben

On Thursday, September 8, 2016 at 11:29:01 AM UTC-4, Bryan Van de ven wrote:
So the change in vbar.js does not actually matter, can you also add BOKEH_MINIFIED=no to the other env var I mentioned, and then verify that the changes are in the inline JS in the HTML page souce (e.g. by searching for "VBarView.prototype.draw_legend_for_index")?

Thanks,

Bryan

> On Sep 8, 2016, at 10:15 AM, Reuben Jacobs <[email protected]> wrote:
>
> Never installed option 1. I followed all the instructions to the letter including isntalling npm and all dependencies needed with npm. I made my change in BokehJS, built bokeh JS locally, and I see the changes reflected in the built js file in "dist-packages/bokeh/" after installing. However, the changes do not seem to be doing anything when I create the plot.
>
> On Thursday, September 8, 2016 at 11:11:43 AM UTC-4, Bryan Van de ven wrote:
> Did you previously select option 1? The changes are in BokehJS so BokehJS has to be rebuilt locally for you to see them take effect. You'd need to have installed npm, run "npm install" in the bokehjs subdir first.
>
> Thanks,
>
> Bryan
>
>
> > On Sep 8, 2016, at 10:09 AM, Reuben Jacobs <[email protected]> wrote:
> >
> > Bryan,
> >
> > Upon installation of bokeh (running "python setup.py install) I selected the option "2) install last built BokehJS from bokeh/bokehjs/build"
> >
> > I just exported `BOKEH_RESOURCES=inline` and uninstalled and reinstalled bokeh selecting that option, but this issue is still occurring.
> >
> > Reuben
> >
> > On Thursday, September 8, 2016 at 10:49:27 AM UTC-4, Bryan Van de ven wrote:
> > You'll need to set the environment variable `BOKEH_RESOURCES=inline` to pick up your locally built BokehJS, otherwise it will try to use the last released BokehJS from CDN.
> >
> > Thanks,
> >
> > Bryan
> >
> > > On Sep 8, 2016, at 9:36 AM, Reuben Jacobs <[email protected]> wrote:
> > >
> > > Hi Sarah,
> > >
> > > So I made your changes in a local bokeh repo and then built the package from that repo. I verify that in my python's new version of bokeh (built) I see the line of code :
> > >
> > > VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {
> > > return this._generic_area_legend(ctx, x0, x1, y0, y1, index);
> > > };
> > >
> > >
> > > within "/usr/local/lib/python2.7/dist-packages/bokeh/server/static/js/tree/models/glyphs/vbar.js". However, even with this code in my version of bokeh, my vbar plot still has no colors in the legend.
> > >
> > > Any thoughts?
> > >
> > > Thanks,
> > > Reuben
> > >
> > > On Thursday, September 8, 2016 at 9:30:14 AM UTC-4, Reuben Jacobs wrote:
> > > Sarah,
> > >
> > > Thank you so much! I was going to open an issue today as I was fairly busy yesterday, but you beat me to it! I think I will make these changes in my local bokeh for the time being.
> > >
> > > Thanks again,
> > > Reuben
> > >
> > > On Thursday, September 8, 2016 at 2:01:18 AM UTC-4, Sarah Bird wrote:
> > > I opened an issue and submitted a PR fixing it: https://github.com/bokeh/bokeh/pull/5114
> > >
> > >
> > > On 9/7/16 1:16 PM, Sarah Bird - Continuum wrote:
> > >> Hi Reuben,
> > >>
> > >> I believe this is a bug because there isn't a draw_legend method for vbar/hbar.
> > >>
> > >> I noticed this just the other day and forgot. Can you open an issue?
> > >>
> > >> It will be very easy to fix.
> > >>
> > >> Best,
> > >>
> > >> Bird
> > >>
> > >> On 9/7/16 11:39 AM, Reuben Jacobs wrote:
> > >>> Here is what my chart and it's legend look like currently:
> > >>>
> > >>> As you can see the associated colors are not in the legend..
> > >>>
> > >>>
> > >>>
> > >>>
> > >>> On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben Jacobs wrote:
> > >>> Hi,
> > >>>
> > >>> I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?
> > >>>
> > >>> Thanks,
> > >>> Reuben
> > >>> --
> > >>> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > >>> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> > >>> To post to this group, send email to [email protected].
> > >>> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io.
> > >>> For more options, visit https://groups.google.com/a/continuum.io/d/optout.
> > >>
> > >> --
> > >> Sarah Bird
> > >> Developer, Bokeh
> > >>
> > >>
> > >>
> > >
> > > --
> > > Sarah Bird
> > > Developer, Bokeh
> > >
> > >
> > >
> > >
> > > --
> > > You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > > To unsubscribe from this group and stop receiving emails from it, send an email to [email protected]o.
> > > To post to this group, send email to [email protected].
> > > To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f695d5a-785d-4216-9816-f3786a3ddd20%40continuum.io.
> > > For more options, visit https://groups.google.com/a/continuum.io/d/optout.
> >
> >
> > --
> > You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> > To post to this group, send email to [email protected].
> > To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f0efd8e-f7ec-428b-98bd-48688f13676c%40continuum.io.
> > For more options, visit https://groups.google.com/a/continuum.io/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/50ad7a37-136b-4d08-9771-edbe0db25873%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/bb755aab-acf2-4e75-b27d-ce61c9202ed8%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

I am running Bash (stock terminal) on linux mint. I was trying to set the env vars as follows:

BOKEH_MINIFIED=no BOKEH_RESOURCES=inline

$ python foo.py

Running it all on one lien fixed my issue. The js is now not minified when I start my app. I opened the source and indeed found

``

VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {
return this._generic_area_legend(ctx, x0, x1, y0, y1, index);
}

``

around line 14.4k. However, the legend still does not appear with color in my plot.

Reuben

···

On Thursday, September 8, 2016 at 12:22:35 PM UTC-4, Bryan Van de ven wrote:

What platform are you on? How are you setting the env vars? I run things like this:

$ BOKEH_MINIFIED=no BOKEH_RESOURCES=inline python foo.py

on bash/zsh

Bryan

On Sep 8, 2016, at 10:52 AM, Reuben Jacobs [email protected] wrote:

I added both env vars and verified they existed before rebuilding and reinstalling. I then rebuilt BokehJS and reinstalled selecting option 2 (install last built BokehJS from bokeh/bokehjs/build"). I then launched my application and viewed the vbar plot on the page without colors in the legend. I hit ctrl+u in chrome to view the page source (the page with my vbar plot on it) and searched for “VBarView” which returned no results. It seems like to me the page source is still somewhat minified code. Maybe these env vars are not taking effect for some reason?

Thanks,

Reuben

On Thursday, September 8, 2016 at 11:29:01 AM UTC-4, Bryan Van de ven wrote:

So the change in vbar.js does not actually matter, can you also add BOKEH_MINIFIED=no to the other env var I mentioned, and then verify that the changes are in the inline JS in the HTML page souce (e.g. by searching for “VBarView.prototype.draw_legend_for_index”)?

Thanks,

Bryan

On Sep 8, 2016, at 10:15 AM, Reuben Jacobs [email protected] wrote:

Never installed option 1. I followed all the instructions to the letter including isntalling npm and all dependencies needed with npm. I made my change in BokehJS, built bokeh JS locally, and I see the changes reflected in the built js file in “dist-packages/bokeh/” after installing. However, the changes do not seem to be doing anything when I create the plot.

On Thursday, September 8, 2016 at 11:11:43 AM UTC-4, Bryan Van de ven wrote:
Did you previously select option 1? The changes are in BokehJS so BokehJS has to be rebuilt locally for you to see them take effect. You’d need to have installed npm, run “npm install” in the bokehjs subdir first.

Thanks,

Bryan

On Sep 8, 2016, at 10:09 AM, Reuben Jacobs [email protected] wrote:

Bryan,

Upon installation of bokeh (running "python setup.py install) I selected the option “2) install last built BokehJS from bokeh/bokehjs/build”

I just exported BOKEH_RESOURCES=inline and uninstalled and reinstalled bokeh selecting that option, but this issue is still occurring.

Reuben

On Thursday, September 8, 2016 at 10:49:27 AM UTC-4, Bryan Van de ven wrote:
You’ll need to set the environment variable BOKEH_RESOURCES=inline to pick up your locally built BokehJS, otherwise it will try to use the last released BokehJS from CDN.

Thanks,

Bryan

On Sep 8, 2016, at 9:36 AM, Reuben Jacobs [email protected] wrote:

Hi Sarah,

So I made your changes in a local bokeh repo and then built the package from that repo. I verify that in my python’s new version of bokeh (built) I see the line of code :

VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {
return this._generic_area_legend(ctx, x0, x1, y0, y1, index);
};

within “/usr/local/lib/python2.7/dist-packages/bokeh/server/static/js/tree/models/glyphs/vbar.js”. However, even with this code in my version of bokeh, my vbar plot still has no colors in the legend.

Any thoughts?

Thanks,
Reuben

On Thursday, September 8, 2016 at 9:30:14 AM UTC-4, Reuben Jacobs wrote:
Sarah,

Thank you so much! I was going to open an issue today as I was fairly busy yesterday, but you beat me to it! I think I will make these changes in my local bokeh for the time being.

Thanks again,
Reuben

On Thursday, September 8, 2016 at 2:01:18 AM UTC-4, Sarah Bird wrote:
I opened an issue and submitted a PR fixing it: https://github.com/bokeh/bokeh/pull/5114

On 9/7/16 1:16 PM, Sarah Bird - Continuum wrote:

Hi Reuben,

I believe this is a bug because there isn’t a draw_legend method for vbar/hbar.

I noticed this just the other day and forgot. Can you open an issue?

It will be very easy to fix.

Best,

Bird

On 9/7/16 11:39 AM, Reuben Jacobs wrote:

Here is what my chart and it’s legend look like currently:

As you can see the associated colors are not in the legend…

On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben Jacobs wrote:
Hi,

I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?

Thanks,
Reuben

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


Sarah Bird
Developer, Bokeh


Sarah Bird
Developer, Bokeh


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f695d5a-785d-4216-9816-f3786a3ddd20%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f0efd8e-f7ec-428b-98bd-48688f13676c%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/50ad7a37-136b-4d08-9771-edbe0db25873%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/bb755aab-acf2-4e75-b27d-ce61c9202ed8%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Ah, you have to do as

  export BOKEH_MINIFIED=no

to make the setting "permanent". Otherwise, without "export", the settings only affect the single command line they are on (which in this case do nothing else).

Alternatively, if you don't want the settings to be permanent, you can do everything on one line as I demonstrated earlier.

Thanks,

Bryan

···

On Sep 8, 2016, at 12:22 PM, Reuben Jacobs <[email protected]> wrote:

I am running Bash (stock terminal) on linux mint. I was trying to set the env vars as follows:

BOKEH\_MINIFIED=no BOKEH_RESOURCES=inline
$ python foo.py

Running it all on one lien fixed my issue. The js is now not minified when I start my app. I opened the source and indeed found

VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {
    return this._generic_area_legend(ctx, x0, x1, y0, y1, index);
}

around line 14.4k. However, the legend still does not appear with color in my plot.

Reuben

On Thursday, September 8, 2016 at 12:22:35 PM UTC-4, Bryan Van de ven wrote:
What platform are you on? How are you setting the env vars? I run things like this:

    $ BOKEH_MINIFIED=no BOKEH_RESOURCES=inline python foo.py

on bash/zsh

Bryan

> On Sep 8, 2016, at 10:52 AM, Reuben Jacobs <[email protected]> wrote:
>
> I added both env vars and verified they existed before rebuilding and reinstalling. I then rebuilt BokehJS and reinstalled selecting option 2 (install last built BokehJS from bokeh/bokehjs/build"). I then launched my application and viewed the vbar plot on the page without colors in the legend. I hit ctrl+u in chrome to view the page source (the page with my vbar plot on it) and searched for "VBarView" which returned no results. It seems like to me the page source is still somewhat minified code. Maybe these env vars are not taking effect for some reason?
>
> Thanks,
> Reuben
>
> On Thursday, September 8, 2016 at 11:29:01 AM UTC-4, Bryan Van de ven wrote:
> So the change in vbar.js does not actually matter, can you also add BOKEH_MINIFIED=no to the other env var I mentioned, and then verify that the changes are in the inline JS in the HTML page souce (e.g. by searching for "VBarView.prototype.draw_legend_for_index")?
>
> Thanks,
>
> Bryan
>
>
> > On Sep 8, 2016, at 10:15 AM, Reuben Jacobs <[email protected]> wrote:
> >
> > Never installed option 1. I followed all the instructions to the letter including isntalling npm and all dependencies needed with npm. I made my change in BokehJS, built bokeh JS locally, and I see the changes reflected in the built js file in "dist-packages/bokeh/" after installing. However, the changes do not seem to be doing anything when I create the plot.
> >
> > On Thursday, September 8, 2016 at 11:11:43 AM UTC-4, Bryan Van de ven wrote:
> > Did you previously select option 1? The changes are in BokehJS so BokehJS has to be rebuilt locally for you to see them take effect. You'd need to have installed npm, run "npm install" in the bokehjs subdir first.
> >
> > Thanks,
> >
> > Bryan
> >
> >
> > > On Sep 8, 2016, at 10:09 AM, Reuben Jacobs <[email protected]> wrote:
> > >
> > > Bryan,
> > >
> > > Upon installation of bokeh (running "python setup.py install) I selected the option "2) install last built BokehJS from bokeh/bokehjs/build"
> > >
> > > I just exported `BOKEH_RESOURCES=inline` and uninstalled and reinstalled bokeh selecting that option, but this issue is still occurring.
> > >
> > > Reuben
> > >
> > > On Thursday, September 8, 2016 at 10:49:27 AM UTC-4, Bryan Van de ven wrote:
> > > You'll need to set the environment variable `BOKEH_RESOURCES=inline` to pick up your locally built BokehJS, otherwise it will try to use the last released BokehJS from CDN.
> > >
> > > Thanks,
> > >
> > > Bryan
> > >
> > > > On Sep 8, 2016, at 9:36 AM, Reuben Jacobs <[email protected]> wrote:
> > > >
> > > > Hi Sarah,
> > > >
> > > > So I made your changes in a local bokeh repo and then built the package from that repo. I verify that in my python's new version of bokeh (built) I see the line of code :
> > > >
> > > > VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {
> > > > return this._generic_area_legend(ctx, x0, x1, y0, y1, index);
> > > > };
> > > >
> > > >
> > > > within "/usr/local/lib/python2.7/dist-packages/bokeh/server/static/js/tree/models/glyphs/vbar.js". However, even with this code in my version of bokeh, my vbar plot still has no colors in the legend.
> > > >
> > > > Any thoughts?
> > > >
> > > > Thanks,
> > > > Reuben
> > > >
> > > > On Thursday, September 8, 2016 at 9:30:14 AM UTC-4, Reuben Jacobs wrote:
> > > > Sarah,
> > > >
> > > > Thank you so much! I was going to open an issue today as I was fairly busy yesterday, but you beat me to it! I think I will make these changes in my local bokeh for the time being.
> > > >
> > > > Thanks again,
> > > > Reuben
> > > >
> > > > On Thursday, September 8, 2016 at 2:01:18 AM UTC-4, Sarah Bird wrote:
> > > > I opened an issue and submitted a PR fixing it: https://github.com/bokeh/bokeh/pull/5114
> > > >
> > > >
> > > > On 9/7/16 1:16 PM, Sarah Bird - Continuum wrote:
> > > >> Hi Reuben,
> > > >>
> > > >> I believe this is a bug because there isn't a draw_legend method for vbar/hbar.
> > > >>
> > > >> I noticed this just the other day and forgot. Can you open an issue?
> > > >>
> > > >> It will be very easy to fix.
> > > >>
> > > >> Best,
> > > >>
> > > >> Bird
> > > >>
> > > >> On 9/7/16 11:39 AM, Reuben Jacobs wrote:
> > > >>> Here is what my chart and it's legend look like currently:
> > > >>>
> > > >>> As you can see the associated colors are not in the legend..
> > > >>>
> > > >>>
> > > >>>
> > > >>>
> > > >>> On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben Jacobs wrote:
> > > >>> Hi,
> > > >>>
> > > >>> I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?
> > > >>>
> > > >>> Thanks,
> > > >>> Reuben
> > > >>> --
> > > >>> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > > >>> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> > > >>> To post to this group, send email to [email protected].
> > > >>> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io.
> > > >>> For more options, visit https://groups.google.com/a/continuum.io/d/optout.
> > > >>
> > > >> --
> > > >> Sarah Bird
> > > >> Developer, Bokeh
> > > >>
> > > >>
> > > >>
> > > >
> > > > --
> > > > Sarah Bird
> > > > Developer, Bokeh
> > > >
> > > >
> > > >
> > > >
> > > > --
> > > > You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > > > To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> > > > To post to this group, send email to [email protected].
> > > > To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f695d5a-785d-4216-9816-f3786a3ddd20%40continuum.io.
> > > > For more options, visit https://groups.google.com/a/continuum.io/d/optout.
> > >
> > >
> > > --
> > > You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > > To unsubscribe from this group and stop receiving emails from it, send an email to bokeh+un[email protected].
> > > To post to this group, send email to [email protected].
> > > To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f0efd8e-f7ec-428b-98bd-48688f13676c%40continuum.io.
> > > For more options, visit https://groups.google.com/a/continuum.io/d/optout.
> >
> >
> > --
> > You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> > To post to this group, send email to [email protected].
> > To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/50ad7a37-136b-4d08-9771-edbe0db25873%40continuum.io.
> > For more options, visit https://groups.google.com/a/continuum.io/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/bb755aab-acf2-4e75-b27d-ce61c9202ed8%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/b0d47f53-8ce3-4d39-96c5-9c68b38a5dcf%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Bryan,

I did it as a one liner and the settings worked. I also see the relevant code in inspect source on chrome, but the legend is still not updated with color.

Reuben

···

On Thursday, September 8, 2016 at 1:39:14 PM UTC-4, Bryan Van de ven wrote:

Ah, you have to do as

    export BOKEH_MINIFIED=no

to make the setting “permanent”. Otherwise, without “export”, the settings only affect the single command line they are on (which in this case do nothing else).

Alternatively, if you don’t want the settings to be permanent, you can do everything on one line as I demonstrated earlier.

Thanks,

Bryan

On Sep 8, 2016, at 12:22 PM, Reuben Jacobs [email protected] wrote:

I am running Bash (stock terminal) on linux mint. I was trying to set the env vars as follows:

$ BOKEH_MINIFIED=no

$ BOKEH_RESOURCES=inline

$ python foo.py

Running it all on one lien fixed my issue. The js is now not minified when I start my app. I opened the source and indeed found

VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {

return this._generic_area_legend(ctx, x0, x1, y0, y1, index);

}

around line 14.4k. However, the legend still does not appear with color in my plot.

Reuben

On Thursday, September 8, 2016 at 12:22:35 PM UTC-4, Bryan Van de ven wrote:

What platform are you on? How are you setting the env vars? I run things like this:

$ BOKEH_MINIFIED=no BOKEH_RESOURCES=inline python foo.py

on bash/zsh

Bryan

On Sep 8, 2016, at 10:52 AM, Reuben Jacobs [email protected] wrote:

I added both env vars and verified they existed before rebuilding and reinstalling. I then rebuilt BokehJS and reinstalled selecting option 2 (install last built BokehJS from bokeh/bokehjs/build"). I then launched my application and viewed the vbar plot on the page without colors in the legend. I hit ctrl+u in chrome to view the page source (the page with my vbar plot on it) and searched for “VBarView” which returned no results. It seems like to me the page source is still somewhat minified code. Maybe these env vars are not taking effect for some reason?

Thanks,
Reuben

On Thursday, September 8, 2016 at 11:29:01 AM UTC-4, Bryan Van de ven wrote:
So the change in vbar.js does not actually matter, can you also add BOKEH_MINIFIED=no to the other env var I mentioned, and then verify that the changes are in the inline JS in the HTML page souce (e.g. by searching for “VBarView.prototype.draw_legend_for_index”)?

Thanks,

Bryan

On Sep 8, 2016, at 10:15 AM, Reuben Jacobs [email protected] wrote:

Never installed option 1. I followed all the instructions to the letter including isntalling npm and all dependencies needed with npm. I made my change in BokehJS, built bokeh JS locally, and I see the changes reflected in the built js file in “dist-packages/bokeh/” after installing. However, the changes do not seem to be doing anything when I create the plot.

On Thursday, September 8, 2016 at 11:11:43 AM UTC-4, Bryan Van de ven wrote:
Did you previously select option 1? The changes are in BokehJS so BokehJS has to be rebuilt locally for you to see them take effect. You’d need to have installed npm, run “npm install” in the bokehjs subdir first.

Thanks,

Bryan

On Sep 8, 2016, at 10:09 AM, Reuben Jacobs [email protected] wrote:

Bryan,

Upon installation of bokeh (running "python setup.py install) I selected the option “2) install last built BokehJS from bokeh/bokehjs/build”

I just exported BOKEH_RESOURCES=inline and uninstalled and reinstalled bokeh selecting that option, but this issue is still occurring.

Reuben

On Thursday, September 8, 2016 at 10:49:27 AM UTC-4, Bryan Van de ven wrote:
You’ll need to set the environment variable BOKEH_RESOURCES=inline to pick up your locally built BokehJS, otherwise it will try to use the last released BokehJS from CDN.

Thanks,

Bryan

On Sep 8, 2016, at 9:36 AM, Reuben Jacobs [email protected] wrote:

Hi Sarah,

So I made your changes in a local bokeh repo and then built the package from that repo. I verify that in my python’s new version of bokeh (built) I see the line of code :

VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {
return this._generic_area_legend(ctx, x0, x1, y0, y1, index);
};

within “/usr/local/lib/python2.7/dist-packages/bokeh/server/static/js/tree/models/glyphs/vbar.js”. However, even with this code in my version of bokeh, my vbar plot still has no colors in the legend.

Any thoughts?

Thanks,
Reuben

On Thursday, September 8, 2016 at 9:30:14 AM UTC-4, Reuben Jacobs wrote:
Sarah,

Thank you so much! I was going to open an issue today as I was fairly busy yesterday, but you beat me to it! I think I will make these changes in my local bokeh for the time being.

Thanks again,
Reuben

On Thursday, September 8, 2016 at 2:01:18 AM UTC-4, Sarah Bird wrote:
I opened an issue and submitted a PR fixing it: https://github.com/bokeh/bokeh/pull/5114

On 9/7/16 1:16 PM, Sarah Bird - Continuum wrote:

Hi Reuben,

I believe this is a bug because there isn’t a draw_legend method for vbar/hbar.

I noticed this just the other day and forgot. Can you open an issue?

It will be very easy to fix.

Best,

Bird

On 9/7/16 11:39 AM, Reuben Jacobs wrote:

Here is what my chart and it’s legend look like currently:

As you can see the associated colors are not in the legend…

On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben Jacobs wrote:
Hi,

I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?

Thanks,
Reuben

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


Sarah Bird
Developer, Bokeh


Sarah Bird
Developer, Bokeh


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f695d5a-785d-4216-9816-f3786a3ddd20%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f0efd8e-f7ec-428b-98bd-48688f13676c%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/50ad7a37-136b-4d08-9771-edbe0db25873%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/bb755aab-acf2-4e75-b27d-ce61c9202ed8%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/b0d47f53-8ce3-4d39-96c5-9c68b38a5dcf%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Consider this solved. I pulled down from master and rebuilt and installed and that fixed the issue. Originally I was checking out the tag 0.12.2 and adding Sarah’s fix and then building and installing. Apparently I needed to checkout master for this to work.

Thanks,

Reuben

···

On Thursday, September 8, 2016 at 1:49:21 PM UTC-4, Reuben Jacobs wrote:

Bryan,

I did it as a one liner and the settings worked. I also see the relevant code in inspect source on chrome, but the legend is still not updated with color.

Reuben

On Thursday, September 8, 2016 at 1:39:14 PM UTC-4, Bryan Van de ven wrote:

Ah, you have to do as

    export BOKEH_MINIFIED=no

to make the setting “permanent”. Otherwise, without “export”, the settings only affect the single command line they are on (which in this case do nothing else).

Alternatively, if you don’t want the settings to be permanent, you can do everything on one line as I demonstrated earlier.

Thanks,

Bryan

On Sep 8, 2016, at 12:22 PM, Reuben Jacobs [email protected] wrote:

I am running Bash (stock terminal) on linux mint. I was trying to set the env vars as follows:

$ BOKEH_MINIFIED=no

$ BOKEH_RESOURCES=inline

$ python foo.py

Running it all on one lien fixed my issue. The js is now not minified when I start my app. I opened the source and indeed found

VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {

return this._generic_area_legend(ctx, x0, x1, y0, y1, index);

}

around line 14.4k. However, the legend still does not appear with color in my plot.

Reuben

On Thursday, September 8, 2016 at 12:22:35 PM UTC-4, Bryan Van de ven wrote:

What platform are you on? How are you setting the env vars? I run things like this:

$ BOKEH_MINIFIED=no BOKEH_RESOURCES=inline python foo.py

on bash/zsh

Bryan

On Sep 8, 2016, at 10:52 AM, Reuben Jacobs [email protected] wrote:

I added both env vars and verified they existed before rebuilding and reinstalling. I then rebuilt BokehJS and reinstalled selecting option 2 (install last built BokehJS from bokeh/bokehjs/build"). I then launched my application and viewed the vbar plot on the page without colors in the legend. I hit ctrl+u in chrome to view the page source (the page with my vbar plot on it) and searched for “VBarView” which returned no results. It seems like to me the page source is still somewhat minified code. Maybe these env vars are not taking effect for some reason?

Thanks,
Reuben

On Thursday, September 8, 2016 at 11:29:01 AM UTC-4, Bryan Van de ven wrote:
So the change in vbar.js does not actually matter, can you also add BOKEH_MINIFIED=no to the other env var I mentioned, and then verify that the changes are in the inline JS in the HTML page souce (e.g. by searching for “VBarView.prototype.draw_legend_for_index”)?

Thanks,

Bryan

On Sep 8, 2016, at 10:15 AM, Reuben Jacobs [email protected] wrote:

Never installed option 1. I followed all the instructions to the letter including isntalling npm and all dependencies needed with npm. I made my change in BokehJS, built bokeh JS locally, and I see the changes reflected in the built js file in “dist-packages/bokeh/” after installing. However, the changes do not seem to be doing anything when I create the plot.

On Thursday, September 8, 2016 at 11:11:43 AM UTC-4, Bryan Van de ven wrote:
Did you previously select option 1? The changes are in BokehJS so BokehJS has to be rebuilt locally for you to see them take effect. You’d need to have installed npm, run “npm install” in the bokehjs subdir first.

Thanks,

Bryan

On Sep 8, 2016, at 10:09 AM, Reuben Jacobs [email protected] wrote:

Bryan,

Upon installation of bokeh (running "python setup.py install) I selected the option “2) install last built BokehJS from bokeh/bokehjs/build”

I just exported BOKEH_RESOURCES=inline and uninstalled and reinstalled bokeh selecting that option, but this issue is still occurring.

Reuben

On Thursday, September 8, 2016 at 10:49:27 AM UTC-4, Bryan Van de ven wrote:
You’ll need to set the environment variable BOKEH_RESOURCES=inline to pick up your locally built BokehJS, otherwise it will try to use the last released BokehJS from CDN.

Thanks,

Bryan

On Sep 8, 2016, at 9:36 AM, Reuben Jacobs [email protected] wrote:

Hi Sarah,

So I made your changes in a local bokeh repo and then built the package from that repo. I verify that in my python’s new version of bokeh (built) I see the line of code :

VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {
return this._generic_area_legend(ctx, x0, x1, y0, y1, index);
};

within “/usr/local/lib/python2.7/dist-packages/bokeh/server/static/js/tree/models/glyphs/vbar.js”. However, even with this code in my version of bokeh, my vbar plot still has no colors in the legend.

Any thoughts?

Thanks,
Reuben

On Thursday, September 8, 2016 at 9:30:14 AM UTC-4, Reuben Jacobs wrote:
Sarah,

Thank you so much! I was going to open an issue today as I was fairly busy yesterday, but you beat me to it! I think I will make these changes in my local bokeh for the time being.

Thanks again,
Reuben

On Thursday, September 8, 2016 at 2:01:18 AM UTC-4, Sarah Bird wrote:
I opened an issue and submitted a PR fixing it: https://github.com/bokeh/bokeh/pull/5114

On 9/7/16 1:16 PM, Sarah Bird - Continuum wrote:

Hi Reuben,

I believe this is a bug because there isn’t a draw_legend method for vbar/hbar.

I noticed this just the other day and forgot. Can you open an issue?

It will be very easy to fix.

Best,

Bird

On 9/7/16 11:39 AM, Reuben Jacobs wrote:

Here is what my chart and it’s legend look like currently:

As you can see the associated colors are not in the legend…

On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben Jacobs wrote:
Hi,

I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?

Thanks,
Reuben

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


Sarah Bird
Developer, Bokeh


Sarah Bird
Developer, Bokeh


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f695d5a-785d-4216-9816-f3786a3ddd20%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f0efd8e-f7ec-428b-98bd-48688f13676c%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/50ad7a37-136b-4d08-9771-edbe0db25873%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/bb755aab-acf2-4e75-b27d-ce61c9202ed8%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/b0d47f53-8ce3-4d39-96c5-9c68b38a5dcf%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Ah, yes this morning you would have had to also check out the PR branch, but I merged it to master a few hours ago. Gal it works for you! There should be a 0.12.3 in a few weeks, and dev builds next week.

Thanks,

Bryan

···

On Sep 8, 2016, at 12:52 PM, Reuben Jacobs <[email protected]> wrote:

Consider this solved. I pulled down from master and rebuilt and installed and that fixed the issue. Originally I was checking out the tag 0.12.2 and adding Sarah's fix and then building and installing. Apparently I needed to checkout master for this to work.

Thanks,
Reuben

On Thursday, September 8, 2016 at 1:49:21 PM UTC-4, Reuben Jacobs wrote:
Bryan,

I did it as a one liner and the settings worked. I also see the relevant code in inspect source on chrome, but the legend is still not updated with color.

Reuben

On Thursday, September 8, 2016 at 1:39:14 PM UTC-4, Bryan Van de ven wrote:
Ah, you have to do as

        export BOKEH_MINIFIED=no

to make the setting "permanent". Otherwise, without "export", the settings only affect the single command line they are on (which in this case do nothing else).

Alternatively, if you don't want the settings to be permanent, you can do everything on one line as I demonstrated earlier.

Thanks,

Bryan

> On Sep 8, 2016, at 12:22 PM, Reuben Jacobs <[email protected]> wrote:
>
> I am running Bash (stock terminal) on linux mint. I was trying to set the env vars as follows:
>
> BOKEH\_MINIFIED=no &gt; BOKEH_RESOURCES=inline
> python foo\.py &gt; &gt; Running it all on one lien fixed my issue\. The js is now not minified when I start my app\. I opened the source and indeed found &gt; &gt; VBarView\.prototype\.draw\_legend\_for\_index = function\(ctx, x0, x1, y0, y1, index\) \{ &gt; return this\.\_generic\_area\_legend\(ctx, x0, x1, y0, y1, index\); &gt; \} &gt; &gt; around line 14\.4k\. However, the legend still does not appear with color in my plot\. &gt; &gt; Reuben &gt; &gt; On Thursday, September 8, 2016 at 12:22:35 PM UTC\-4, Bryan Van de ven wrote: &gt; What platform are you on? How are you setting the env vars? I run things like this: &gt; &gt; BOKEH_MINIFIED=no BOKEH_RESOURCES=inline python foo.py
>
> on bash/zsh
>
> Bryan
>
> > On Sep 8, 2016, at 10:52 AM, Reuben Jacobs <[email protected]> wrote:
> >
> > I added both env vars and verified they existed before rebuilding and reinstalling. I then rebuilt BokehJS and reinstalled selecting option 2 (install last built BokehJS from bokeh/bokehjs/build"). I then launched my application and viewed the vbar plot on the page without colors in the legend. I hit ctrl+u in chrome to view the page source (the page with my vbar plot on it) and searched for "VBarView" which returned no results. It seems like to me the page source is still somewhat minified code. Maybe these env vars are not taking effect for some reason?
> >
> > Thanks,
> > Reuben
> >
> > On Thursday, September 8, 2016 at 11:29:01 AM UTC-4, Bryan Van de ven wrote:
> > So the change in vbar.js does not actually matter, can you also add BOKEH_MINIFIED=no to the other env var I mentioned, and then verify that the changes are in the inline JS in the HTML page souce (e.g. by searching for "VBarView.prototype.draw_legend_for_index")?
> >
> > Thanks,
> >
> > Bryan
> >
> >
> > > On Sep 8, 2016, at 10:15 AM, Reuben Jacobs <[email protected]> wrote:
> > >
> > > Never installed option 1. I followed all the instructions to the letter including isntalling npm and all dependencies needed with npm. I made my change in BokehJS, built bokeh JS locally, and I see the changes reflected in the built js file in "dist-packages/bokeh/" after installing. However, the changes do not seem to be doing anything when I create the plot.
> > >
> > > On Thursday, September 8, 2016 at 11:11:43 AM UTC-4, Bryan Van de ven wrote:
> > > Did you previously select option 1? The changes are in BokehJS so BokehJS has to be rebuilt locally for you to see them take effect. You'd need to have installed npm, run "npm install" in the bokehjs subdir first.
> > >
> > > Thanks,
> > >
> > > Bryan
> > >
> > >
> > > > On Sep 8, 2016, at 10:09 AM, Reuben Jacobs <[email protected]> wrote:
> > > >
> > > > Bryan,
> > > >
> > > > Upon installation of bokeh (running "python setup.py install) I selected the option "2) install last built BokehJS from bokeh/bokehjs/build"
> > > >
> > > > I just exported `BOKEH_RESOURCES=inline` and uninstalled and reinstalled bokeh selecting that option, but this issue is still occurring.
> > > >
> > > > Reuben
> > > >
> > > > On Thursday, September 8, 2016 at 10:49:27 AM UTC-4, Bryan Van de ven wrote:
> > > > You'll need to set the environment variable `BOKEH_RESOURCES=inline` to pick up your locally built BokehJS, otherwise it will try to use the last released BokehJS from CDN.
> > > >
> > > > Thanks,
> > > >
> > > > Bryan
> > > >
> > > > > On Sep 8, 2016, at 9:36 AM, Reuben Jacobs <[email protected]> wrote:
> > > > >
> > > > > Hi Sarah,
> > > > >
> > > > > So I made your changes in a local bokeh repo and then built the package from that repo. I verify that in my python's new version of bokeh (built) I see the line of code :
> > > > >
> > > > > VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {
> > > > > return this._generic_area_legend(ctx, x0, x1, y0, y1, index);
> > > > > };
> > > > >
> > > > >
> > > > > within "/usr/local/lib/python2.7/dist-packages/bokeh/server/static/js/tree/models/glyphs/vbar.js". However, even with this code in my version of bokeh, my vbar plot still has no colors in the legend.
> > > > >
> > > > > Any thoughts?
> > > > >
> > > > > Thanks,
> > > > > Reuben
> > > > >
> > > > > On Thursday, September 8, 2016 at 9:30:14 AM UTC-4, Reuben Jacobs wrote:
> > > > > Sarah,
> > > > >
> > > > > Thank you so much! I was going to open an issue today as I was fairly busy yesterday, but you beat me to it! I think I will make these changes in my local bokeh for the time being.
> > > > >
> > > > > Thanks again,
> > > > > Reuben
> > > > >
> > > > > On Thursday, September 8, 2016 at 2:01:18 AM UTC-4, Sarah Bird wrote:
> > > > > I opened an issue and submitted a PR fixing it: https://github.com/bokeh/bokeh/pull/5114
> > > > >
> > > > >
> > > > > On 9/7/16 1:16 PM, Sarah Bird - Continuum wrote:
> > > > >> Hi Reuben,
> > > > >>
> > > > >> I believe this is a bug because there isn't a draw_legend method for vbar/hbar.
> > > > >>
> > > > >> I noticed this just the other day and forgot. Can you open an issue?
> > > > >>
> > > > >> It will be very easy to fix.
> > > > >>
> > > > >> Best,
> > > > >>
> > > > >> Bird
> > > > >>
> > > > >> On 9/7/16 11:39 AM, Reuben Jacobs wrote:
> > > > >>> Here is what my chart and it's legend look like currently:
> > > > >>>
> > > > >>> As you can see the associated colors are not in the legend..
> > > > >>>
> > > > >>>
> > > > >>>
> > > > >>>
> > > > >>> On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben Jacobs wrote:
> > > > >>> Hi,
> > > > >>>
> > > > >>> I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?
> > > > >>>
> > > > >>> Thanks,
> > > > >>> Reuben
> > > > >>> --
> > > > >>> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > > > >>> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> > > > >>> To post to this group, send email to [email protected].
> > > > >>> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io.
> > > > >>> For more options, visit https://groups.google.com/a/continuum.io/d/optout.
> > > > >>
> > > > >> --
> > > > >> Sarah Bird
> > > > >> Developer, Bokeh
> > > > >>
> > > > >>
> > > > >>
> > > > >
> > > > > --
> > > > > Sarah Bird
> > > > > Developer, Bokeh
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > --
> > > > > You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > > > > To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> > > > > To post to this group, send email to [email protected].
> > > > > To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f695d5a-785d-4216-9816-f3786a3ddd20%40continuum.io.
> > > > > For more options, visit https://groups.google.com/a/continuum.io/d/optout.
> > > >
> > > >
> > > > --
> > > > You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > > > To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> > > > To post to this group, send email to [email protected].
> > > > To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f0efd8e-f7ec-428b-98bd-48688f13676c%40continuum.io.
> > > > For more options, visit https://groups.google.com/a/continuum.io/d/optout.
> > >
> > >
> > > --
> > > You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > > To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> > > To post to this group, send email to [email protected].
> > > To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/50ad7a37-136b-4d08-9771-edbe0db25873%40continuum.io.
> > > For more options, visit https://groups.google.com/a/continuum.io/d/optout.
> >
> >
> > --
> > You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> > To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> > To post to this group, send email to [email protected].
> > To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/bb755aab-acf2-4e75-b27d-ce61c9202ed8%40continuum.io.
> > For more options, visit https://groups.google.com/a/continuum.io/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
> To post to this group, send email to [email protected].
> To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/b0d47f53-8ce3-4d39-96c5-9c68b38a5dcf%40continuum.io.
> For more options, visit https://groups.google.com/a/continuum.io/d/optout.

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/676d7370-1a70-49ab-a5e1-0f46b6571163%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

Makes sense. Actually, building from master made the colors works in the legends, but it broke the hit testing on the vbars! The hover tooltips stopped working.

···

On Thursday, September 8, 2016 at 1:54:42 PM UTC-4, Bryan Van de ven wrote:

Ah, yes this morning you would have had to also check out the PR branch, but I merged it to master a few hours ago. Gal it works for you! There should be a 0.12.3 in a few weeks, and dev builds next week.

Thanks,

Bryan

On Sep 8, 2016, at 12:52 PM, Reuben Jacobs [email protected] wrote:

Consider this solved. I pulled down from master and rebuilt and installed and that fixed the issue. Originally I was checking out the tag 0.12.2 and adding Sarah’s fix and then building and installing. Apparently I needed to checkout master for this to work.

Thanks,

Reuben

On Thursday, September 8, 2016 at 1:49:21 PM UTC-4, Reuben Jacobs wrote:

Bryan,

I did it as a one liner and the settings worked. I also see the relevant code in inspect source on chrome, but the legend is still not updated with color.

Reuben

On Thursday, September 8, 2016 at 1:39:14 PM UTC-4, Bryan Van de ven wrote:

Ah, you have to do as

    export BOKEH_MINIFIED=no

to make the setting “permanent”. Otherwise, without “export”, the settings only affect the single command line they are on (which in this case do nothing else).

Alternatively, if you don’t want the settings to be permanent, you can do everything on one line as I demonstrated earlier.

Thanks,

Bryan

On Sep 8, 2016, at 12:22 PM, Reuben Jacobs [email protected] wrote:

I am running Bash (stock terminal) on linux mint. I was trying to set the env vars as follows:

BOKEH_MINIFIED=no BOKEH_RESOURCES=inline
$ python foo.py

Running it all on one lien fixed my issue. The js is now not minified when I start my app. I opened the source and indeed found

VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {
return this._generic_area_legend(ctx, x0, x1, y0, y1, index);
}

around line 14.4k. However, the legend still does not appear with color in my plot.

Reuben

On Thursday, September 8, 2016 at 12:22:35 PM UTC-4, Bryan Van de ven wrote:
What platform are you on? How are you setting the env vars? I run things like this:

$ BOKEH_MINIFIED=no BOKEH_RESOURCES=inline python foo.py

on bash/zsh

Bryan

On Sep 8, 2016, at 10:52 AM, Reuben Jacobs [email protected] wrote:

I added both env vars and verified they existed before rebuilding and reinstalling. I then rebuilt BokehJS and reinstalled selecting option 2 (install last built BokehJS from bokeh/bokehjs/build"). I then launched my application and viewed the vbar plot on the page without colors in the legend. I hit ctrl+u in chrome to view the page source (the page with my vbar plot on it) and searched for “VBarView” which returned no results. It seems like to me the page source is still somewhat minified code. Maybe these env vars are not taking effect for some reason?

Thanks,
Reuben

On Thursday, September 8, 2016 at 11:29:01 AM UTC-4, Bryan Van de ven wrote:
So the change in vbar.js does not actually matter, can you also add BOKEH_MINIFIED=no to the other env var I mentioned, and then verify that the changes are in the inline JS in the HTML page souce (e.g. by searching for “VBarView.prototype.draw_legend_for_index”)?

Thanks,

Bryan

On Sep 8, 2016, at 10:15 AM, Reuben Jacobs [email protected] wrote:

Never installed option 1. I followed all the instructions to the letter including isntalling npm and all dependencies needed with npm. I made my change in BokehJS, built bokeh JS locally, and I see the changes reflected in the built js file in “dist-packages/bokeh/” after installing. However, the changes do not seem to be doing anything when I create the plot.

On Thursday, September 8, 2016 at 11:11:43 AM UTC-4, Bryan Van de ven wrote:
Did you previously select option 1? The changes are in BokehJS so BokehJS has to be rebuilt locally for you to see them take effect. You’d need to have installed npm, run “npm install” in the bokehjs subdir first.

Thanks,

Bryan

On Sep 8, 2016, at 10:09 AM, Reuben Jacobs [email protected] wrote:

Bryan,

Upon installation of bokeh (running "python setup.py install) I selected the option “2) install last built BokehJS from bokeh/bokehjs/build”

I just exported BOKEH_RESOURCES=inline and uninstalled and reinstalled bokeh selecting that option, but this issue is still occurring.

Reuben

On Thursday, September 8, 2016 at 10:49:27 AM UTC-4, Bryan Van de ven wrote:
You’ll need to set the environment variable BOKEH_RESOURCES=inline to pick up your locally built BokehJS, otherwise it will try to use the last released BokehJS from CDN.

Thanks,

Bryan

On Sep 8, 2016, at 9:36 AM, Reuben Jacobs [email protected] wrote:

Hi Sarah,

So I made your changes in a local bokeh repo and then built the package from that repo. I verify that in my python’s new version of bokeh (built) I see the line of code :

VBarView.prototype.draw_legend_for_index = function(ctx, x0, x1, y0, y1, index) {
return this._generic_area_legend(ctx, x0, x1, y0, y1, index);
};

within “/usr/local/lib/python2.7/dist-packages/bokeh/server/static/js/tree/models/glyphs/vbar.js”. However, even with this code in my version of bokeh, my vbar plot still has no colors in the legend.

Any thoughts?

Thanks,
Reuben

On Thursday, September 8, 2016 at 9:30:14 AM UTC-4, Reuben Jacobs wrote:
Sarah,

Thank you so much! I was going to open an issue today as I was fairly busy yesterday, but you beat me to it! I think I will make these changes in my local bokeh for the time being.

Thanks again,
Reuben

On Thursday, September 8, 2016 at 2:01:18 AM UTC-4, Sarah Bird wrote:
I opened an issue and submitted a PR fixing it: https://github.com/bokeh/bokeh/pull/5114

On 9/7/16 1:16 PM, Sarah Bird - Continuum wrote:

Hi Reuben,

I believe this is a bug because there isn’t a draw_legend method for vbar/hbar.

I noticed this just the other day and forgot. Can you open an issue?

It will be very easy to fix.

Best,

Bird

On 9/7/16 11:39 AM, Reuben Jacobs wrote:

Here is what my chart and it’s legend look like currently:

As you can see the associated colors are not in the legend…

On Wednesday, September 7, 2016 at 11:37:21 AM UTC-4, Reuben Jacobs wrote:
Hi,

I was able to make a stacked bar chart with various hover tooltips using plotting and VBars. I also enabled a legend for the plot. However, my vbars are colored and the colors for each vbar (each stack) are not appearing in the legend. Only the names for the stack in the legend are appearing. Is this not an implemented feature yet?

Thanks,
Reuben

You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/a5beca2a-71e3-439b-a980-bd1d853ff9a6%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


Sarah Bird
Developer, Bokeh


Sarah Bird
Developer, Bokeh


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f695d5a-785d-4216-9816-f3786a3ddd20%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/8f0efd8e-f7ec-428b-98bd-48688f13676c%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/50ad7a37-136b-4d08-9771-edbe0db25873%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/bb755aab-acf2-4e75-b27d-ce61c9202ed8%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/b0d47f53-8ce3-4d39-96c5-9c68b38a5dcf%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.


You received this message because you are subscribed to the Google Groups “Bokeh Discussion - Public” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/676d7370-1a70-49ab-a5e1-0f46b6571163%40continuum.io.

For more options, visit https://groups.google.com/a/continuum.io/d/optout.