Version related issues for modules mismatch

I am trying to update bokeh version for latest our client project, its doesn’t work getting some issues. Previously used version is bokeh==2.2.3, python 3.4 and latest bokeh==3.4.1 and python 3.11

What are you trying to do?

In some cases, a screenshot of your plot will also be helpful.

It’s not possible to say anything at all with so little information, most especially without a complete Minimal Reproducible Example. All that I can do is refer you to the migration guides:

Actually I can state that the screenshot clearly shows you are trying to use BokehJS 2.2.3 with the Python Bokeh package version 3.4.2 and there is no chance that would ever work. There’s different ways that mismatch might occur but it’s not possible to speculate without more information.