Wheel-zoom not working?

I’m running bokeh 0.6.1.dev.20140923-np19py27_1 in an IPython notebook.

Holding down shift and zooming with the mouse wheel doesn’t work for me.

If I click on the “Wheel Zoom” button it works as expected.

Is this a known problem?

In [4]: print sys_info()

{‘commit_hash’: ‘a2e1c67’,

‘commit_source’: ‘installation’,

‘default_encoding’: ‘cp850’,

‘ipython_path’: ‘C:\dev\bin\Anaconda\lib\site-packages\IPython’,

‘ipython_version’: ‘3.0.0-dev’,

‘os_name’: ‘nt’,

‘platform’: ‘Windows-7-6.1.7601-SP1’,

‘sys_executable’: ‘C:\dev\bin\Anaconda\python.exe’,

‘sys_platform’: ‘win32’,

‘sys_version’: ‘2.7.5 |Anaconda 2.0.0 (64-bit)| (default, Jul 1 2013, 12:37:52) [MSC v.1500 64 bit (AMD64)]’}

Thanks,

Dave

I cannot reproduce this on OSX/Safari. Can you submit a GH issue? Any addition information (what browser, does it work on other browsers, does it work with IPython 2.x, etc.) would be very helpful.

Bryan

···

On Sep 24, 2014, at 8:58 AM, [email protected] wrote:

I'm running bokeh 0.6.1.dev.20140923-np19py27_1 in an IPython notebook.

Holding down shift and zooming with the mouse wheel doesn't work for me.

If I click on the "Wheel Zoom" button it works as expected.

Is this a known problem?

In [4]: print sys_info()
{'commit_hash': 'a2e1c67',
'commit_source': 'installation',
'default_encoding': 'cp850',
'ipython_path': 'C:\\dev\\bin\\Anaconda\\lib\\site-packages\\IPython',
'ipython_version': '3.0.0-dev',
'os_name': 'nt',
'platform': 'Windows-7-6.1.7601-SP1',
'sys_executable': 'C:\\dev\\bin\\Anaconda\\python.exe',
'sys_platform': 'win32',
'sys_version': '2.7.5 |Anaconda 2.0.0 (64-bit)| (default, Jul 1 2013, 12:37:52) [MSC v.1500 64 bit (AMD64)]'}

Thanks,
Dave

--
You received this message because you are subscribed to the Google Groups "Bokeh Discussion - Public" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit https://groups.google.com/a/continuum.io/d/msgid/bokeh/b0a06320-0419-4000-acda-136f111627c3%40continuum.io.
For more options, visit https://groups.google.com/a/continuum.io/d/optout.

It turns out that it does work in my FF 32.0.2 but fails in my chrome “37.0.2062.120 m”

I’d already opened an issue - https://github.com/ContinuumIO/bokeh/issues/1245

Feel free to close if it’s just a chrome bug.

This however led me to another observation which is the fact that the rendering, panning/zooming is much slower in FF than in chrome. In FF it’s quite painfully slow.

Thanks,

Dave

···

On Wednesday, 24 September 2014 14:44:17 UTC+1, Bryan Van de ven wrote:

I cannot reproduce this on OSX/Safari. Can you submit a GH issue? Any addition information (what browser, does it work on other browsers, does it work with IPython 2.x, etc.) would be very helpful.

Bryan

On Sep 24, 2014, at 8:58 AM, [email protected] wrote:

I’m running bokeh 0.6.1.dev.20140923-np19py27_1 in an IPython notebook.

Holding down shift and zooming with the mouse wheel doesn’t work for me.

If I click on the “Wheel Zoom” button it works as expected.

Is this a known problem?

In [4]: print sys_info()

{‘commit_hash’: ‘a2e1c67’,

‘commit_source’: ‘installation’,

‘default_encoding’: ‘cp850’,

‘ipython_path’: ‘C:\dev\bin\Anaconda\lib\site-packages\IPython’,

‘ipython_version’: ‘3.0.0-dev’,

‘os_name’: ‘nt’,

‘platform’: ‘Windows-7-6.1.7601-SP1’,

‘sys_executable’: ‘C:\dev\bin\Anaconda\python.exe’,

‘sys_platform’: ‘win32’,

‘sys_version’: ‘2.7.5 |Anaconda 2.0.0 (64-bit)| (default, Jul 1 2013, 12:37:52) [MSC v.1500 64 bit (AMD64)]’}

Thanks,

Dave