Azure and Bokeh integration

Hello, I am trying to integrate a Bokeh server into an Azure Web App. I originally found this old post (Host bokeh server on Microsoft Azure App Service) and tried to follow some of its guidance. There was also a tutorial linked in that discussion that helped me through most of the process. I’ve tried using containers and GitHub as the source code, but I’ve encountered the same issue in both cases. My Bokeh figures are not loading. The Bokeh logo appears at the top of the tab, indicating that it is running, and I don’t see any apparent errors on the Azure side, so I’m a little stumped. It seems like an error you would get with Bokeh when there is a minor issue that doesn’t stop the program but prevents the figures from generating properly. I’ve tested the container/image locally and haven’t had any issues. I followed the code provided in this tutorial:

I have tried running the Azure Web App with and without startup commands, but it seems to work better without them. I believe this is because the Dockerfile already includes the line “CMD [“bokeh”, “serve”, “–port”, “8000”, “–”, “”]” which performs the same function.

To be specific, my current setup involves building the Docker image, testing it locally, tagging it, pushing it to a DockerHub repository, and then setting up a Web App for Containers and pulling from that repository. Previously, I tried a normal Web App with GitHub, but encountered the same issue.

I am using Python 3.8, and since I import Bokeh, it’s possible that Azure is running newer versions of JavaScript, causing a mismatch. Upgrading to a newer version would be time-consuming, and I’m not even sure if that is the root cause of the issue. I was wondering if anyone has experience with this situation. I apologize for the lack of specifics, as I’m still new to Azure and unsure of what information would be most useful. I have included an image of what a loaded page looks like below. Thank you for any help you can provide.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.