Jupyter Notebook server example not showing in Windows

I am trying to run the example of embedding a Bokeh server in a Notebook but the app won’t show anywhere, no tab opening, no error. The notebook is running at the default URL (localhost:8888).

I am running Windows 10 / miniconda3. Python 3.8.5

bokeh                     2.3.3
jupyter_bokeh             3.0.2 
jupyter_client            6.1.12
jupyter_core              4.7.1
jupyter_server            1.4.1
jupyterlab                3.0.16
jupyterlab_pygments       0.1.2
jupyterlab_server         2.6.1
jupyterlab_widgets        1.0.0
notebook                  6.4.0
python                    3.8.5

Am I missing something? Or is this Bokeh server app example only for linux and not Windows? Other server examples using the ScriptHandler are working fine (e.g. the single module format example.)

Are there any messages or errors in the browser’s JavaScript console?

I don’t even know what that is. How can I bring it up?

I use Chrome.

It differs by both browser and by platform. I don’t typically use Windows, so I don’t actually know. You will need to do a google search for your specific setup.

For Chrome, you want “Developer Tools”:

1 Like

Thanks for that pointer. So here is what I get when I run the notebook. When I start the notebook, I get all the lines till DevTools failed to load source map (...).
The the next two lines are when I execute all the cells before the last one.
When I execute the last cell with show(bkapp), in the console I just get the last line with Bokeh items were rendered successfully, but nothing actually shows up.


I don’t have an answer for you [yet], but I strongly suspect that it’s to do with Jupyter rather than Bokeh. I just tested out the notebook to see if we didn’t catch a problem in a recent release, but it works like a charm in both Chrome and Firefox for me.

The “find-and-replace does not exist” error message seems suspicious to me, and was present on another unsolved (as far as this Discourse) notebook problem, as well as a similar issue involving Plotly that I found out on the greater internet.

I would start by trying a different browser and seeing what happens, at least to get more data.

I tried with Firefox but the outcome was the same as with Chrome. When I start the notebook, I get these errors. No other errors show in the console after I run all the cells but the app still won’t show anything just like in Chrome.

I’ll try from Linux and report back, but I need to make this work from Windows unfortunately.

Worked fine with Linux. Few warnings that are identical as on Windows Firefox. sorry about the French one earlier, not sure why it lost my localization in the middle of the other ones in English, but you have the same here in English with the linux firefox console.

If the messages don’t have “bokeh” somewhere in them, they are typically not coming from Bokeh (with very few exceptions). So, almost all the output above is not coming from Bokeh, and the ones that are from Bokeh look nominal / normal. I’ll have to see about getting a Windows VM set up this weekend to actually try to reproduce directly.

The only other thing I can suggest for now, just to collect another data point, is to try in the classic notebook instead of jupyterlab.

Ok. I have another Windows computer, i will try on it to provide another data point.
I tried both Jupyter lab and Jupyter Notebook. Same outcome.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.