Legend with networkx graph breaks plot

So following up with this post : (Legend in network graph), I ran into issues with including a legend when plotting a network graph. The code in that post serves as a minimal reproducible example:

import networkx as nx

from bokeh.io import  show
from bokeh.models import Legend, LegendItem
from bokeh.plotting import figure, from_networkx


p = figure(x_range=(-3,3), y_range=(-3,3))
p.grid.grid_line_color = None

r = from_networkx(G, nx.spring_layout, scale=3, center=(0,0))

legend = Legend(items=[
    LegendItem(label="orange", renderers=[r.node_renderer])])

Though indicated by @Bryan that it was working as expected, it no longer does so at this point in time for me (windows 10, chrome + firefox). For one the legend doesn’t include the colored glyph:

Second, when I drag (as you would with box select) any area on the graph, things go crazy and I get a kind of recursive zoom as shown in this pic:

The behaviour on firefox is different but still buggy.

@Han Your code is working perfectly as expected for me, with Bokeh 2.3.x (please always specify all relevant versions in every question) so my first suggestion would be to upgrade, if you are using an earlier version.

My bad! Had a fresh conda install so assumed it was the latest version. conda update bokeh wouldn’t update either, had to use the bokeh channel. Works now.

That’s really strange, AFAIK 2.3.2 has been in conda defaults for at least a week.